Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gruppen werden nicht richtig gesehen - Login.bat nach Gruppen funktioniert nicht

Frage Entwicklung Batch & Shell

Mitglied: bitnetworks

bitnetworks (Level 1) - Jetzt verbinden

01.10.2007, aktualisiert 21.11.2007, 5921 Aufrufe, 7 Kommentare

Hallo zusammen

Ich glaub ich bin kurz vorm durchdrehen. Ich probier nun schon seit einer Ewigkeit ein Loginscript anhand der Gruppenzugehörigkeit zu erstellen. Der Aufbau usw. des Skripts ist mir eigentlich klar, nur was meiner Meinung nach nicht funktioniert ist die Richtige Zuordnung in die Gruppe...
Wenn ich mit ifmember.exe /v /l eine abfrage mache in welcher Gruppe ich bin, bekomme ich folgendes Resultat zurück
01.
C:\Dokumente und Einstellungen\benutzer>\\DC1\NETLOGON\IFMEMBER.EXE /v /l 
02.
User is a member of group DomainZH\Domõnen-Benutzer. 
03.
User is a member of group \Jeder. 
04.
User is a member of group VORDEFINIERT\Administratoren. 
05.
User is a member of group VORDEFINIERT\Benutzer. 
06.
User is a member of group NT-AUTORIT?T\INTERAKTIV. 
07.
User is a member of group NT-AUTORIT?T\Authentifizierte Benutzer. 
08.
User is a member of group \LOKAL. 
09.
User is a member of group DomainZH\Domõnen-Admins.
Ich bin aber schon seit längerem in der Gruppe IT, welche hier nicht erscheint. Zudem habe ich heute Morgen eine Testgruppe gemacht, in welcher ich auch bin, die erscheint auch nicht.
Mach ich einen Überlegungsfehler oder läuft was auf meinem Server nicht ganz so wie es sollte?

Mein Login.bat sieht theoretisch so aus, ich poste hier nur eine verkürzte Version...:

01.
@ECHO OFF 
02.
 
03.
ECHO Anmeldescript läuft... 
04.
 
05.
REM ### Skripte nach Gruppenzugehörigkeit ausführen ### 
06.
\\fcwdc1\netlogon\ifmember DomainZH\it  
07.
if errorlevel 1 goto it 
08.
 
09.
goto END 
10.
 
11.
:it 
12.
NET USE x: /d >nul 
13.
NET USE x: \\DC1\it 
14.
goto END 
15.
 
16.
:END 
17.
Exit
Ein paar Details zu meinem System:
2x Win2003 Srv R2 (zwei Domänencontroller, DC1 & DC2)
ca. 20 Win XP Clients
eine Domäne, mehrere Gruppen & Benutzer

Kann mir jemand helfen bevor ich komplett durchdrehe? :D
Mitglied: Dani
01.10.2007 um 12:10 Uhr
Moin bitnetworks,
du schreibst, du hast 2 DC's im Netzwerk. Somit findet eine Replikation aller Objekte statt. Läuft diese auch ordnungsgemäß und erfolgreich ab??
Die Syntax ist bei dir richtig (hab's eben bei mir hier getestet .


Grüße
Dani
Bitte warten ..
Mitglied: bitnetworks
01.10.2007 um 13:09 Uhr
Hallo Dani

Der neue DC ist erst seit einer Woche in Betrieb, den hab ich aufgesetzt und in die Domäne genommen, den Rest hat er selbst synchonisiert. Da ich auch auf beiden DC im AD die Benutzer und Gruppen usw. sehe, nehme ich an das die Synchronisation richtig läuft.
Oder wie würdest du das noch überprüfen?

Gruss
Lia
Bitte warten ..
Mitglied: 48303
21.11.2007 um 11:49 Uhr
Hallo,

ich hänge mich jetzt mal an diesen Beitrag in der Hoffnung das ihn noch jemand findet.

Gab es hier eine Lösung. Ich habe momentan das gleiche Problem. Ich habe 4 DC, Replikation läuft neue Gruppen und User tauchen überall auf.
Nun zu dem Problem, in der Ausgabe von Ifmember /L erkenne ich nur Gruppen die bis vor einiger Zeit (unbekannt) angelegt wurden, alle neueren Gruppen von mir erkennt er (ifmember)nicht.

Die Berechtigung für einzelne Ordner in Laufwerken funktioniert aber mit diesen Gruppen.

Vielen Dank

Andi
Bitte warten ..
Mitglied: bitnetworks
21.11.2007 um 12:56 Uhr
Hy

Die Replikation funktioniert. Ich habs vor einigen Tagen rausgefunden, ich hatte lokale statt globale Gruppen. Wenn ich alles Global mach, dann klappts.

Gruss
Bitte warten ..
Mitglied: 48303
21.11.2007 um 16:27 Uhr
Hallo

danke für die schnelle Antwort "heul"

Ich habe nur Globale Gruppen, werd ich wohl weitersuchen müssen.

Danke

Gruss Andi
Bitte warten ..
Mitglied: bitnetworks
21.11.2007 um 16:52 Uhr
Hallo Andi

Wann hast du die Gruppen erstellt?
Ich hatte anfangs zu wenig geduld. Der Server braucht einige Zeit bis er die Gruppen aktualisiert.

Umgehen kannst du das warten indem du auf Start -> Ausführen gehst, dort gpupdate.exe eingibst und OK drückst.

Gruss
bitnetworks
Bitte warten ..
Mitglied: 48303
21.11.2007 um 17:16 Uhr
Hallo,

nein an Geduld mangelt es mir glaube ich nicht, die Gruppen sind zum Teil schon ein paar Wochen alt, da ich sie für verschieden Berechtigungen in unseren "allgemein" Laufwerken schon benutzt habe.

Außerdem arbeite ich an unserem Hauptdomaincontroller, hier sollte eigentlich gar keine Replikation nötig sein.

Danke dir

Gruß
Andi
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
gelöst Login .bat funktioniert nicht immer (5)

Frage von xtra-long zum Thema Windows Server ...

Windows Server
Raid funktioniert nicht richtig (20)

Frage von Roadrunner777 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...