Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Hal.dll fehlerhaft gelöscht? XP fährt nicht mehr hoch

Frage Microsoft Windows XP

Mitglied: rapidonym

rapidonym (Level 1) - Jetzt verbinden

25.11.2008, aktualisiert 18.10.2012, 5137 Aufrufe, 4 Kommentare

Hallo,

folgendes:

Beim hochfahren des PCs kam die Fehlermeldung dass die 'hal.dll' beschädigt sei bzw. fehlt. Bei Google gesucht und durch diverse Foren geklickt habe ich mich bereits. Folgendes habe ich bis jetzt schon durchgeführt.

Windows XP Installations-CD eingelegt, Wiederherstellungsmodus aufgerufen.
Befehl durchgeführt: copy x:\i386\hal.dl_ y:\windows\system32

Dabei kam jedoch immer eine Fehlermeldung. Ging nicht!

Außerdem habe ich 'bootcfg /rebuild' durchgeführt.

Alles ohne Erfolg. Fehlermeldung kommt bei jedem Start wieder!
Zwischenzeitlich war es mal so, dass das Windows XP Logo kam und er geladen hat, danach allerdings wieder heruntergefahren ist.

Das Problem bei der Wiederherstellungskonsole ist auch folgendes. Ich habe zwei Partitionen, C und D. Ein Kennwort habe ich nicht vergeben, wähle ich bei bei Reparier-Funktion allerdings 'C' aus, fragt er mich nach einem PW und sagt immer es sei falsch. Habe nur ENTER gedrückt, da wie schon erwähnt, ich keins habe. Wähle ich 'D' aus, drücke auch nur ENTER akzeptiert er es und es geht weiter. Die Befehle musste ich also alle unter 'D' ausführen.

Wer kann mir helfen, was kann ich noch tun?
Mitglied: Netzheimer
26.11.2008, aktualisiert 18.10.2012
Die Suchfunktion oben rechts bemühen.

Der Artikel XP retten mit der Wiederherstellungskonsole kann dir da vielleicht helfen.

Wenn es nicht geht, mit dem Ergebnis wieder hier melden.

Daniel
Bitte warten ..
Mitglied: rapidonym
26.11.2008 um 12:09 Uhr
Ergebnis: Ich habe die Festplatte jetzt als externe angeschlossen. Ich komme auf beide Partitionen drauf, also 'C' und 'D' ... Die Daten habe ich zur Sicherheit jetzt erstmal gesichert.

Die Datei: hal.dll im System32 ist vorhanden. Nun kommen wir also zur boot.ini

Diese hat folgenden Inhalt:

---
[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP (d)" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=""
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS=""
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
---

Auf 'C' liegt das Betriebssystem. Von dort muss also gebootet werden, ein Auswahlmenü brauch ich eigentlich nicht. Normal kann ich doch einfach den Befehl '[boot loader]' entfernen, oder? Dann müsste das erste System unter '[operating systems]' starten oder nicht?

Problem ist nur, ich kann die boot.ini nicht speichern ... Obwohl ich den Schreibschutzt deaktiviert habe.

Was mach ich also nun? Bitte dringend um Hilfe
Bitte warten ..
Mitglied: rapidonym
26.11.2008 um 12:13 Uhr
Info: Die 'boot.ini' kann ich nun bearbeiten, wie soll der Inhalt aussehen?
Bitte warten ..
Mitglied: Netzheimer
28.11.2008 um 07:40 Uhr
Ich glaube, hier liegt das Problem.

Wenn ich 0-0-0-1 zusammenfasse, sehe ich XP, nix, XP-Pro fastdetect
bei 0-0-0-2 sehe Ich XP(d), nix, XP-Pro

das scheint sich irgendwie zu beißen, da auf einer Partition 2 verschiedene XP liegen.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...