Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

kann hamachi unter Opensuse 11 nicht installieren

Frage Linux Suse

Mitglied: Truckermane

Truckermane (Level 1) - Jetzt verbinden

15.09.2008, aktualisiert 18.09.2008, 6951 Aufrufe, 5 Kommentare

Hallo, ich habe folgendes Preoblem, ich wollte hamachi unter Opensuse 11 installieren,nach Anleitung, doch irgendwie funktioniert das nicht.
Ich habe als "root" alles in den Ordner /usr/bin entpackt. In der shellconsole den Befehl: cd /usr/bin eingegeben,dann " make install"
doch hier endet alles mit der Ausgebe "bash: make: command not found.

auch die andere Methode mit " ./Makefile funktioniert nicht.

Würde gerne hamachi aufsetzen, da der Computer, auf dem Linux läuft als Server für verschiedene Anwendungen fungieren soll, und auf den Windows-clients ebenfalls hamachi bereits läuft.
Ich bitte um Hilfe

Danke

Mane
Mitglied: 39916
16.09.2008 um 00:26 Uhr
Hi Manfred,

Dir fehlt das Paket build-essential.

Gruß,
Martin
Bitte warten ..
Mitglied: theton
16.09.2008 um 01:15 Uhr
Hier ist von OpenSuSE die Rede. Da gibt es kein build-essential. Dieses Meta-Paket gibt es nur bei Debian-basierten Systemen.

Also... zuerstmal entpackt man nichts nach /usr/bin. Linux hat eine klar definierte Dateisystem-Struktur, in der jeder Ordner spezifische Aufgaben hat. In /usr/bin liegen nur die Programm-Binaries. Irgendwelche Downloads oder entpackte Pakete haben dort nichts zu suchen. Entpacke den Tarball nach /usr/src oder in dein Root-Homeverzeichnis. Ausserdem musst du das Paket 'make' installieren, das auch den Befehl 'make' enthält, der dir ja offensichtlich fehlt.
Bitte warten ..
Mitglied: Truckermane
16.09.2008 um 21:47 Uhr
Danke, dies hat mir schon ein bisschen geholfen, aber ganz läuft es immer noch nicht.
Also, ich hab das Paket "make" installiert. dann hamachi mit dem Befehl "make install" ebenfalls installiert. So weit, so gut.
Folgende Meldung kam:"Copying hamachi into /usr/bin ..
Creating hamachi-init symlink ..
Copying tuncfg into /sbin ..
Hamachi is installed."
Dann heisst es im Readme man solle den Befehl " ./hamachi-init " ausführen.
Doch hier ist mein nächstes Problem,Ich wechsle zum Verzeichnis " /usr/bin und tippe den Befehl ein, dann erhalte ich folgende Fehlermeldung: "./hamachi-init: error while loading shared libraries: libcrypto.so.0.9.7: cannot open shared object file: No such file or directory"
Dabei hiess es in der Anleitung,dass mit diesem Befehl "./hamachi" das Verzeichnis erstellt werde , in dem das Schlüsselpaar, und der Status eingetragen wird. Ach ja tuncfg, konnte ich starten.

Ich Danke im Voraus

Mane
Bitte warten ..
Mitglied: theton
16.09.2008 um 23:38 Uhr
Vermutlich fehlt dir das Paket compat-openssl097g. Ich kann allerdings nicht sagen, ob es das bei 11.0 noch gibt. Bei SuSE 10.3 gab es das jedenfalls. Alternativ installiere libopenssl0_9_8 (oder die Version, die bei 11.0 dabei ist) und verlinke /usr/lib/libcrypto.so.X.X.X nach /usr/lib/libcrypto.so.0.9.7 (wobei X.X.X für die installierte Version steht. Einfach mal in /usr/lib nachschauen welche die richtige Datei ist).
Bitte warten ..
Mitglied: Truckermane
18.09.2008 um 21:58 Uhr
Ich glaube jetzt könnte es funktionieren. der einzige Fehler liegt evtl. noch daran, dass ich mit dem Linux-rechner noch keine direkte Internetverbindung habe( Ist nur über Netzwerkkabel mit dem Windows-Rechner verbunden.Der ist am Internet über Wlan-usb-Stick).Deshalb kann sich hamachi nicht einloggen ("hamachi logging in...failed")
Ansonsten läuft Hamachi mi Hintergrund bereits.

Ich bedanke mich recht herzlich für die super Hilfe.

Mane

Ach ja, auch im Opensuse 11 gibt es noch das Paket "compat-openssl097g".
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...