Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Hardware Festplatten, SSD, Raid

GELÖST

Hardware-RAID-Controller erkennt Fetplatten nicht richtig

Mitglied: fenris-der-wolf

fenris-der-wolf (Level 1) - Jetzt verbinden

18.04.2007, aktualisiert 10.05.2007, 10031 Aufrufe, 8 Kommentare

Moin Moin,

wir haben uns zwei Server mit ICP-Vortex RAID-Controllern zugelegt.
Es handelt sich um ICP 9014RO Hardware-SCSI-RAIDS verbunden mit je 3 Fujitsu Festplatten mit 73GB.
Auf beiden Controllern ist ein RAID1 mit Hotspare konfiguriert. Auf beiden Server läuft Ubuntu Server.

Nun tritt bei beiden Servern das selbe Problem auf unabhängig davon ob das Betriebssystem schon geladen wurde oder nicht:
- Es beginnt damit das nachdem zuerst alle 3 Festplatten einwandfrei erkannt wurden, eine Festplatte aus der Konfiguration verschwindet und auch vom Controller nicht mehr gefunden wird.
- Nach einiger Zeit oder einem Reboot wird die zweite Festplatte in der RAID-Konfiguration als fehlerhaft erkannt.
- Die letzte Festplatte bleibt aber funktionsfähig und das Betriebssystem lässt sich auch vom unvollständigen RAID weiterhin starten.
- Beim Neustart braucht der RAID-Controller bei 3 angeschlossenen Festplatten ca 5Min zum Booten. Sind nur 2 Festplatten angeschlossen so dauert es nur ca 15 Sekunden.

Nun haben wir folgendes probiert:
1. Tauschen des SCSI-Kabels und des Terminators.
2. Tauschen der Anschlüsse der Festplatten Stromversorgung
3. Tauschen der RAID-Controller untereinanader
4. Tauschen einzelner Festplatten
Ergebnis: keine Änderung
5. Anschließen des Kabels an die Festplatten in umgekehrter Reihenfolge
Ergebnis: Es wird immer die am weitesten von Controller entfernte Festplatte nicht erkannt und die in der Mitte hat nach einer Weile Fehler, unabhängig von der ID.

Ich würde ja normalerweise auf das Kabel oder den Terminator tippen aber die haben wir bereits 4 mal getauscht.

Zur Hardwarekonfiguration:
Die Festplatten haben die IDs 0 bis 2 der Controller die 7.
Die Terminierung des Controllers steht auf 'Auto'. (Ansonsten gibt es nur noch 'Off')
Die gesamte übrige Hardware (Mainboard,CPU,Stromversorgung) benutzen wir auch in einem dritten Server allerdings mit einem 3Ware SATA-RAID dieser funktioniert einwandfrei.

Mir ist das Ganze ein ziemliches Rätsel oder wir haben einfach nur Tomaten auf den Augen.
Mitglied: SteffenF
18.04.2007 um 12:17 Uhr
Hallo,
ich bitte um nähere Angaben zu den verwendeten Fuji-Festplatten: Typ, FW-Version, write-cache ein oder ausgeschaltet, 68- oder 80-polig (SCA), wenn letzteres: im HotSwap-Rahmen an einer Backplane oder an SCA zu 68polig-Adapter ?
Allgemein:
Steckt auf dem Kabel ein aktiver LVD-Terminator oder wird etwa passiv terminiert ?
Wenn es 68polige Platten sind hilft es manchmal, auf der letzten (am weitesten entfernten) Platte TermPower einzuschalten.
Qualtät der SCSI-Kabel (meines Wissens steckt ICP/Adaptec keine Kabel dazu), wirklich U320 zertifiziert ?
Letzte verfügbare FW (Nov. 2006) auf dem Controller ?
Welcher Treiber wird verwendet ?
Ist der StorageManager installiert ?
freundliche Grüße
SteffenF
Bitte warten ..
Mitglied: fenris-der-wolf
18.04.2007 um 17:00 Uhr
Die Festplatten haben 68polige Anschlüsse. Typ ist Fujitsu MAW 3073 NP.
Am Kabel steckt ein aktiver LVD-Terminator.
Write-Cache ist bei allen Platten meines Wissens eingeschaltet.
Was U320 zertifiziert betrifft: Jein. Ich möchte es mal so sagen: Es steht zumindest auf Kabel und Terminator drauf.
Morgen früh teste ich das Ganze noch einmal mit einem anderen Kabel.
Wenn das nicht geht werde ich den Tipp mit Termpower an der Festplatte mal ausprobieren.

Auf jeden Fall schon mal vielen Dank für die Hilfestellung!
Bitte warten ..
Mitglied: SteffenF
18.04.2007 um 18:13 Uhr
Hallo,
der verwendete ICP ist ein sogenannter CacheController (256MB ECC onBoard). Deshalb ist auf serverspezifizierten Festplatten der WriteCache factorydefault aus - kann da nämlich durchaus zu Fehlern kommen. Der von Ihnen verwendete Typ MAW3073NP ist aber eher eine Workstationplatte (schon daran zu erkennen, daß sie einen 68poligen Anschluß hat, neuere Serverplatten kommen allgemeinhin mit 80polig SCA), und bei denen ist der WriteCache eingeschaltet.
Mit der Qualität der Kabel (siehe hier http://www.adaptec.com/en-US/_whitepapers/tech/scsi/cables_u320.htm ) und Terminatoren steht und fällt jede SCSI-Konfig. ! Früher gab Adaptec (ICP ist nach leidvollem Intermezzo bei Intel jetzt bei Adaptec) auch schon mal konkrete Hinweise, welche Kabel welchen Herstellers bevorzugt werden. Kleiner Tip: in vielen von mir betreuten Servern steckt Foxconn.
Meine Frage zum verwendeten Treiber haben Sie leider unbeantwortet gelassen: Ubuntu basiert auf Debian und dafür bietet ICP/Adaptec keine Treiber an, allerdings die LinuxSourceCodes für Kernel 2.4 und 2.6 --> auf zum fröhlichen Kompilieren
Auch die Antwort auf die Frage, ob der Storage Manager installiert ist sind Sie mir leider schuldig geblieben - anhand der Fehlerlogs hätten wir möglicherweise das Problem eingrenzen können.
Die lange Bootzeit mit drei Platten führe ich darauf zurück, daß der Controller unter Einbeziehung des Spare ein Rebuild versucht, aber wegen zu vieler Fehler aufgibt.
Viel Erfolg und freundliche Grüße
SteffenF
Bitte warten ..
Mitglied: fenris-der-wolf
19.04.2007 um 09:08 Uhr
Ups hab' ich vergessen...
Storage Manager ist installiert und die Logs hab' ich mir auch gezogen und an ICP/Adaptec geschickt.
Interessant scheint z.B diese Stelle zu sein:
"[1091]: 18:00:12 >> [0:01:0] DomainValidate fallback set 80 MB/s [wide=1], device was 50 MB/s [wide=0]"
Genau wie Sie beschrieben haben scheint es ein Terminator / Kabel Problem zu sein.
Schade, mittlerweile habe ich 5 Kabel ausprobiert von denen 4 eindeutig als U320 verkauft wurden.
Das gleiche gilt für die Terminatoren...

Die Treiberversion ist laut ICP OK.
Bitte warten ..
Mitglied: SteffenF
19.04.2007 um 14:01 Uhr
Hallo,
meine Empfehlung für Kabel /Terminator wäre z.B. http://www.lindy.com/de/productfolder/03/33/33177/index.php und http://www.lindy.com/de/productfolder/07/70381/index.php .
Das Fallback ist ein ziemlich eineindeutiger Hinweis auf schlechte Kabel / Terminator-Qualität, spätestens dann, wenn er auf asynchron zurückfällt (kann Sie beruhigen, der Controller meldet das Teil viel eher ab) ist Feierabend mit dem RAID.
Viel Erfolg
würde mich über positives feedback freuen (dann könnte das Thema auch mit einem grünen Haken versehen werden )
freundliche Grüße
SteffenF
Bitte warten ..
Mitglied: fenris-der-wolf
20.04.2007 um 13:37 Uhr
Wir haben uns nach ausführlichen Konsultationen mit dem Adaptec/ICP Support. Endlich dazu durchgerungen ein Adptec-Kabel zu kaufen. Ist zwar extrem teuer aber dann haben wir endgültig Sicherheit. Wenn das Kabel eintrifft gibt's auch hoffentlich einen grünen Haken.

Ich möchte mich noch mal eindeutig bei den Forenmitgliedern bedanken für die kompetente Hilfe und auch bei den wirklich geduldigen Mitarbeitern des Adaptec-Supports.
Bitte warten ..
Mitglied: fenris-der-wolf
10.05.2007 um 09:10 Uhr
Endlich ist das ,mit einer wirklich sehr langen Lieferzeit gesegnete, Kabel eingetroffen.
Halleluja es funktioniert!!!

Ich werde wohl ein längeres Gespräch mit dem Hardwarelieferanten meines ehemaligen Vertrauens führen müssen. Seltsamerweise sind nach meinem ersten Gespräch mit ihm alle SCSI-Kabel, auf seiner Webseite, die vormals als U320 gekennzeichnet waren nur noch als SCSI3 gekennzeichnet.

Nochmal vielen Dank für die kompetente Hilfe...!
Bitte warten ..
Mitglied: SteffenF
10.05.2007 um 20:53 Uhr
Hallo,
vielen Dank für das FeedBack.
freundliche Grüße
SteffenF
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
Welchen Hardware Raid Controller für Workstation
gelöst Frage von michi1983Festplatten, SSD, Raid27 Kommentare

Hallo Admins, ich habe von Hardware Raid Controllern leider absolut keine Ahnung. Alles was ich über Raid Controller weiß ...

Server-Hardware
Raid Controller richtig und sinnvoll nutzen
Frage von vGavenServer-Hardware12 Kommentare

Hi, folgendes Szenario, habe einen Server mit Raid Controller an dem kann ich 8 Festplatten verbinden kann. Festplatten haben ...

Festplatten, SSD, Raid
Storage Spaces vs Hardware RAID Controller
Frage von alexsportFestplatten, SSD, Raid4 Kommentare

Hallo zusammen, ich würde gerne eure Meinung zu folgendem Thema erfahren. Welchen Lösungssatz würdet ihr bevorzugen: Windows Server 2016 ...

Festplatten, SSD, Raid
RAID 1 einrichten mit HP Microserver und Hardware RAID Controller
gelöst Frage von pinto123456Festplatten, SSD, Raid3 Kommentare

Hallo an die Experten, ich habe ein HP Microserver Gen 8, mit einem Hardware RAID von Adaptec, 4 HDD ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall9 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...