Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

HDD-Austausch in RAID 1 oder RAID 10 (0,1) Array funktioniert nicht

Frage Hardware Server-Hardware

Mitglied: FRitter

FRitter (Level 1) - Jetzt verbinden

21.02.2006, aktualisiert 14.11.2007, 8195 Aufrufe, 5 Kommentare

Hallo an alle!

Es handelt sich um folgende Hardware-Konfigration:

- COMPAQ ProLiant 3000R-Server mit CPQ SmartArray 3200-Ultra2SCSI-Controller (64 MB)

- 8 x HDDs in RAID 5 Array (mit jeweils 9,1 GB SCA, U2W, CPQ BB00911C49)

- 2 x HDDs in RAID 1 Array (mit jeweils 9,1 GB SCA, U2W, Seagate ST39175LC)

-> Auf dem Raid 1 Array befindet sich eine MS Windows 2000 Server Bootpartition!

Die HDDs des Raid 5 Arrays lassen sich wie gewünscht im laufenden Serverbetrieb austauschen und es wird automatisch ein Rebuild vom Controller durchgeführt. ABER das Raid 1 Array lässt sich nicht tauschen -> eine neu eingesetzte (baugleiche) HDD wird vom Controller hochgefahren und nach ein paar Sekunden leuchtet die Fehleranzeige-LED (rot) des HotPlug-Rahmens. In der Controller-Software habe ich festgestellt (mit großer Verwunderung), dass das Array als RAID 10 (also 0+1) aufgelistet wird! Werden für RAID 10 nicht mind. 4 HDDs benötigt? Oder kann es sein, dass die Seagate-HDDs nicht 100%ig HotPlug-Kompatibel sind wie die Compaq-HDDs, die als Originalteile im Server waren?
Mir ist auch noch aufgefallen, dass nach jedem Reboot des Servers im Windows-EventLog steht, dass auf den beiden Seagate-HDDs "Drive Monitoring Treshold" nicht aktiviert ist bzw. werden kann, da es nicht unterstützt wird. Diese Meldung kommt bei den CPQ-Platten nicht.

Leider weiss ich an dieser Stelle wirklich nicht mehr weiter und jedes Testen ist äußerst riskant, da die Maschine in einer Produktionsumgebung läuft...

Habt ihr schonmal ähnliche Probleme im o.g. Umfeld gehabt?

Schonmal danke für eure Mühe!
Mitglied: loefflerman
21.02.2006 um 21:36 Uhr
Hallo,

wenn ich dich richtig verstanden habe sind die beiden Seagate Platten keine Originalteile von Compaq bzw. HP. Dann kann der Fehler entweder daher kommen, dass die Firmware der Platten nicht kompatibel zum Controller ist, oder dass die Plattengrösse etwas zu klein ist und der Controller das RAID1 nicht mehr rebuilden kann.

Kannst du mal testweise eine Platte aus dem RAID5 ziehen und dem RAID1 als Tauschplatte geben und dann überprüfen ob der Controller einen Rebuild auf dem RAID1 macht ?

Sollten die Seagate Platten original HP oder COmpaq sein könnte ein Firmwareupgrade der Platten helfen. Versuchs dazu mal auf www.hp.com/support

VIele Grüße,

loefflerman
Bitte warten ..
Mitglied: FRitter
22.02.2006 um 17:55 Uhr
Hallo zurück und danke für die schnelle Antwort!

Ich habe bereits versucht, eine der beiden Seagate-Platten mit einer original Compaq-HDD zu tauschen - leider klappt auch das nicht, so dass der Controller die HDD gar nicht annimmt und wieder nur nach ein paar Sekunden die rote Fehler-LED des HotPlug-Rahmens leuchtet (wollte natürlich lieber alles komplett CPQ-HDDs im Server laufen lassen, da ja dort die Fehlermeldung des "Drive Monitoring Treshold" (HDD-Überwachung) nicht auftritt).

Ich habe noch einmal in der Array-Software nachgeschaut und mit Verwunderung festgestellt, dass das Array als RAID 1+0 läuft (hatte zuvor 0+1 gepostet). Als Migrationsmöglichkeiten werden mir dort RAID 0, 4, 5 angeboten. Leider kann ich nicht auf RAID 1 migrieren, warum auch immer... kennt sich jemand speziell mit dem CPQ SmartArray 3200 aus oder kann mit näheres zu RAID 1+0 sagen??? (Ich finde in allen Dokus immer nur RAID 10 bzw. 0+1!

Leider kann ich an dem Server nicht allzu viel testen, da das RAID-Array wie gesagt eine Boot-Partition beinhaltet und die MUSS laufen!

(PS: Ich habe bei Seagate nachgeforscht und gefunden, dass die Platten HotPlug voll unterstützen sollten. Beim HP/Compaq-Support kam ich leider nicht weiter, da die Platten nicht mit HP/Compaq gelabelt sind, so wie manch andere die mit einem Server ausgeliefert wurden.)
Bitte warten ..
Mitglied: FRitter
18.03.2006 um 14:15 Uhr
Hallo nochmals,

hat jemand Erfahrungen mit einem "RAID 1+0"-Array? Ich bräuchte allgemeine Informationen zu diesem Array aus der Praxis, also wieviele HDDs müssen mindestens existieren und wie kann ein Austausch vorgenommen werden...

Vielen Dank!
Bitte warten ..
Mitglied: emule72ki
16.04.2007 um 15:56 Uhr
ein Raid 10 (0,1) besteht mindestens aus 4 Platten. Es wird häufig für Datenbank genohmen. es schnell und sicher. Compaq flasht die Platten nur für Compaq mit dem Logo.Meine Vermutung liegt nahe das auf den neuen Platten irgendwelche Information liegen und deshalb wird es als Raid 10 angezeigt. Diese neuen Platten lowLevel formatieren und dann sollte es kein Problem mehr sein. Kenne Dieses Problem aus der Vergangenheit.
Bitte warten ..
Mitglied: FRitter
14.11.2007 um 19:24 Uhr
Hallo noch einmal,

dieses Problem wurde inzwischen bzw. schon seit längerem gelöst. Es lag tatsächlich daran, dass die HDD-Speicherkapazität etwas zu klein war. Der Austausch wurde mit 18,2 GB HDDs anstelle 9,1 GB Kap. durchgeführt, da die Statusinformationen auf den Original-HP/Compaq-HDDs darauf ein paar MB benötigen. Die vorher genutzten Seagate HDDs hatten das Feature dieser Statusinfos nicht (kein "Drive Monitoring Treshold"). Exakt dieser kleine Speicherplatz fehlte für die RAID-Wiederherstellung.

Vielen Dank an alle für die genannten Tipps (insb. loefflerman bzw. Markus Löffler)!

(damit schließe ich diesen Thread nun als "erledigt")
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Festplatten, SSD, Raid
Vergleich zweier SSD-Typen im Raid-10 für den Anwendungsfall SQL-Datenbank (8)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...

Windows 10
Windows 10 von externer USB-HDD installieren (4)

Frage von cableguy007 zum Thema Windows 10 ...

Windows Server
Raid funktioniert nicht richtig (20)

Frage von Roadrunner777 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...