Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

HDD aus defekten NAS auf andere HDD klonen

Frage Linux Linux Tools

Mitglied: m.reeger

m.reeger (Level 2) - Jetzt verbinden

02.11.2014 um 16:50 Uhr, 2685 Aufrufe, 12 Kommentare

Hallo zusammen,

bei einem bekannten hat ein Seagate BlackArmor mit 1x1 TB alle 4'e von sich gestreckt.

Da dort Wichtige Dokumten drauf liegen und Backups wollte er die Daten gerne haben.

Eigentlich soweit kein Problem...die HDD ist i.O

Unter WIndows:
Datenträgerverwaltung erkennt 5 Partitonen und ich kann keine öffnen oder "mounten"

Unter Linux:
dd if=/dev/sda4 of=/dev/sdf1

Die partition SDA4 beinhaltet meines Wissens alle Daten...die Partition ist 893GB groß.
Leider sehe ich absolut kein Fortschritt und die HDD's laufen auch nicht?!

Die alte HDD (dev/sda) kann ich nicht mounten, da ich den Fehler bekomme: Mount: no valid Partiton : Linux_RAID_System
Das selbe Problem habe ich auch seid dem ich den DD abgesetzt habe mit der Backupplatte (WD MyCLOUD 3TB - DEV/SDF)

Es geht nur darum die Daten wiederzubeschaffen!

Ein neues Nas ist von QNAP geordert. Auf mein anraten hin auch ein 4-Bay mit 2x RAID 1.


Danke und Grüße

PS.

OS: Windows 8.1 Pro
Das Linux ist ein Ubuntu Live System 14.04.01 in einer Hyper-V VM, die beiden Datenträger sind als Offline gesetzt und in die VM durchgereicht.
Mitglied: colinardo
02.11.2014 um 17:00 Uhr
Hi,
die Platten aus solchen Systemen sind meistens Software-Raids welche man mit mdadm verwaltet und mountet:
http://www.hetzner.co.za/helpcentre/index.php/articles/content/category ...

Grüße Uwe
Bitte warten ..
Mitglied: m.reeger
02.11.2014 um 17:14 Uhr
Ok Danke,
mdadm ist bei meine Live Ubuntu niicht dabei und kann nicht installiert werden...

Habe gerade mal einfach "Create Disk image" gemacht und er macht mir nun eine .img Datei der Partition mal schauen ob das hinhaut.

Verbleibenden Zeit: 6h +
Bitte warten ..
Mitglied: broecker
02.11.2014 um 17:27 Uhr
Moin,
ist es wirklich im ursprünglichen NAS nur eine Platte gewesen? - dann würde ja RAID kaum Sinn machen...
die Platte könnte GPT-Partitioniert sein, dann kann fdisk unter Linux/Windows auch "Unsinn" liefern.
parted unter Knoppix o.ä. könnte dann das richtige Ergebnis liefern: parted /dev/sda -> darin: print -> danach: quit
dd soll so erstmal keine Ausgabe liefern, besser wäre dann:
ddrescue /dev/sda4 /dev/sdf1 --force
ABER: bitte erst man-Page lesen!
Wenn die Platte dabei gar nicht anläuft gibt's entsprechend Fehler in /var/log/messages und spätestens dann sollte man innehalten und über den Wert der Daten nachdenken: hoch->Profis...
Aus RAID1-Verbunden läßt sich grundsätzlich unabhängig von Hardware-/Software-RAID eine Partition auch von nur einer Platte wie beschrieben rausretten, d.h. es bedarf nicht des ganzen RAID-Verbundes und eines speziellen Abmeldens; das Mounten einer solchen Partition/loop-back-Datei geht dann auch ohne besondere Parameter.
HG
Mark
Bitte warten ..
Mitglied: Lochkartenstanzer
02.11.2014, aktualisiert um 17:52 Uhr
Zitat von m.reeger:

Die alte HDD (dev/sda) kann ich nicht mounten, da ich den Fehler bekomme: Mount: no valid Partiton : Linux_RAID_System
Das selbe Problem habe ich auch seid dem ich den DD abgesetzt habe mit der Backupplatte (WD MyCLOUD 3TB - DEV/SDF)

Wieviel Platten waren denn in dem NAS und welches RAID-Level war denn eingestellt?

lks
Bitte warten ..
Mitglied: colinardo
02.11.2014, aktualisiert um 19:06 Uhr
Linux_RAID_System
sagt doch schon alles

ist es wirklich im ursprünglichen NAS nur eine Platte gewesen? - dann würde ja RAID kaum Sinn machen...

Die NAS-Hersteller legen in wahrer Voraussicht meistens auch mit einer Platte ein Pseudo-RAID mit einem simplen Volume an, so ist die Erweiterung/Migration auf andere Raid Level mit mdadm einfacher zu handhaben.

Grüße Uwe
Bitte warten ..
Mitglied: m.reeger
02.11.2014 um 19:38 Uhr
Also im NAS war nur 1x 1TB Seagate HDD.

Das Image sagt noch 5h 15min 32sec. Ich bin gespannt....
Bitte warten ..
Mitglied: colinardo
02.11.2014, aktualisiert um 20:00 Uhr
Zitat von m.reeger:
Ok Danke,
mdadm ist bei meine Live Ubuntu niicht dabei und kann nicht installiert werden...
Mit Knoppix kein Thema:
hier nochmal die Grundlagen zu Platten mit Software-Raid (ja, dies kann auch bei einer Platte der Fall sein):
http://www.pcwelt.de/ratgeber/Raid-Verbund_unter_Linux_reparieren-Anlei ...
Für den Zugriff wirst du da sehr wahrscheinlich nicht drum herum kommen.
Vorher die Platte Klonen ist auf jeden Fall anzuraten, aber das machst du ja anscheinend gerade ...
Bitte warten ..
Mitglied: Lochkartenstanzer
03.11.2014 um 10:46 Uhr
Zitat von m.reeger:

Also im NAS war nur 1x 1TB Seagate HDD.

Dann solte es mt knoppix kein prblem sein,die zu mounten, sofern das Filesystem in Ordnung ist.


Das Image sagt noch 5h 15min 32sec. Ich bin gespannt....

Hängt die über SATA oder eine USB-Adapter dran. USB2.0 dauert ca. 10h, SATA sollte zwischen 3 und 4h benötigen, wenn die Platte in Ordnugn ist.

Wenn Di Platte alelrdings makcen hat, kann das durchaus mal 3 tage dauern.

lks
Bitte warten ..
Mitglied: m.reeger
03.11.2014 um 16:15 Uhr
So Image angelegen ist fertig...Meldung: Die Imagedatei kann nicht geöffnet werden, sie ist möglicherweise beschädigt.

Die alte HDD hängt an einem 3,5" HotSwap Sata und die neue Backupplatte wird via USB3 angesteuert.

Mit MDADM komm ich leider auch nicht weiter.... cat /proc/mdstat : Datei oder Verzeichnins nicht gefunden.
Bitte warten ..
Mitglied: colinardo
03.11.2014, aktualisiert um 16:55 Uhr
Zitat von m.reeger:

Mit MDADM komm ich leider auch nicht weiter.... cat /proc/mdstat : Datei oder Verzeichnins nicht gefunden.
das kann ja so auch nicht gehen, weil dieser Befehl nur auf einem System mit installiertem mdadm und einghängtem Raid funktioniert !!! Du hast obigen Link also nicht vollständig gelesen.

Du muße erst das hier z.B. mit einem Knoppix machen:
mdadm --examine --scan
dann ein
mdadm --assemble --scan
dann mit
cat /proc/mdstat
die Raid Config prüfen.
Dann einen Ordner für den Mount-Point anlegen
mkdir /mnt/nasplatte
und dann das Raid-Volume mounten (Raid-Device ist an die Ausgabe von cat... anzupassen)
01.
mount -v /dev/md0 /mnt/nasplatte
bitte lese doch den obigen Link, da steht es doch haarklein beschrieben.

Grüße Uwe
Bitte warten ..
Mitglied: broecker
03.11.2014 um 16:52 Uhr
Moin,
aber - damit es nicht in die falsche Richtung läuft - konnte denn eigentlich erfolgreich gelesen werden?
ursprünglich stand doch im Raum, daß die Platte nichts macht?
bei dd hätte am Ende gestanden, wieviele GB er geschaufelt hat,
ein kurzer Test könnte mit der alten Platte noch sein:
dd if=/dev/sda1 | strings
Das gibt einfach alles halbwegs lesbares von der Plattenpartition auf dem Bildschirm aus (mit Ctrl+c abbrechen) und läßt erkennen, ob die Platte überhaupt Blöcke liefert.
Je nach Tool könnte jetzt ja auch ein leeres Image da liegen?!
HG
Mark
Bitte warten ..
Mitglied: Lochkartenstanzer
03.11.2014 um 17:28 Uhr
Zitat von broecker:

dd if=/dev/sda1 | strings

dd bricht übrigens bei Fehlern ab, im Gegensatz zu ddrescue. Sollte das der fall gewesen sein, ist das Image unvollständig und es kann daher alle smögliche passieren, aber nichts vernünftiges.

lks
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Microsoft
gelöst Probleme mit HDD auf kleinere SSD klonen (15)

Frage von Fenris14 zum Thema Microsoft ...

Windows Netzwerk
Windows 10 PC auf andere PCs klonen für Domainbetrieb (7)

Frage von Mikel56 zum Thema Windows Netzwerk ...

SAN, NAS, DAS
NAS RAID5 - RAID0 und Backup (7)

Frage von easy4breezy zum Thema SAN, NAS, DAS ...

Datenschutz
NAS aufräumen (1)

Frage von Kizuko zum Thema Datenschutz ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...