Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Netzwerk

GELÖST

Heartbeat Kommunikation funktioniert nur in einem bestimmten VLAN

Mitglied: freakms

freakms (Level 1) - Jetzt verbinden

18.06.2013 um 07:14 Uhr, 1796 Aufrufe, 6 Kommentare

Hallo Liebe Netzwerker!

Wir haben wir folgendes Problem:

Es gibt bei uns ein System, welches redundant aufgebaut ist, Sprich Serverraum A und Serverraum B. Gleiche Hardware, gleiche Konfiguration. Die Kommunikation läufter über einen Heartbeat zum Lastenausgleich und, falls das eine System sich nicht mehr meldet zum schwenken.

Nun läuft dieser Heartbeat, allein in einem VLAN 214. Das Vlan 214 ist entsprechend auf dem Coreswitch-Port vom Heartbeat untagged konfiguriert. Auf beiden Seiten. Die Uplinks der Core-Switche sind entsprechend tagged auf dieses VLAN Konfiguriert.

Das VLAN ist unter anderem auch auf das entsprechende Interface des Blade Centers gelegt.

Jetzt der Clou, mit dem VLAN 213 funktioniert die Kommunikation tadellos, mit anderen VLANs nicht.

Habt ihr eine Idee?

Ich schließe die Switch Konfiguration mal aus, da es wie gesagt mit andern VLANs geht. Ich vermute mal das irgendwoe auf dem Bladecenter oder dem Clustermanager auf dem Server noch das VLAN 214 bekannt gemacht werden muss.

Gruß, der Freak
Mitglied: benpunkt
18.06.2013 um 09:19 Uhr
Naja, die Switch Konfiguration ist schon wesentlich:
Hast Du alle beteiligten die Ports den entsprechenden VLANS zugeordnet?

Du musst eine durchgängig konsistente Layer 2 Verbindung schalten.

Es gibt keinen Grund, warum das in anderen VLANs nicht funktionieren sollte außer dem, dass eine der beteiligten Komponenten nicht auf VLANxxx konfiguriert ist.

Siehst Du die MAC-Adresse in der Mac-Adress-Table des VLANs?
Bitte warten ..
Mitglied: MrNetman
LÖSUNG 18.06.2013, aktualisiert 26.02.2014
Es gibt Zufälle,
die Bewirken, dass eine anerkannte Konfiguration in einer anderen Umgebung nicht funtioniert. Es sind ja nur bits.
Aber meist liegt ein Konfigurationsproblem vor.
Das VLAN ist nicht durchgängig. Dem Heartbeat ist es nämlich vollkommen egal wie er verteilt wird. Die Hauptsache ohne Router und Layer2.
Der integrierte Bladeswitch könnte eine Fehlerquelle darstellen.

Gruß
Netman
Bitte warten ..
Mitglied: brammer
18.06.2013 um 10:49 Uhr
Hallo,

was für ein Core switch ist dem im BC??

und was für ein BC?

brammer
Bitte warten ..
Mitglied: freakms
18.06.2013 um 11:12 Uhr
Moin danke für die Antworten!

@benpunkt:

Die Ports sind sauber konfiguriert um es zu testen brauch ich ja nur die Ports der Heartbeats einem anderen VLAN untagged zuweisen. Und das geht.Ebenfalls wird dann ja auch dem entsprechendem externen und internem Interface auf dem Blade ein anderes Vlan eingestellt...Und das funktioniert! Es ist dann ja die 1 zu 1 Konfiguration wo man aus vlan 213 nur vlan 214 macht. Das ist das Problem...
Bitte warten ..
Mitglied: freakms
18.06.2013 um 11:24 Uhr
Also das Bladecenter ist ein H Gehäuse von IBM und die Server jeweils HS22 Blades.

Was da für Switche drin sind kann ich dir so nicht sagen ich glaube dieser hier

BNT 1/10Gb Uplink Ethernet Switch Module for IBM BladeCenter
Bitte warten ..
Mitglied: freakms
26.02.2014 um 13:18 Uhr
Für diejenigen die mal ein ähnliches Problem haben sollten:

Bei uns war es das Problem das zusätzlich auf dem Bladecenter selber Spanning Tree angeschaltet war. Das hat die Probleme verursacht.
Bitte warten ..
Ähnliche Inhalte
Netzwerke
Fragen Inter-VLAN Kommunikation
gelöst Frage von 118080Netzwerke10 Kommentare

Guten Abend Allerseits Ich habe mal angefangen mich mit VLANs zu beschäftigen. Ich habe vor demnächst mein Netzwerk in ...

Windows Server
Server Netzwerkadapter fehlt, Kommunikation funktioniert aber ???
Frage von sonnblickWindows Server1 Kommentar

Hallo Community! Habe eine Frage und hoffe einer von euch kann mir helfen. Ich hatte gestern Nacht einen Ausfall ...

Cluster
Heartbeat Failover Masternode konfigurieren
gelöst Frage von akadawaCluster1 Kommentar

Hallo, ich habe mit heartbeat ein cluster mit 2 nodes eingreichtet,. beide nodes haben zum test einen apache2 server, ...

Cluster
Heartbeat über 2 subnetze
Frage von akadawaCluster8 Kommentare

hallo leute, ich stehe in meinem Projekt noch vor einem Problem mit dem heartbeat. heartbeat scheint nicht mit node1 ...

Neue Wissensbeiträge
Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 10 StundenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 11 StundenSicherheit7 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 12 StundenSicherheit8 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Sicherheit

Meltdown und Spectre: Die machen uns alle was vor

Information von Frank vor 12 StundenSicherheit12 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Heiß diskutierte Inhalte
Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von 92943Windows 1031 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Batch & Shell
Anmeldevorgang für Informatikraum (Schule) unter Windows
gelöst Frage von IngenieursBatch & Shell29 Kommentare

Hey zusammen, ich werde in naher Zukunft den Informatik Raum meiner jetzigen Schule von dem aktuellen Betreiber übernehmen (Vertrag ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
Frage von Windows10GegnerNetzwerkgrundlagen20 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...