Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Heartbeat - nodes sind immer tot oO

Frage Linux

Mitglied: sence-override-coc

sence-override-coc (Level 1) - Jetzt verbinden

08.08.2009, aktualisiert 14.12.2010, 3376 Aufrufe, 3 Kommentare

-Deleted--Deleted--Deleted--Deleted--Deleted--Deleted--Deleted--Deleted-
Mitglied: aqui
08.08.2009 um 19:10 Uhr
Keine gute Intro fürs Forum... Ist das ein überflüssiger Doppelpost zu

http://www.administrator.de/Heartbeat_-_nodes_erkennen_sich_nicht.html ???

Auf welchen hättest du denn nun gerne eine Antwort ??
Bitte warten ..
Mitglied: sence-override-coc
08.08.2009 um 20:30 Uhr
ok, hier bitte : )

ha.cf
logfacility 0
auto_failback on
bcast eth0
node mx1
node mx2
keepalive 2
deadtime 30
warntime 10
initdead 120
respawn hacluster /usr/lib/heartbeat/ipfail
ping 10.12.0.1

haresources
mx1 10.12.0.160

authkeys
auth 1
1 md5 meinpw


(2 vserver VMWARE)

Habe auch schon, den ping auf die 10.12.0.160 gesetz und von bcast auf ucast umgestellt.


egal, welche konfiguration ich wähle, es steht immer nur im log dass der primäre down ist, und der 2. die resource jetzt übernimmt.
dann laufen beide nodes mit der IP.

der fehler liegt in der Erkennung der nodes welche sich nicht unterhalten können, aber der brodcast geht durch.
Es läuft bcast auf eth0 und bereits über eth1 und eth0 und eth1



meine hosts Datei schaut wie folgt aus:

10.12.0.151 mx1.it-schuth.net mx1
10.12.0.152 mx2.it-schuth.net mx2

hatte auch nur 10.12.0.151 mx1 mx1
und 10.12.0.152 mx2 mx2
gehabt , aber die ausflösung der ip durch ping mx1 bzw mx2 funktioniert.

Wichtig noch:
ich habe die namen aus uname -n benutzt, und die Datei authkeys mit den rechten 600 versehen.
und auch schon die anderen mit 777, hatte jedoch leider auch nicht zum Erfolg geführt.

Vielen Dank für die Hilfe!
Bitte warten ..
Mitglied: 6890
06.09.2009 um 11:39 Uhr
Tach,

verwende mal bitte bei deinen tests "node mx1.it-schuth.net mx2.it-schuth.net" und als cast "ucast ethx ip-des-anderenhosts".

und dann printe mal deine ha.log.

MfG
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Cluster
Heartbeat Failover Masternode konfigurieren (1)

Frage von akadawa zum Thema Cluster ...

Exchange Server
SBS 2011 Exchange Server 2010 nach SP3 tot (6)

Frage von intermarty zum Thema Exchange Server ...

Exchange Server
gelöst Notfall - Netzwerkadapter nicht mehr funktionsfähig, Exchange tot (14)

Frage von vBurak zum Thema Exchange Server ...

Batch & Shell
gelöst Autorun.inf tot? (6)

Frage von Todybear zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (23)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (19)

Frage von smartino zum Thema Mac OS X ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (10)

Frage von Akcent zum Thema Hyper-V ...

Windows Server
Server 2016 - Kuriositäten (8)

Frage von certifiedit.net zum Thema Windows Server ...