Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

HELO greeting

Frage Microsoft Exchange Server

Mitglied: kerfte

kerfte (Level 1) - Jetzt verbinden

26.10.2011 um 12:13 Uhr, 3044 Aufrufe, 5 Kommentare

Falsche Reihenfolge des HELO greetings bei Kommunikation von 2 servern

Hallo liebe Admins,
folgendes Problem ereignet sich in unserem Email-System.
Wenn der Haupt-Mailserver unsere mails zu unserem mailserver weiterleiten will werden diese abgeblockt. Laut Aussage unseres providers liegt es an der Reihenfolge des HELO greetings.
Der Haupt-Mailserver (Exchange 2010) schickt den HELO command raus und fängt sofort an zu senden ohne vorher auf Antwort von unserem mailserver (Linux) zu warten. Deshalbt blockt unser mailserver die Emails aus Sicherheitsgründen ab und der provider weigert sich auch das zu ändern.
Die Frage ist jetzt, kann ich, oder wie kann ich das im Exchange abändern? Vielleicht gibt es auch eine andere Lösung?

Vielen Dank schonmal für eure Hilfe.

MfG
Kai
Mitglied: Pago159
26.10.2011 um 12:26 Uhr
Hallo Kai,
wenn ich das jetzt richtig gelesen habe, dann hast du doch gar keinen Zugriff auf den Exchange sondern nur auf den Linux-Mailserver,
wobei hier für Hilfe doch mehr angaben benötigt werden,
wie:

  • Welches Linux-Derivat wird eingesetzt,
  • Welcher Mailserver wird hierauf betrieben?
  • Gibt es eine Firewall.......?

Lg Grapper
Bitte warten ..
Mitglied: kerfte
26.10.2011 um 13:27 Uhr
Hallo Grapper,
deine Fragen kann ich dir bloß schwammig beantworten leider.

-Ich weiss das es ein Redhat Linux drauf hat aber nicht welche Version genau
-Sendmail
-Ja es gibt eine Firewall weiss aber nicht welche

Dieser server wird und kann von uns nur über ein web-interface gesteuert werden und dort auch mehr oder weniger nur domains und Emails.

Den Exchange-server verwalte nicht ich selbst sondern die IT in der Hauptstelle im Ausland und weil die da nich in die Pötte kommen will ich mich mal etwas schlau machen das ich ihm unter die Arme greifen kann.

Doch wie gesagt wird mein provider hier seine Einstellungen nicht ändern bezüglich der Annahme von mails ohne richtiges HELO greeting, was ich auch verstehen kann. Sprich die Exchange-Seite muss etwas ändern. Nur was?

LG
Kai
Bitte warten ..
Mitglied: Pago159
26.10.2011 um 13:59 Uhr
Weshalb muss die Exchange Seite etwas machen?
Ich habe aus deinem Anfangspost raus gelesen, dass der Linux-Mailserver die Mails verwirft und nicht der Exchangeserver?
Irgendwie bin ich ein bisschen verwirrt oder ich bin noch nicht ganz fit,
auch wenn wir schon Mittag haben.

Dein System ist also Folgendermaßen aufgebaut:

  • Mail-Provider (Schickt HELO-ANFRAGE und direkt DATEN) --> Exchange 2010 ruft die Daten beim Provider an und bekommt auch noch welche --> Sendmail ruft die Daten vom Exchange ab, hier entsteht jetzt das Problem, dass die Mails verworfen werden?

  • Bekommst du da eine Fehlermeldung oder wird das in eine Log-Datei eingetragen?

Lg GRapper
Bitte warten ..
Mitglied: kerfte
26.10.2011 um 14:38 Uhr
Eine Fehlermeldung bekommt man nicht. In den log steht der error das der Exchange unzulässig einfach Daten schickt.(Würde das rauskopieren aber der log liegt mir leider nicht vor). Der Exchange wartet den handshake nicht ab.

Zum Verständnis, System sieht so aus:
Mails kommen bei Exchange an(alles gut^^); Exchange leitet zu unserem provider weiter(handshake wird übersprungen)

Wenn der Exchange erst Antwort von unserem provider abwarten würde wäre alles gut, aber das passiert nicht.
Bitte warten ..
Mitglied: filippg
27.10.2011 um 00:35 Uhr
Hallo,

das würde mich total wundern, Exchange ist ziemlich sauber implementiert.
Aber das sollte sich ja gut überprüfen lassen: MS Network Monitor auf Exchange installieren und mal einen Dump der Kommunikation ziehen. Dann lässt sich damit eindeutig nachvollziehen, wer wann was sendet (okay, nach der TLS-Aushandlung kann man nischt mehr lesen, aber bei dir scheint's ja schon lange vorher zu scheitern).

Btw: Exchange sollte ein EHLO schicken, kein HELO. Wenn es ein HELO ist, dann scheint bei dir noch was ganz anderes schief zu laufen, und ich würde fast vermuten, dass nicht wirklich der Exchange sendet, sondern eher irgendein seltsamer Antispam-Proxy o.ä.

Gruß

Filipp
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Name für HELO EHLO wird nicht übernommen auf Exchange 2010 (2)

Frage von QandAt zum Thema Exchange Server ...

DNS
FQDN mit HELO-String unter Plesk hinterlegen (8)

Frage von matschi11 zum Thema DNS ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...