Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Herunterfahren Skript und Ereignisanzeige

Frage Microsoft

Mitglied: AndiK66

AndiK66 (Level 1) - Jetzt verbinden

16.12.2007, aktualisiert 24.12.2007, 5663 Aufrufe, 6 Kommentare

Fehlermeldung obwohl kein Fehler erkennbar?

Hallo,

ich habe bei mir eine kuriose Fehlermeldung in der Ereignisanzeige entdeckt. Und zwar geht es um folgendes.
schon vor langer zeit stellte ich fest, dass wenn ich word, excel oder ein anderes office programm öffne mir jedesmal das icon der html-dateien aus der registry gelöscht wird bzw das office prog den wert für DefaultIcon auf "%1" ändert. warum? hab ich nie rausgefunden. da ich über ein paar prorammierkenntnisse verfüge schrieb ich mir ein kleines skript das diesen eintrag wiederherstellt. dieses skript trug ich in den gruppenrichtlinien als herunerfahrenskript ein. funktioniert hervoragend. nun... seit kurzem steht bei mir in der ereignisanzeige unter anwendung immer wieder ein fehler:

Userinit Ereigniskennung 1000 Typ Fehler
Folgendes Skript konnte nicht ausgeführt werden: G:\Software\Scripte\HTML-Files reparieren.vbs. Zugriff verweigert.

diese fehlermeldung wird selbsverständlicherweise immer beim herunterfahren generiert.
das kuriose dabei ist, dass das skript aber ausgeführt wird. also es funktioniert tadellos und schreibt mir den registryeintrag so wie ich das geplant hatte.
meine frage hier wäre dementsprechend: Wie kommt diese fehlermeldung zustande? wenn das skript doch ausgeführt wird.
Oder: welcher zugriff wurde verweigert?

Gruß
AndiK66

PS: ich benutze win xp pro x64 mit sp2 und allen updates
office 2007 enterprise (war vorher mit office xp aber genauso)
Mitglied: laggflor
18.12.2007 um 01:16 Uhr
Nimm das Script doch mal raus... kommt die Meldung immer noch? Wenn nicht dann hat die Meldung mit dem Script nichts zu tun.

Ansonsten poste bitte mal das Script.

LG
Florian (http://www.lagg.at)
Bitte warten ..
Mitglied: AndiK66
18.12.2007 um 16:21 Uhr
Danke für die antwort. allerdings muss ich sagen so schlau war ich auch schon das skript rauszunehmen -> meldung kam dann nicht mehr.
ich hab auch ein wenig darüber nachgedacht seit wann das ungefähr auftritt, weil es ja ca. 1 1/2 bis 2 jahre wunderbar lief. ich glaube es ist erst seit ich den IE7 drauf hab
bzw. die damit verbundenen updates.
vielleicht hilft dir das bei deinen überlegungen weiter.

Hier mal noch das skript selbst,aber ich glaub nicht, dass es an dem liegt:

set wshell = CreateObject("WScript.Shell")

max = 4
ReDim key(max)
key(0) = "HKCR\htmlfile\ShellEx\IconHandler\"
key(1) = "HKCR\htmlfile\shell\Print\command\"
key(2) = "HKCR\htmlfile\shell\Print\"
key(3) = "HKCR\htmlfile\DefaultIcon\"
key(4) = "HKLM\SOFTWARE\Classes\htmlfile\DefaultIcon\"

wshell.regwrite key(3), "C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE,1"
wshell.regwrite key(4), "C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE,1"

for x = 0 to 2
if RegExists(key(x)) then
wshell.regdelete key(x)
end if
next

function RegExists(schl)
on error resume next
dummy = wshell.RegRead(schl)
if err.number=0 then
RegExists=true
else
RegExists = false
err.clear
end if
end function
Bitte warten ..
Mitglied: laggflor
22.12.2007 um 18:00 Uhr
Welches Programm macht die Änderung eigentlich?
Lad dir doch mal Regmon runter und versuch damit rauszufinden wann / unter welchen Umständen die Änderung passiert.
Regmon bekommst du bei http://technet.microsoft.com/en-us/sysinternals/bb896652.aspx

Ist glaub ich gescheidter das Problem anzugehen als den "Workaround" zu korrigieren.

Wegen dem Script...
kommentier mal alle "wshell.reg*" aus und teste die einzeln.
Dann weißt du genau welche Anweisung genau den Fehler ins Log schreibt.

Grüße
Florian
Bitte warten ..
Mitglied: AndiK66
24.12.2007 um 15:25 Uhr
Also als erstes mal hab ich jetzt rausgefunden dass es die Installation des IE7 war, die diese kuriosität verursacht hat. ich hab ihn nochmal deinstalliert und danach geschaut, ob der eintrag im ereignisprotokoll noch auftritt. dem war nicht so. nachdem das geklärt war hab ich den IE7 wieder aufgespielt und siehe da das skript wird beim herunterfahren geblockt; aber diesmal wirklich geblockt nicht nur der eintrag im EP geschrieben. das lag also definitiv an dieser (wohl fehlerhaften) installation des IE7. soweit so gut. jetzt stellt sich natürlich die frage warum das skript von windows nach der install des IE7 geblockt wird und wie ich das abstellen kann.

Lad dir doch mal Regmon runter und versuch
damit rauszufinden wann / unter welchen
Umständen die Änderung passiert.

hab ich getan. nachdem ich mein skript manuell starte schreibt wscript natürlich die einträge ("HKCR\htmlfile\DefaultIcon" und "HKCR\wow6432node\htmlfile\DefaultIcon").
sobald ich nun irgendeins der officeprogs starte (egal welches) schreibt die jeweilige exe während das prog startet die einträge wieder auf "%1" und das Icon ist nach nem neustart weg.
Ich hab das ganze an nem anderen rechner ausprobiert und da ist es genau dasselbe. nur dass an diesem rechner welcher auf 32bit windows läuft der registry-wert zwar auch auf "%1" geschrieben wird, jedoch das icon trotzdem nach nem neustart richtig angezeigt wird. d.h. 64bit windows interpretiert den registry-eintrag dann wohl anders als ein 32bit windows.
es spielt übrigens keine rolle ob das office xp oder office 2007 ist; beide machen genau dasselbe.

Ist glaub ich gescheidter das Problem
anzugehen als den "Workaround" zu
korrigieren.

da stimm ich dir mitlerweile zu. nur dass ich noch nichts im i-net dazu gefunden hab. weder zum skript-nicht-ausführen- noch zum office-%1-problem.
das einzige was ich herausgefunden hab ist, dass wenn ich das skript beim abmelden statt herunterfahren ausführen lasse, dann funktioniert es.
falls dir/euch noch etwas dazu einfallen würde wäre das echt super, ich bin nämlich soweit mit meinem latein am ende.

Ansonsten frohe weihnachten und lasst euch schön beschenken.

Gruß
AndiK66
Bitte warten ..
Mitglied: laggflor
24.12.2007 um 17:35 Uhr
Schau dir mal das hier an:
http://www.neowin.net/forum/index.php?showtopic=506252&st=0&sta ...
Der Beitrag vom Oct 28 2006, 08:22
Das Herunterladen des Scriptes klappt zwar nicht, der Großteil ist aber im Beitrag selbst angeführt.
Solltest du hinbekommen.

oder in der Microsoft-Newsgroup:
http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx ...
http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx ...
Auch hier wird das oben genannte Script angeführt.

In der entsprechenden Microsoft-Newsgroup gibts viele Leute die das selbe Problem haben.

Ich hoff mal das hilft. Für immer

Frohes Fest
Florian (http://www.lagg.at)
Bitte warten ..
Mitglied: AndiK66
24.12.2007 um 18:14 Uhr
Schau dir mal das hier an:
http://www.neowin.net/forum/index.php?showtopic=506252&st=0&sta ...
Der Beitrag vom Oct 28 2006, 08:22
Das Herunterladen des Scriptes klappt zwar
nicht, der Großteil ist aber im Beitrag
selbst angeführt.
Solltest du hinbekommen.

Vielen Dank. so wie es scheint hat das echt geholfen.

Jetzt ist auch mein Weihnachten gerettet und das kommende Jahr kann kommen.

Mit freundlichen Grüßen
AndiK66
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Skript per GPO ausführen - Berechtigungen? (13)

Frage von honeybee zum Thema Windows Server ...

Windows 10
gelöst Laptop nicht herunterfahren beim Zuklappen u. HDMI (2)

Frage von PharIT zum Thema Windows 10 ...

Batch & Shell
gelöst WinXP-PC mit einem Barcodescanner herunterfahren (8)

Frage von Sinzal zum Thema Batch & Shell ...

Batch & Shell
Powershell CHAT Skript (5)

Frage von xpxy15 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...