Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Hilfe bei Wenn Dann Funktion in Excel

Frage Microsoft Microsoft Office

Mitglied: Humphrey01

Humphrey01 (Level 1) - Jetzt verbinden

26.04.2014 um 12:36 Uhr, 2007 Aufrufe, 8 Kommentare, 1 Danke

Guten Tag,

benötige Hilfe beim anlegen einer "Wenn Dann" Funktion. Ich lege gerade einen Dienstplan in Excel an. Dort hätte ich gerne, dass in der Zelle F24 (gesamte Arbeitsstunden am Tag) der Wert 8:00 (h:mm) auftaucht wenn in der Zelle D22 das Wort Schule eingetragen wird!? Ähnliches habe ich beim Wort Feiertag vor usw. Welcher Crack kann mir da helfen?
Mitglied: certifiedit.net
26.04.2014 um 12:41 Uhr
Hallo

01.
=WENN(Zelle="Schule";8;0)
Grüße,
Christian
Bitte warten ..
Mitglied: bastla
26.04.2014 um 13:05 Uhr
... bzw wenn es wirklich die Uhrzeit sein soll:
=WENN(D22="Schule";ZEITWERT("8:00");0)
Grüße
bastla
Bitte warten ..
Mitglied: certifiedit.net
26.04.2014, aktualisiert um 13:13 Uhr
Zitat von bastla:

... bzw wenn es wirklich die Uhrzeit sein soll:
=WENN(D22="Schule";ZEITWERT("8:00");0) 
> 
Grüße
bastla

Danke @bastla für die konstruktive Ergänzung.;)
Bitte warten ..
Mitglied: Humphrey01
26.04.2014 um 13:17 Uhr
Vielen Dank für die Hilfe, Habe bereits in der Betreffenden Zelle eine Formel hinterlegt "=SUMME(F22:F23)" kann ich die von Dir angegebene Funktion einfach anhängen? oder ist eine bestimmt Reihenfolge bzw. ein entsprechendes Trennzeichen von Nöten?
Bitte warten ..
Mitglied: certifiedit.net
26.04.2014 um 13:21 Uhr
Gerne, Die Summe ergibt sich woraus? Du musst im Prinzip nur die Mathematischen Verhältnisse beachten. Wenn die Summe der Stellenäquivalent zum genannten 8 Stunden Wert darstellen soll, dann eben dort.
Bitte warten ..
Mitglied: bastla
26.04.2014 um 13:21 Uhr
Hallo Humphrey01 und willkommen im Forum!

Wenn nur gerechnet werden soll, wenn nicht in Zelle D22 "Schule" steht, dann
=WENN(D22="Schule";ZEITWERT("8:00");SUMME(F22:F23))
- ansonsten müsstest Du Dein Vorhaben genauer erklären ...

Grüße
bastla
Bitte warten ..
Mitglied: Humphrey01
26.04.2014 um 13:52 Uhr
Danke für die Gelegenheit meine Herausforderung zu schildern.
Also in Spalte 22 habe zwei Zellen in denen ich die Arbeitszeit D22(von) und E22 (bis) eingebe. In Spalte 23 habe ich im Rahmen eines möglichen Teildienstes noch zwei Zellen D23 (von) und E23 (bis) in denen ich die zweite Arbeitszeit eingeben kann. Die Zelle F22 errechnet die Arbeitsstunden aus D22 und E22. Die Zelle F23 errechnet die Arbeitsstunden aus D23 und E23. Die Zeile F24 errechnet die Gesamtstundenzahl aus F22 und F23. Ich möchte das F24 mir entweder die Gesamtstunden aus F22 und F23 errechnet oder im Falle dessen das in F22 oder F23 das Wort "Schule" eingegeben wird automatischen den Wert auf 8 Std. setzt!
Bitte warten ..
Mitglied: 115420
26.04.2014, aktualisiert 27.04.2014
Hallo Humphrey01!

Danke für die Gelegenheit meine Herausforderung zu schildern. Also in Spalte 22 habe zwei Zellen in denen ich die Arbeitszeit D22(von) und E22 (bis) eingebe. In Spalte 23 habe ich im Rahmen eines möglichen Teildienstes noch zwei Zellen D23 (von) und E23 (bis) in denen ich die zweite Arbeitszeit eingeben kann. Die Zelle F22 errechnet die Arbeitsstunden aus D22 und E22. Die Zelle F23 errechnet die Arbeitsstunden aus D23 und E23. Die Zeile F24 errechnet die Gesamtstundenzahl aus F22 und F23. Ich möchte das F24 mir entweder die Gesamtstunden aus F22 und F23 errechnet oder im Falle dessen das in F22 oder F23 das Wort "Schule" eingegeben wird automatischen den Wert auf 8 Std. setzt!
Seltsames Konstrukt

Anhand Deines Beispiels, in etwa so:
A B C D E F G H I
...
22 08:00 16:00 08:00 schule 08:00
23 09:00 15:00 06:00 feiertag 00:00
24 14:00 sonstiges 04:00

Wobei in den Zellen F22/23 ursprünglich die Formeln "=E22-D22"/"=E23-D23" stehen, die gegebenenfalls mit einem Text überschrieben werden???

In der Zelle F24 würde diese Formel stehen:
01.
=WENN(UND(ISTZAHL(F22);ISTZAHL(F23));SUMME(F22:F23);WENN(ISTZAHL(F23);SVERWEIS(F22;H22:I24;2;FALSCH);SVERWEIS(F23;H22:I24;2;FALSCH)))
Wird in F22 oder F23 ein Wort aus der H-Spalte eingegeben, dann wird in F24 der entsprechende Wert aus der I-Spalte angezeigt....

Grüße
spatzenhirn
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Hilfe bei Erstellung eines Suchfelds im Excel (1)

Frage von ZeeRee zum Thema Microsoft Office ...

VB for Applications
gelöst VBA Excel Skript - Hilfe! (1)

Frage von 133202 zum Thema VB for Applications ...

Microsoft Office
gelöst Excel 2010 Funktion ZÄHLENWENN in einer Zahlenkette (2)

Frage von yv35k0 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (21)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (12)

Frage von alemanne21 zum Thema Webentwicklung ...