Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

HMailServer im LAN über öffentliche IP nicht erreichbar

Frage Internet E-Mail

Mitglied: TomJones

TomJones (Level 1) - Jetzt verbinden

27.08.2014, aktualisiert 14:04 Uhr, 1595 Aufrufe, 10 Kommentare

Hallo zusammen,

ich habe ein Problem mit einem Telekom Speedport W723v.

Ich habe einen hMailServer laufen welcher aus dem Internet über IMAP erreichbar ist.
Wenn sich die Geräte außerhalb des Firmen WLANs aufhalten funktioniert der Zugriff.

Sobald die Gerät mit dem Firmen WLAN verbunden sind, funktioniert der Zugriff nicht mehr.
Das Problem in meinem Fall ist der Speedport und das Thema Nat Loopback.

Auf den Geräten ist beim E-Mail Server die öffentliche IP eingetragen, logisch.

Haben Router anderer Hersteller wie z.B. ZyXEL oder Netgear auch dieses "Problem"?
Mitglied: Sheogorath
27.08.2014 um 13:29 Uhr
Moin,

hat dein Mailserver nicht auch eine Lokale IP? wenn ja, vergib einfach einen lokalen DNS Alias, das reicht dann schon.

Gruß
Chris
Bitte warten ..
Mitglied: TomJones
27.08.2014 um 13:32 Uhr
Moin,

was meinst Du damit?

Klar hat mein hMailServer auch eine lokale IP, in meinem Fall: 192.168.10.1
Der hMailServer läuft auf einem Server 2008 R2.

Ich muss doch so, oder so, die WAN IP bei meinen Geräten eintragen, damit diese aus dem Internet sich mit dem hMailServer verbinden können.
Bitte warten ..
Mitglied: jsysde
LÖSUNG 27.08.2014, aktualisiert um 14:04 Uhr
Moin.
Zitat von TomJones:
Ich muss doch so, oder so, die WAN IP bei meinen Geräten eintragen, damit diese aus dem Internet sich mit dem hMailServer
verbinden können.

Nö - normalerweise trägt man da nen DNS-Namen ein, der von extern auf deine WAN-IP und von intern auf die LAN-IP aufgelöst wird.

Um deine Frage wegen dem Speedport zu beantworten:
Ja, das "Problem" haben auch andere Router, ich hatte es bei meiner Witzbox auch - habe ich zwar gelöst bekommen, kann ich mich aber nicht mehr dran erinneren, wie genau (nutze hMailServer nicht mehr, daher....). Meine aber, irgendwas an der Portforwardings gebastelt zu haben.

Cheers,
jsysde
Bitte warten ..
Mitglied: TomJones
27.08.2014 um 13:43 Uhr
Zitat von jsysde:

Moin.
> Zitat von TomJones:
> Ich muss doch so, oder so, die WAN IP bei meinen Geräten eintragen, damit diese aus dem Internet sich mit dem
hMailServer
> verbinden können.

Nö - normalerweise trägt man da nen DNS-Namen ein, der von extern auf deine WAN-IP und von intern auf die LAN-IP
aufgelöst wird.

Um deine Frage wegen dem Speedport zu beantworten:
Ja, das "Problem" haben auch andere Router, ich hatte es bei meiner Witzbox auch - habe ich zwar gelöst bekommen,
kann ich mich aber nicht mehr dran erinneren, wie genau (nutze hMailServer nicht mehr, daher....). Meine aber, irgendwas an der
Portforwardings gebastelt zu haben.

Cheers,
jsysde

Moin,

meinst Du damit, dass ich bei den Geräten z.B. mail.firma.de eintrage.
mail.firma.de verweist dann auf die öffentliche IP.

Und an dem DNS-Server im LAN (Server 2008 R2) trage ich dann ein, dass mail.firma.de die IP 192.168.10.1 hat?
Bitte warten ..
Mitglied: jsysde
27.08.2014 um 13:46 Uhr
Moin.
Zitat von TomJones:
meinst Du damit, dass ich bei den Geräten z.B. mail.firma.de eintrage.
mail.firma.de verweist dann auf die öffentliche IP.

Und an dem DNS-Server im LAN (Server 2008 R2) trage ich dann ein, dass mail.firma.de die IP 192.168.10.1 hat?

Touché.

Cheers,
jsysde
Bitte warten ..
Mitglied: TomJones
27.08.2014 um 13:52 Uhr
Ok, macht Sinn, hätte man auch selber drauf kommen können...

Kannst Du mir auch noch einen Tipp geben, wie ich dieses realisiert bekomme?

Mache ich eine neue Forward-Lookupzone mit dem Namen der Domain mail.firma.de und darin einen neuen Host Eintrag mit der lokalen IP?
Bitte warten ..
Mitglied: TomJones
27.08.2014 um 14:04 Uhr
Ok Problem gelöst:

Neue Forward-Lookupzone mit dem Namen der Domain mail.firma.de und darin einen neuen Host Eintrag mit der lokalen IP


Ich danke Euch!
Bitte warten ..
Mitglied: jsysde
27.08.2014 um 14:05 Uhr
Moin.
Zitat von TomJones:
Mache ich eine neue Forward-Lookupzone mit dem Namen der Domain mail.firma.de und darin einen neuen Host Eintrag mit der lokalen
IP?

Vorweg:
Betreibst du ein Active Directory?

Gibt es im internen DNS bereits eine Zone firma.de?
Wenn ja, dann einfach auf _deinem internen_ DNS den Host mail anlegen mit der internen IP.
Alles andere, was firma.de betrifft, sollte ja dann bereits dort hinterlegt sein.

Gibt es die Zone bisher firma.de, dann kannst du diese natürlich anlegen, musst dann aber alle Hosts (die du sonst über nen öffentlichen DNS abfragen kannst) auch in dieser Zone hinterlegen, z.B. www usw.

Cheers,
jsysde
Bitte warten ..
Mitglied: TomJones
27.08.2014 um 14:08 Uhr
Ja ist ein Active Directory,

Allerdings ist der interne Domain Name firma.local
Bitte warten ..
Mitglied: jsysde
27.08.2014 um 14:10 Uhr
Moin.
Zitat von TomJones:

Ja ist ein Active Directory,

Allerdings ist der interne Domain Name firma.local

Dann ist ja alles gut!

Cheers,
jsysde
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
DNS
gelöst Sophos UTM9 - FTP nur über IP erreichbar (4)

Frage von PronMaster zum Thema DNS ...

Router & Routing
Lancom N:N-NAT - öffentliche IP und Firewall

Frage von devil77 zum Thema Router & Routing ...

Netzwerke
LAN und WLAN je mit gleicher IP (13)

Frage von dauatitsbest zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...