Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

HMailserver - mal wieder

Frage Internet E-Mail

Mitglied: Admimistrator

Admimistrator (Level 1) - Jetzt verbinden

12.03.2014 um 21:51 Uhr, 3089 Aufrufe, 4 Kommentare

Mittlerweile bin ich mehr als verwirrt und kann schon nicht mehr sagen, was ich alles ausprobiert habe. Also schildere ich die Problematik mal kurz.
Ich habe zuhause mehrere Rechner, mit denen ich Mails bei diversen Providern empfange. Der Hauptrechner löscht diese dann beim Abruf. Folglich sind die anderen Rechner nicht immer auf dem selben Stand. Also dachte ich mir, ich richte einen alten XP-Rechner her und fahre hMailserver 5.4 drauf, um alle Rechner via IMAP zu versorgen.

Ich habe die Domain haselfasel.de (Beispiel !!). Im hMailserver habe ich unter Domains "haselfasel.local" und dazu eine Mailadresse "info@haselfasel.local" erzeugt. Dort habe ich als externe Emailadresse "info@haselfasel.de" eingetragen. Dort wiederum stehen natürlich die Zugangsdaten zu diesem Postfach drin.

Der Empfang funktioniert.

Unter Einstellungen - Protokolle - SMTP - Versand von E-Mail habe ich beim lokalen Host "mailserver.local" eingetragen, aber bei Remote Hostnamen nichts. Ausgewählt sind Remote-E-Mailadresse für Absender und Empfänger. Der lokale Hostname "mailserver.local" taucht übrigens ansonsten nirgends namentlich auf. Ich habe ihn so gewählt, damit klar ist, daß hier keine Domain gemeint ist. Möglicherweise gibt es hier einen Fehler, aber - wie schon gesagt - der Mailempfang klappt ja, der Versand aber eben nicht, egal was ich hier eintrage.
Bei Routen steht als Domain "haselfasel.local" drin und bei Adressen "Stelle allen Adressen zu".
Der Versand nach extern funktioniert nicht. Im Protokoll wird dann gemeldet "RECEIVED: 450 4.1.8 <info@haselfasel.local>: Sender address rejected: Domain not found". Mir ist schon klar, dass die Domain haselfasel.local nicht gefunden werden kann. Soll sie ja auch nicht. Ich bin bisher davon ausgegangen, daß der hMailserver die interne Mailadresse beim Senden durch die externe ersetzt, so daß dem Provider vorgegaukelt wird, die Mail käme von info@haselfasel.de. Das ist aber offensichtlich ein Irrtum. Hier habe ich ein Verständnisproblem!

Desweiteren habe ich Verständnisschwierigkeiten mit dem Punkt Einstellungen - SMTP. Ich nutze mehrere Provider. Hier kann ich bei "Versand von E-Mail" aber nur einen SMTP-Relayer eintragen. Muß ich diesen Eintrag für den Remote Hostnamen nun leer lassen und stattdessen die diversen Provider über den Punkt "Routen" eintragen?

Bei einem GMX-Postfach bekomme ich übrigens eine andere Rückmeldung und zwar "554 No SMTP service - IP address is black listed".

Ich möchte eigentlich keine Domain über dyndns einrichten, die auf meinen Server zeigt, oder geht es nicht anders?
Mitglied: Looser27
13.03.2014 um 11:11 Uhr
Moin,

Du solltest einfach die interne Domain exact wie die externe Domain benennen, in Deinem Fall "haselfasel.de".
Als SMTP Relayer kannst Du einen Deiner Provider nehmen.

Gruß

Looser27
Bitte warten ..
Mitglied: Admimistrator
13.03.2014 um 11:32 Uhr
Ist das nun geraten oder gewußt? ;)
Denn das scheint nicht zu klappen. Kann aber auch sein, daß sich damit andere Einstellungen ergeben, die ich so noch nicht erkannt habe.
Außerdem habe ich diverse Email-Accounts bei verschiedenen Providern, weswegen mir nicht klar ist, warum ich beim Relayer nun "meinen Provider" eintragen soll bzw. welchen von den fünf vorhandenen? ;)
Die Oberfläche des Programms ist diesbezüglich für mich nicht schlüssig.
Bitte warten ..
Mitglied: Looser27
13.03.2014 um 11:39 Uhr
Ich hab den hmailserver selber mit mehreren Domains im Einsatz gehabt.
Die interne Domain wie die externe benennen umgeht das Problem, dass die Mailendung "übersetzt" werden muß.

Beim Relayer trägst Du einen der Provider ein, von denen Du abholst. Welchen spielt eigentlich keine Rolle.

Das Abholen und Versenden solltest Du noch über Port 465 SSL laufen lassen, da z.B. GMX keinen Kontakt unverschlüsselt mehr zulässt.

Gruß Looser27
Bitte warten ..
Mitglied: Admimistrator
13.03.2014 um 17:02 Uhr
Hab vielen Dank! Zwischenzeitlich klappte es mal kurz. Nun sendet hMailserver wieder nicht. Möglicherweise sendete er auch nur lokal zu lokal. Ich muß mal einen Tag Pause machen, um den Kopf frei zu bekommen. Aber DANN! ;)
Bitte warten ..
Ähnliche Inhalte
Python
gelöst Python mal utf-8 mal nicht (1)

Frage von peterpa zum Thema Python ...

Administrator.de Feedback
gelöst War das hier nicht mal werbefrei? (10)

Frage von keine-ahnung zum Thema Administrator.de Feedback ...

Cloud-Dienste
Encfs als mal wieder defekte Dateien (8)

Frage von Thor01 zum Thema Cloud-Dienste ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
Uninitialisierte Festplatte - Daten retten (10)

Frage von peterla zum Thema Festplatten, SSD, Raid ...

Microsoft Office
Outlook 2016 in Ordneransicht starten - GPO (9)

Frage von D-Line zum Thema Microsoft Office ...