Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Homepage auf Webserver

Frage Entwicklung HTML

Mitglied: Sapzero

Sapzero (Level 1) - Jetzt verbinden

03.12.2008, aktualisiert 22:37 Uhr, 6022 Aufrufe, 10 Kommentare

Hallo,
ich habe mir zur Hause ein FTP Server angelegt mit Hilfe meines Routers (Fritzbox 7270), sowie eine Domain sapzero.homeftp.net von dyndns.org (die IP aktualisiert sich von selber durch mein Router).
Ein USB-Stick ist an meinen Router angeschlossen und fungiert als FTP Server.
Wenn ich ftp://sapzero.homeftp.net eingebe erscheint auch die Oberfläche und das uploaden oder downloaden funktioniert auch ohne Probleme (mit fireftp firefox).
Bis dorthin ist noch alles klar, jedoch habe ich mir eine Homepage angelegt und will es als Startseite benutzen wenn ich die URL in Browser eingebe. Also es soll die Homepage anzeigen wenn ich http://sapzero.homeftp.net eingebe, welches noch nicht funktioniert.
Kann mir jemand da weiterhelfen würde mich auf eine schnelle Antwort sehr freuen.

Mit freundlichen Grüßen
Sapzero
Mitglied: petenicker
03.12.2008 um 20:17 Uhr
Hallo,

was hast du denn für einen Webserver installiert? Du schreibst in deinem Beitrag nur von einem FTP-Server auf dem Stick.

Gruß
petenicker
Bitte warten ..
Mitglied: Sapzero
03.12.2008 um 20:29 Uhr
Ich hab kein Webserver installiert. Auf meinem USB sind nur ein paar Dateien die ich mit fireftp draufgeladen habe.
Ich benutze nur den USB-Stick als Server man könnte es auch als Festplatte sehen die vom internet aus genutzt werden kann.
Bitte warten ..
Mitglied: petenicker
03.12.2008 um 21:12 Uhr
Der nicht existente Webserver ist das Problem. Laut Handbuch ist ein FTP-Zugriff auf den USB-Stick möglich. Das FTP-Protokoll benutzt den Port 21. Das HTTP-Protokoll jedoch Port 80.

D.h. bei der Eingabe von http://sapzero.homeftp.net/ erhält dein Router von außerhalb eine Anfrage auf Port 80. Der Router weiß nun aber nicht, was er mit den Datenpaketen anfangen soll. Ihm fehlt die Weiterleitung auf einen Webserver, der wiederum auf Port 80 lauscht.
Bitte warten ..
Mitglied: Sapzero
03.12.2008 um 21:54 Uhr
wie könnte ich dann es weiterleiten???
Es ist mir auch aufgefallen das wenn ich es direkt an mein pc anschliße den Stick es http://sapzero.homeftp.net erkennt
aber nicht wenn ich es an mein Router anschließe
Bitte warten ..
Mitglied: Sapzero
03.12.2008 um 21:56 Uhr
Ich habe jetzt auch noch XAMPP auf mein USB Stick installiert aber es geht trotzdem nicht wie könnte ich den die anfrage auf pot 80 weiterleiten.
Ich habe auch noch den Port 80 freigeschaltet.
Bitte warten ..
Mitglied: HightopOne
03.12.2008 um 22:28 Uhr
Zitat von Sapzero:
Ich habe jetzt auch noch XAMPP auf mein USB Stick installiert aber es
geht trotzdem nicht wie könnte ich den die anfrage auf pot 80
weiterleiten.
Ich habe auch noch den Port 80 freigeschaltet.

ist ja schön,dass du dieses alles gemacht hast,aber es wird nix bringen,der Kollegen hat es deutlich gesagt hier nochmal das zitat und es gilt noch immer,egal was du tust,es hat gültigkeit.

Zitat von petenicker:
Der nicht existente Webserver ist das Problem. Laut Handbuch ist ein
FTP-Zugriff auf den USB-Stick möglich. Das FTP-Protokoll benutzt
den Port 21. Das HTTP-Protokoll jedoch Port 80.

D.h. bei der Eingabe von http://sapzero.homeftp.net/ erhält dein
Router von außerhalb eine Anfrage auf Port 80. Der Router
weiß nun aber nicht, was er mit den Datenpaketen anfangen soll.
Ihm fehlt die Weiterleitung auf einen Webserver, der wiederum auf Port
80 lauscht.

Im Klartext heisst,dass wenn dein router nur FTP-Server spielen kann und kein HTTP-Server spielt,solange wird die Adresse von DynDns ->immer<- an den FTP-Server weitergeleitet,weil dein Router eine anfrage an den Port 21 weiterleitet und nicht an den Port 80 des integrierten Servers des Routers und nein es hilft nichts,wenn du den Port 80 freischaltest,weil die FW für die Clients gedacht ist.

In Neudeutsch:
Konkret nix HTTP Server in krasse Routermaschine,dann konkret nix mit krasse Website im www.
Bitte warten ..
Mitglied: Sapzero
03.12.2008 um 22:37 Uhr
ja ok habs ja verstanden. Wieso gleich so beledigend.
Bitte warten ..
Mitglied: congernet
27.03.2009 um 12:15 Uhr
hallo,
ich frage nach einer ähnlichen problematik.
zuhause habe ich ein webstar cabelmodem, den netgear wgr 614v5 wlan-router und ein longshine lcs-8240 usb-server mit einem usb-speicherstick. mein isp ist infocity 1000/256, der firma telecolumbus, über kabelmultimediaanschluss.
per dyndns.com hatte ich bereits einmal einen zugang aus dem internet auf einen web-ordner des usb-sticks realisiert und auch mehrere homepages erreichbar gemacht. seit einiger zeit, wahrscheinlich seit einem firmware-update des wlan-router, funktioniert es allerdings nicht mehr und ich finde keine funktionierende einstellung meinen web-ordner im internet wieder zugänglich zu machen. scheinbar schickt der router dyndns.com nicht die korrekte ip-adresse oder dyndns.com ändert diese in eine andere und lässt die verbindung mit dem domain-namen zu meinem usb-server nicht mehr entstehen. ich habe nun schon viel zu viel zeit mit probieren und im internet informieren verbracht und stehe kurz vor der kapitulation zum vorhaben 3 homepages auf meinem usb-server im internet erreichbar zu machen.
der c´t online-port-scanner listet die per port-forwarding am router zum usb-server eingetragenen ports 21, 80, 8080 als offen, wobei eigentlich nur port 8080 ausreichen sollte.
besteht unter umständen auch die möglichkeit das mein isp diese funktion unterbindet, leider gab es zu technischen fragen per email und telefon bisher noch nie brauchbare informationen.
der dns-server ist laut tracert: ns.blue-cable.net bzw. ns2.blue-cable.net.
für hinweise und informationen bezüglich korrekter gateway- und dns- ip-adressen und weiterer möglicher fehler bin ich dankbar.
Bitte warten ..
Mitglied: Sapzero
27.03.2009 um 21:32 Uhr
Hi,
soweit ich es weis leitet der Router nur die anfragen auf port 21(FTP) auf dein USB weiter. Du bräuchtes den Port 80(Webserver) für deinen Homepage auch wenn du ihn freischaltest leitet dein router nicht die anfrage auf den USB weiter und somit ist auch dein Homepage auf dem usb Stick nicht erreichbar. Also ist der USB Stich nur als FTP Server zu gebrauchen und nicht als Webserver zurzeit jedenfalls.
Ich hatte mich auch im Internet informiert und keine Lösung gefunden. Die einzige Lösung die genannt wurde war das man an der Firmware selber rumproammieren muss um das möglich zu machen, was dazu führen kann, dass du dein Rouer schrottest. Oder man wartet bis bei einer Firmware aktuslisierung das schon möglich ist.

Falls du eine andere Lösung findest würde ich mich freuen wenn du sie mir mitteilen würdest.

Mit freundlichen Grüßen
Sapzero
Bitte warten ..
Mitglied: congernet
27.03.2009 um 22:06 Uhr
hallo,
schon einmal danke für die schnelle antwort.
ich versuche die problematik noch einmal genauer zu beschreiben, da es im prinzip schon funktioniert jedoch im moment nur per umweg.
aktuell ist es so das der router eine ip-adresse an "dyndns.com" sendet und den von mir gewählten domainnamen damit verknüpft. nun ist diese ip-adresse aber gar nicht die mit der das modem im internet angemeldet ist. innerhalb meines netzwerkes kann ich mit dem von mir gewählten domain-namen oder der an "dyndns.com" übermittelten ip-adresse meinen web-ordner im usb-stick erreichen jedoch nicht von außerhalb. für diesen test nutze ich dann mein umts-funktelefon. wenn ich es aber mit der ip-adresse versuche die mir beispielsweise "wieistmeineip.de" anzeigt, also meine tatsächliche, dann kann ich meine homepages von außerhalb und zwar nur von außerhalb abrufen.
theoretisch macht ja dann der router etwas verkehrt oder er erhält, warum auch immer, nicht die korrekte ip-adresse vom modem.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Apache Server
gelöst Apache Webserver HTTP 500 Error (7)

Frage von ClepToManix zum Thema Apache Server ...

LAN, WAN, Wireless
gelöst Webserver Errichbarkeit aus dem Internet über einen Reverse Proxy (5)

Frage von mario87 zum Thema LAN, WAN, Wireless ...

Netzwerke
TP-ER5120 DMZ für Webserver (13)

Frage von ajudran zum Thema Netzwerke ...

Erkennung und -Abwehr
gelöst IT-Sicherheit für eigenen Raspberry Pi Webserver im Heimnetzwerk erhöhen (19)

Frage von mastermaiksen zum Thema Erkennung und -Abwehr ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (29)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...