Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Warum kann Hostname über WLAN nicht aufgelöst werden?

Frage Netzwerke DNS

Mitglied: 87533

87533 (Level 1)

06.02.2010, aktualisiert 18.10.2012, 17659 Aufrufe, 19 Kommentare

Grade habe ich meinen Netzwerk-Kurs abgeschlossen, bekomme aber trotz intensiver Nachforschung und Informationssuche mein Problem im eigenen Heim-Netzwerk nicht gelöst. Vermutlich habe ich etwas falsch eingestellt - nur was? Und wo?

Habe ein ganz einfaches Heim-Netzwerk mit mehreren Rechnern, die an einem Netgear-Router hängen.
An einem dieser Rechner hängt unser Drucker, sind auch zentral Dateien untergebracht.

Nun habe ich den Effekt, daß ich über den LAN-Anschluß meines Laptop den Rechner mit dem Drucker per Hostname ansprechen kann - über WLAN funktioniert das jedoch nicht - bzw. nach dem Abziehen des Kabels etwa noch eine halbe Minute lang.
Dann kommt für einen "ping hostname" die Meldung "Host konnte nicht gefunden werden".
Per IP kann der Rechner erreicht werden - und so habe ich ersatzweise den Drucker ein zweites Mal eingerichtet, diesmal mit der IP in der Adressierung, damit ich vom Lappy aus über WLAN drucken kann.

Zugang ins Internet ist sowohl über LAN als auch über WLAN problemlos möglich.

Hat mir jemand einen Tipp, wo ich drehen muß, damit die interne Host-Namensauflösung auch über WLAN funktioniert?

Vielen Dank!
Mitglied: Cometcola
06.02.2010 um 15:14 Uhr
moin,

was mir spontan einfällt, du hast bei deinem Access Point (oder im Router selbst), kein Standard Gateway gesetzt, oder aber an deinem Notebook ist "DNS-Server automatisch beziehen" nicht aktiviert. Ein paar mehr Informationen besonders zur Konfiguration wären hier sehr hilfreich
Bitte warten ..
Mitglied: 87533
06.02.2010 um 15:38 Uhr
Na klar - wollte nur nicht gleich eine Datenflut absetzen - für einen vielleicht banalen Denkfehler.

Also - ich arbeite auf beiden Rechnern mit Windows XP, der Rechner mit dem Drucker hat die Prof-Version, mein Lappy die Home-Edition.

Der Router ist ein Netgear ProSafe 802.11g
Die WLAN-Karte nennt sich Netgear WG511

In den Eigenschaften der Netzwerkverbindungen (sowohl LAN als auch WLAN) ist unter "Internetprotokoll TCP/IP"-Eigenschaften sowohl "IP-Adresse automatisch beziehen" als auch "DNS-Serveradresse automatisch beziehen" eingetragen - somit kann ist das Feld für "Standard-Gateway" deaktiviert.

Für die WLAN-Karte benutze ich das Progi des Herstellers - dort hat er im "Verbindungsstatus" die IP des Routers als Standard-Gateway eingetragen.

Im Router kann ich nichts finden, wo ich einen Standard-Gateway eintragen könnte.
Bitte warten ..
Mitglied: Cometcola
06.02.2010 um 15:46 Uhr
also wenn die WLAN Funktion im Router integriert ist, dann wirst du kein Standard-Gateway finden. (Meine Überlegung, lasse mich gerne belehren)

Funktioniert den die Namesauflösung bei anderen Computern?
Bitte warten ..
Mitglied: Raducanu
06.02.2010 um 17:17 Uhr
bei LAN wie auch WLAN der selbe dhcp server und dns suffix?
ipconfig -all
und bei
"Verbindungsspezifisches DNS-Suffix" sollte bei beiden verbindungen das selbe stehen
Bitte warten ..
Mitglied: aqui
06.02.2010, aktualisiert 18.10.2012
Ohne einen DNS Server im Netz geht die lokalen Windows Namensauflösung per UDP Broadcast vonstatten ! Das kann damit dann laut Microsoft Knowledge Base bis zu 45 Minuten dauern bis die Namen sich gegenseitig bekannt gemacht haben.
Deshalb ist das Gateway oder irgendwelche DNS Server am Router unsinnig, denn sie gelten nur für die Internet Namensauflösung niemals aber für die Auflösung der lokalen Namen im Netz...vergiss das also.

Damit du nicht immer auf den Namensbroadcast warten musst solltest du den lokalen Namen des Drucker PCs ganz einfach statisch in die Datei lmhosts eintragen. Damit klappt das dann auch Anhieb ohne Wartezeit.
Wie das genau geht beschreibt dir dieser Thread:
http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...
Bitte warten ..
Mitglied: 87533
06.02.2010 um 22:04 Uhr
zu Rückfrage von Cometcola:

Hm ... "Standard-Gateway" im Router ist m.E. der DNS-Server des Providers ... oder so.
Aber das ist ja nur für Internet-Adressen ... und das funktioniert ja.

Namensauflösung bei anderen Computern ... hm. Da hab ich jetzt wohl grade in ein Wespennest gestochen. Junior meinte zu Weihnachten, sein Lappy funktioniert problemlos.
Aber Junior ist samt Lappy weg.

Habe aber die 2 Lappys meiner Tochter da - beide mit Vista (bitte kein Aufschrei ...)
im Folgenden Lappy 2 und Lappy 3 genannt
Habe also mit pings getestet - und bin zu folgendem Ergebnis gekommen:

Lappy1 (meiner, mit XP - IP meist = 192.168.0.2 ):
ping --> Drucker-PC = "nicht gefunden" ... / ping mit IP = "OK"
ping --> Lappy 2 = "nicht gefunden" ........... / ping mit IP = "OK" (aber nicht immer)
ping --> Lappy 3 = "nicht gefunden" ........... / ping mit IP = "Zeitüberschreitung"
ping --> Lappy 1 = "OK"

Lappy2 (mit Vista - IP meist 192.168.0.3 ):
ping --> Drucker-PC = "OK" ........................ / ping mit IP = "OK"
ping --> Lappy 3 = "Zeitüberschreitung" ... / ping mit IP = "Zeitüberschreitung"
ping --> Lappy 1 = "nicht gefunden" ........... / ping mit IP = "Zeitüberschreitung"
ping --> Lappy 2 = "OK"

Lappy3 (mit Vista - IP meist 192.168.0.5):
ping --> Drucker-PC = "nicht gefunden" ... / ping mit IP = "OK"
ping --> Lappy 2 = "OK"............................ ... / ping mit IP = "OK" - aber nicht immer
ping --> Lappy 1 = "nicht gefunden" ........... / ping mit IP = "Zeitüberschreitung"
ping --> Lappy 3 = "OK"

... und zu guter letzt - Drucker-PC (mit XP-prof - IP fest 192.168.0.4):
ping --> Lappy 1 = "nicht gefunden" ........... / ping mit IP = "Zeitüberschreitung"
ping --> Lappy 2 = "OK"............................ ... / ping mit IP = "OK"
ping --> Lappy 3 = "nicht gefunden" ........... / ping mit IP = "Zeitüberschreitung"
ping --> Drucker-PC = "OK"

Da liegt also noch einiges im Argen ...
Bitte warten ..
Mitglied: 87533
06.02.2010 um 22:14 Uhr
zu Rückfrage von Raducanu:

Habe gleich nochmal alles überprüft:

IP-Adresse ist bei beiden "DHCP-aktiviert" - erledigt der Router.
DNS-Suffix ist bei beiden leer
Verbindungsspezifisches DNS-Suffix ist auch bei beiden leer.

ipconfig /all unterscheidet sich, haben ja unterschiedliche IP-Adressen.

Gibt es da evtl. einen Parameter, den ich speziell überprüfen sollte?
Bitte warten ..
Mitglied: 87533
06.02.2010 um 22:23 Uhr
Zu Kommentar von aqui:

Hm ja - ein DNS-Server scheint mir dafür nicht zuständig ...
Vielleicht aber WINS? Oder NetBios?

Gut - das mit den 45 Minuten ... das merkt man beim Arp -a ...
Da erscheinen die Einträge aber, sobald ich mal einen Ping auf die IP abgesetzt habe.
Den Namen kann er deshalb aber trotzdem noch nicht auflösen.

Und - mein Lappy hängt mehr als diese 45 Minuten am Netz - der Drucker-PC ist trotzdem nicht über seinen Namen ansprechbar.

Das mit der Datei lmhosts ist in etwa dieselbe Lösung, die ich mit der IP in der Adressierung des Druckers habe - die IP muß jeweils fest zugeordnet sein, sonst geht das nicht.
Und den Eintrag muß ich manuell in jedem Rechner , der sich bei mir einklinkt, nachziehen.

Aber wie ich beim Test festgestellt habe, habe ich auch mit der WLAN-Verbindung zu den übrigen Rechnern ein Prob bei der Namensauflösung.
Bitte warten ..
Mitglied: Cometcola
07.02.2010 um 08:31 Uhr
moin.

probier doch einfach mal deine drei Laptops + PC an nen Switch (nicht am Router) zu hängen und bei gleicher Konfiguration die Tests nochmal durchzuführen. Wenn du Vista benutzt, gibt es ja die Netzwerkgruppen (Privat, Öffentlich etc...). Überpüfe mal bei den Laptops, ob du da überall in der Gruppe Privates Netzwerk (oder so ähnlich) bist.

Mfg
Cometcola
Bitte warten ..
Mitglied: 87533
07.02.2010 um 08:58 Uhr
Guten Morgen, Cometcola

Ich denke, in der Liste oben sind zweierlei Probs dokumentiert - einmal das mit der Zeitüberschreitung, da hat er garkeinen Kontakt - und dann daß er den Namen nicht auflösen kann.
Letzteres könnte mit ersterem zu tun haben - aber grade mit dem Drucker-PC gibt es den Fall "ping mit IP geht" - "ping mit Namen geht nicht".

Wenn ich die PC's an einen Switch hänge, dann hängen sie ja am Kabel - und am Kabel habe ich den Effekt ja nicht - zumindest beim Lappy1 hab ich das getestet.

Gut, Switch hab ich da noch keinen dazwischengehängt - muß erstmal gucken, wo mein Junior den nach der letzten LAN-Party vergraben hat.

Werde mal alle 3 Lappys an Kabels andocken und gucken was dann geht.
Und das mit den Vista-Gruppen guck ich mir auch an - werd' ich schon finden.

Danke fürs Mitdenken - Haska
Bitte warten ..
Mitglied: Raducanu
07.02.2010 um 10:35 Uhr
wenn kein dns server im netzwerk vorhanden ist (oder zumindest keiner, der die lokalen pc namen kennt) läuft das ganze über NetBios wie aqui schon schrieb.
Dieses funktioniert (wenn es denn mal funktioniert) sehr sehr langsam und nicht zuverlässig.
Entweder feste IP Adressen vergeben und die namen in die HOSTS Datei eintragen oder dns server mit dynamic updates
Bitte warten ..
Mitglied: 87533
07.02.2010 um 11:23 Uhr
Hm ... Du meinst also es kann nicht funktionieren?

Komischerweise hat es funktioniert - bis ich meinen Lappy neu aufgesetzt habe - und dann draufgekommen bin, daß in der Nachbarschaft noch zwei weitere Netgear-Access-Points erreichbar sind, die ich dann aussperren mußte.
Da vermute ich daß ich irgendwas falsch gemacht habe.

Und warum geht es dann, wenn die Lappys am Kabel hängen?
(Ob bei allen, muß ich noch testen.)

Die Liste der erreichbaren Rechner hat der Router - mit Namen.
Warum gibt er diese über Kabel weiter - und über WLAN nicht?

Wo und wie sollte ich einen DNS-Server platzieren?
Bitte warten ..
Mitglied: Cometcola
07.02.2010 um 11:29 Uhr
moin,

mal eine ganz vage und höchstwahrscheinlich falsche Theorie: Wählst du dich vllt bei deinem Nachbar ins WLAN ein?

Wenn diese kein Passwort gesetzt haben und sich deine Notebooks je nach verfügbarem WLAN anmelden....das könnte erklären, weshalb der Ping manchmal zwischen den Notebooks funktioniert und mal nicht.
Bitte warten ..
Mitglied: 87533
07.02.2010 um 11:56 Uhr
Ja, hast schon recht - den Effekt hatte ich anfangs echt mit meinem Lappy - weshalb der per WLAN nicht mehr ins Internet kam. Hab dann erstmal übers Kabel die MAC-Adresse von meinem Router ermittelt - und dann meinem Router einen "hübscheren" Namen als "NETGEAR" verpaßt - so hießen se nämlich alle ...
Auch lasse ich in auf einem deutlich anderen Kanal als der Nachbar arbeiten

Jetzt "sehe" ich also in den Einstellungen, mit welchem Router er verbunden ist - alles Oki.

Wenn ich wirklich am falschen Router hängen würde, könnte ich ja auch den Drucker-PC nicht über die IP-Adresse erreichen.

Und auch im Router sind die PC's als "Attached Devices" eingetragen.
Bitte warten ..
Mitglied: 87533
07.02.2010 um 20:19 Uhr
Uff - das war eine Aktion ...
Also - kurz gesagt: Wenn ich die Rechner alle ans Kabel hänge, funktioniert das mit der Namensauflösung - früher oder später.
Der Zugang zu meinem XP-Lappy erfolgt dabei mal übers WLAN, ein anderes mal über das LAN-Kabel.
Die zwei Vista-Lappys gehen über die IPv6 ... da bin ich mir nicht sicher, wie ich die interpretieren muß, insbesondere das %irgendwas am Ende. Könnte zwar vergleichen, war mir dann aber zu mühsam.

Was in der \"Netzwerkumgebung\" oder wie das jetzt bei Vista heißt angezeigt wird, ist nochmal ein anderes Thema ... Beim einen Vista-Lappy hatte ich alle Rechner, beim anderen nur die zwei Vista-Lappys ... Hätte gerne nach den nicht angezeigten Rechnern gesucht - aber iwie blicke ich da die Suchfunktion nicht mehr, wie ich da nach Computern suchen kann.

Mein XP-Lappy hatte auch alle Rechner ... der hat sie sogar noch angezeigt, nachdem ich zweie ausgeschaltet hatte - trotz Aktualisierung.

Also hat jetzt der eine Vista-Lappy trotz Kabel und erfolgreichem ping mit Namen immer noch keinen Zugang zum Drucker-PC - via Namen. Evtl. geht das über die IP, wie ich es an meinem Lappy für das WLAN eingerichtet habe.

Netzwerkgruppen habe ich bei den Vista-Rechnern keine entdeckt - nur diese \"Workgroup\"
Aber so öffentlich und privat war da nix dabei. Wirkte auf mich aber eh alles ziemlich befremdlich - hab mit Vista noch nicht wirklich was gemacht.
Bitte warten ..
Mitglied: aqui
08.02.2010, aktualisiert 18.10.2012
@87533
"...Gut - das mit den 45 Minuten ... das merkt man beim Arp -a ..." Das ARP protkoll hat mit der namensauflösung in Windows SMB Netzen rein gar nichts zu tun. Hier irrst du also gewaltig oder kennst schlicht und einfach die Protokollmechanismen dafür nicht !!
Du kannst auch weiterhin hilflos und sinnlos mit Kabel und WLAN hin- und herschalten.
Der statische Eintrag deines Drucker PCs in die lmhost löst dein Namens Problem auf Schlag.
Man muss es nur einmal machen....

Zum Thema WLAN Einrichtung und nachbar APs solltest du dann mal das hier lesen:
http://www.administrator.de/forum/w-lan-auf-ibm-lenovo-t60-funktioniert ...
Bitte warten ..
Mitglied: 87533
08.02.2010 um 23:25 Uhr
Gut von mir aus, dann heißt es halt anders.
Kann mir diese doofen neumodischen Abkürzungen einfach nicht merken.
Werde schon noch finden, was ich verstellt habe - früher ging es ja auch - ohne daß irgendwer irgendwelche Namenslisten manuell führen mußte - an etwa 7 PCs für etwa 12 Netzwerkadapter - und ohne daß die Rechner feste IP-Adressen hatten.

Schlimmstenfalls muß ich warten, bis mein Junior Semesterferien hat.
Vielen Dank jedenfalls für die vielen Ratschläge.
Bitte warten ..
Mitglied: aqui
09.02.2010 um 11:06 Uhr
...auch der wird die lmhost Datei benutzen

Bis dahin vielleicht dann
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: 87533
09.02.2010 um 12:11 Uhr
Glaub ich jetzt weniger - sonst hätt ich das längst.
Außerdem tippt der nicht gerne - uns einem Geklickse kann ich kaum folgen.

Man liest sich - bis zum nächsten niveaulosen Problemchen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerke
LAN und WLAN je mit gleicher IP (13)

Frage von dauatitsbest zum Thema Netzwerke ...

LAN, WAN, Wireless
Hat On Networks PL500PS WLAN-Funktion? (4)

Frage von Andy1987 zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Datenbankverbindung über WLAN? (5)

Frage von flyingKangaroo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...