Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hotplug im Raid 1 mit Systemplatten möglich?

Frage Hardware Festplatten, SSD, Raid

Mitglied: UsualSuspect

UsualSuspect (Level 1) - Jetzt verbinden

27.01.2010 um 11:58 Uhr, 11419 Aufrufe, 17 Kommentare

Ist es möglich eine Systemplatte im Raid 1 Verbund wärend des laufenden Betriebes zu ziehen?

Hi Volks,

vermutlich eine relativ einfache Frage, finde aber im Netz keine (mir genügende) Antwort!

Ist es möglich eine Systemplatte im Raid 1 Verbund wärend des laufenden Betriebes zu ziehen?

Bisher heißt es immer:
- Eine Systemplatte im laufenden Betrieb zu ziehen geht nicht (eh klar)
- SATA ist Hotplut fähig
- im Raid 1 mit SATA kann eine Platte problemlos gezogen werden (im laufenen Betrieb)

Wie schaut es jetzt aus wenn W2k8 auf einem Raid 1 mit zwei SATA Platten installiert ist.
Diese zwei platten hängen an einem Adaptec Raidcontroller 5805 mit folgenden Einstellungen:

Read-cache mode: Enable
Write-cache mode: write-back
kein hot-spare laufwerk vorhanden

getestet habe ich es schon. Windows geht in den BSoD!

Daher, die Frage, liegt es an
- den Settings
- dem Raidcontroller
- dem OS
oder ist es prizipiell garnicht möglich, und wenn dem so ist, WARUM?
Mitglied: sputnik
27.01.2010 um 12:03 Uhr
Du musst die "defekte" Platte vorher als "failed" einstellen!!!!!1111einseins Also im Adaptec-Storage-Manager oder BIOS.
Bitte warten ..
Mitglied: Arch-Stanton
27.01.2010 um 12:10 Uhr
es sollte bei richtiger Einstellung und bei verwendung von sata II Festplatten auch so funktionieren, sonst bräuchte man ja keinen Raidcontroller. Was passiert sonst bei einem echten Defekt, Systemabsturz?!?
Nach reiner Lehre sollte man aber SAS-Platten verwenden, die unzterstützen hot-plug.

Gruß, Arch Stanton
Bitte warten ..
Mitglied: hajowe
27.01.2010 um 12:12 Uhr
Da es sich hier im einen Raidcontroller handelt wird dieser auch die Spiegelung übernehmen und nicht das OS.

Ich empfehle dir mal diese Lektüre zu lesen
http://download.adaptec.com/pdfs/user_guides/Adaptec_RAID_Controller_IU ...

Da steht drin wie dein Controller eingerichtet werden sollte.
Dann kannst du auch gleich mal Firmware Treiber etc. checken.

ZUudem gibt es von Adaptec noch einen Manager dafür, damit man während des Betriebes auch draufschauen kann.


bei hot Spare andelt es sich um eine leere für den Controller verfügbare Platte, welche er bei Ausfall einer im Raid befindlichen Platte heranzieht.
Bitte warten ..
Mitglied: sputnik
27.01.2010 um 12:13 Uhr
Türlich. Jedoch hat er nur getestet... und beim Testen muss man die als failed deklarieren. Im Ernstfall macht es der Controller jedoch von selbst und dann kannste die auch ziehen... BTW: Das Backplane muss auch hot-plug-fähig sein.
Bitte warten ..
Mitglied: Phalanx82
27.01.2010 um 12:20 Uhr
Hi,

bei einem Raid1 sollte es zumindest in der Theorie möglich sein die 2. Platte zu ziehen ohne das die Kiste beinträchtigt wird.
Dafür gibt es ja Raid Systeme u.a. Mit dem Platte ziehen simulierst du ja quasi einen Plattenausfall und solltest den gleichen
Datenvorrat auf der noch im System steckenden Platte haben, falls beide Platten sauber eingerichtet und syncron sind zumindest.

In der Praxis siehts dann teilweise anders aus: Hardware Raid Controller sollte das auch wie in der Theorie gehen.
Bei einem Softwareraid ist das ganze dann doch mit Vorsichtig zu genießen was den laufenden Betrieb angeht, hier
kann dir der Controller einen Strich durch die Rechnung machen und dann endet das ganze im BSoD. (kenne ich selbst
von einigen unserer Maschinen hier). Am OS liegts sicherlich nicht, soviel kann ich dir schonmal sagen.

SATA ist in der Theorie Hotplug fähig ja, in der Praxis ist diese Funktion allerdings auf den meisten (Onboard) Controllern beschnitten.
Will heißen: Geht nicht, endet im BSoD.
Bei einigen Controllern tritt der BSoD allerdings nur auf, wenn du erst das Datenkabel anschließt bevor die Platte Strom hat (Widereinbau)
oder du das Stromkabel vor dem Datenkabel ziehst bzw. gleichzeitig (Ausbau).

Was du probieren kannst, sofern möglich, zieh erstmal das Datenkabel der Platte und danach das Stromkabel. Beim Widereinbau der Platte
erst das Stromkabel dann das Datenkabel dran. Damit hatte ich bei meinem Onboard Controller an meinem Privaten PC zumindest Erfolg.

In deinem Fall habe ich gerade nachgeschaut, der Controller selbst ist Hotplug fähig.
Allerdings musst du soweit mir bekannt ist, den Cache im Kontroller komplett deaktivieren damit die Daten direkt geschrieben werden.

Siehe auch: http://www.administrator.de/SATA:_erst_deaktivieren_-_dann_Hot_Plug_%3F ...

Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: UsualSuspect
27.01.2010 um 12:25 Uhr
hey,

erstma thx für die Hilfe.
Hab deiner Empfehlung folgegeleistet und eine der Platten auf "Failed" gesetzt!
Das wirklich tolle da ran, es tritt das selbe auf, wie wenn ich die platte Ziehe ;) W2k8 säuft mir ab ;)

ich werd jetzt erstmal nach Treiberupdates bzw. Firmwareupdates suchen...
Bitte warten ..
Mitglied: sputnik
27.01.2010 um 12:45 Uhr
Allerdings musst du soweit mir bekannt ist, den Cache im Kontroller komplett deaktivieren damit die Daten direkt geschrieben
werden.

Den Cache musst du nur deaktivieren, wenn der RAID-Controller keine Batterie hat. Also für den Fall, dass der Strom ausfällt oder das Netzteil hinüber ist.
Bitte warten ..
Mitglied: UsualSuspect
27.01.2010 um 12:52 Uhr
Meines Wissens hat der Cache folgendes zu bedeuten:

Das OS schickt daten zum schreiben auf die Platte. Der Raidcontroller schickt an das OS eine "geschrieben" bestätigung zurück, obwohl noch nichts auf der Festplatte ist.
Ziehe ich jetzt die Festplatte, denkt das OS die Daten sind geschrieben. In wirklichkeit sind sie aber noch im Cache des Controllers.
Für einen Stromausfall ist das mit der Batterie und dem Cache sicherlich richtig. Aber ich "ziehe" die Festplatte ja einfach.

Verstehe es trotzdem nicht, da ja noch eine zweite Festplatte da ist, auf die das OS zugrifen können sollte.

Hab mir jetzt die neuesten Treiber und Firmware besorgt. Dauert allerdings noch etwas da das Raid noch am Rebuilden ist.
Da ich zwei identische Maschinen zum testen habe werde ich gleich beides testen.

Neuste Treiber mit Write Back
und
Neuste Treiber mit Write Throu

mal sehen was passiert.... stay tuned!
Bitte warten ..
Mitglied: Pjordorf
27.01.2010 um 13:05 Uhr
Hallo UsualSuspect,

mal eine ganz banale Frage: Macht dein Adaptec das RAID 1 oder macht dein Windows Server 2008 das Raid 1?
Verwendest du ein Backplane wo deine HDD draufstecken? zie´hst du dort die Platte raus? Ist das Backplane auch HotPlug/HotSwap fähig?
Falls kein Backplane, welches Kabel ziehst du denn ab. Das Stromkabel an der HDD oder das Seriellkabel an der HDD?

Und dein RAID1 ist vorher immer in einem konsistenten Zustand, oder?

Peter
Bitte warten ..
Mitglied: UsualSuspect
27.01.2010 um 13:11 Uhr
Hi Peter,

Das Raid wird von meinem Adaptec 5808 Controller verwaltet.
Die Platten hängen, wie ich vermute, direkt an dem Controller. (Werde das aber gleich noch einmal überprüfen)
Die Platten befinden sich in Wechsrahmen, also Einschüben. Dort Ziehe ich sie, Daten wie Stromkabel werden also "zeitgleich" gezogen!

/edit: Jo, raid is immer "optimal"

so long...
Bitte warten ..
Mitglied: UsualSuspect
27.01.2010 um 13:51 Uhr
Also...

die Tests mit neuen Treiber und verschiedenen write und read cache einstellungen haben nix geholfen!
so oder so geht das System in den freeze oder endet mit dem BSoD!

Wofür ein Raid 1 auf den Systemplatten wenn das System abstürtzt bei einem Festplattendefekt?
Ok, nach einem Neustart läuft das System auf einer Platte weiter - daten sind nicht verloren!
Aber der Zeitaufwand zwischen Fehler bemerken - in den Serverraum rennen - Rechner neu starten.... das kann doch nicht Sinn der Sache sein!?!
Bitte warten ..
Mitglied: sputnik
27.01.2010 um 14:37 Uhr
Das Problem wird eher dein Wechselrahmen sein. Ich habe viele Adaptecs im Einsatz und keine Probleme.
Bitte warten ..
Mitglied: Phalanx82
27.01.2010 um 15:16 Uhr
Probiers mal ohne den Wechselrahmen bringt das auch nichts dann mach noch folgendes:

Geh in den Gerätemanger auf deine Festplatten und stell die dort auf "Für schnelles Entfernen optimieren" um.
Dann solltest du die Platten jederzeit rausziehen können ohne BSoD, allerdings deaktiviert das den Platten
internen Cache, was zur Folge hat, das alle Daten direkt geschrieben werden _müssen_, sprich die Performance
der Platten deutlich abfällt.

Teste mal mit beiden Platten auf dieser Einstellung und zieh dann mal eine ab, bin gespannt was passiert.

Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: UsualSuspect
28.01.2010 um 12:53 Uhr
Hi,

also problem solved!
Nachdem ich die "Backplane" umgangen habe läuft es ohne Probleme.
Bisher getestet:
- Platte im Manager auf "Failure" gesetzt
- Datenkabel der Platte gezogen und gesteckt

Es handelt sich um eine SuperMicro SAS743TQ Predikat: "ungenügend" ;)

danke für die reichliche Unterstützung!
Bitte warten ..
Mitglied: Pjordorf
28.01.2010 um 15:07 Uhr
Hi UsualSuspect,

zu deiner Backplane von der du nie etwas sagtest. Hast / hattest du auch die treiber dafür installiert und entsprechend angeschlossen oder warum versagt diese? Das it eine der Hauptaufgaben der backplane, dafür zu sorgen das der Server eben nicht einen BSOD erleidet. Ich hatte das mal, aber da hatte der Kunde auch die Treiber nicht installiert sowie das I²C Kabel nicht angeschlossen. Nach Treiber und Kabel konnte dort dann auch eine HDD im Betrieb gezogen werden. dafür ist die BackPlane ja da. Du verwendest schon ein Server Board wo eine backplane erkannt wird?

Wenn es bei dir so nicht geht, ist etwas faul an dem SAS743TQ. Reklamieren!

Peter
Bitte warten ..
Mitglied: UsualSuspect
28.01.2010 um 15:28 Uhr
Hi Peter,

erstmal danke für deine Hilfe!
Wenn ich ehrlich bin, hab ich von so einem Kabel noch nie etwas gehört, musste mich gerade auch erstmal schlau machen was das denn überhaupt ist.
Leider finde ich ein solches Kabel nur für 3Com <-> Supermicro. Adaptec selber scheint so ein Kabel auch nicht anzubieten!
Der vollständigkeit halber nochmal die Hardware

Mainboard:
http://www.supermicro.com/products/motherboard/Xeon3000/X58/X8ST3-F.cfm
Raidcontroller:
http://www.adaptec.com/en-US/products/Controllers/Hardware/sas/performa ...
Backplane:
http://www.supermicro.com/manuals/other/BPN-SAS-743TQ.pdf
HDDs für System im Raid 1:
2x WD250ABYS
HDDs für Storage im Raid 5:
5x http://www.wdc.com/de/products/products.asp?driveid=504

Das System wurde "fertig" und so konfiguriert von einem Distributor bestellt! Kann ich ihm jetzt vorwürfe machen?!?!
Eigentlich hätte es mir auch selber auffallen müssen. Jetzt erstmal schaun ob ich das passende Kabel finde!

Danke nochmal

so long...
Bitte warten ..
Mitglied: UsualSuspect
28.01.2010 um 16:42 Uhr
Hi nochmal,

wenn ich das richtig verstehe ist i2c bzw. sgpio nur dafür zuständig die LEDs über die Backplane zu steuern.
Also um Festplatten anhand von LEDs zu identifiezieren bzw. ihre aktivität zu signalisieren.

Hab das mal geprüft. Der RAidcontroller läuft auf "auto" hab ihn zum testen mal auf "sgpio" umgestellt (keine verbesserung)
Auf der Backplane ist SGPIO gejumpert. die Übertragung von SGPIO läuft wohl über die Kabel
mSASx4 (SFF-8087) to SATA (4)x1 with sideband (SFF-8448).

Eine Frage hätt ich noch, es werden nirgend Treiber für die Backplane angeboten, verstehe auch nicht ganz was das für Treiber seien sollen und wofür, hast du da noch einen letzten Tip?
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Netzwerk
Kein RDP über VPN per MS-TSC möglich (9)

Frage von survial555 zum Thema Windows Netzwerk ...

Microsoft
Keine Anmeldung mehr möglich (Server 2012 R2) (4)

Frage von Shnuuu zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...