Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

HP 2910al-24g mehrere VLAN Routing über Default-Route über Lancom 1711 ins Internet

Frage Netzwerke Netzwerkmanagement

Mitglied: TEXRanger

TEXRanger (Level 1) - Jetzt verbinden

17.07.2013 um 14:04 Uhr, 2318 Aufrufe, 19 Kommentare, 1 Danke

Hi,
befasse mich noch nicht so lange mit VLAN's...lerne noch
Ich babe eine Testumgebung erstellt. Alle Clients erreichen sich in allen VLAN's.
VLAN 1 kann ohne Probleme ins Internet. Die anderen VLAN's leider nicht.
Wenn ich die 'ip route 0.0.0.0 0.0.0.0 192.168.1.1' umsetze auf 'ip route 0.0.0.0 0.0.0.0 192.168.2.1',
dann ändert sich der Zugriff dementsprechend. VLAN 2 kann nun ins Internet.
Wenn ich diese Route für alle VLAN's verwende,
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 0.0.0.0 0.0.0.0 192.168.3.1
dann funktioniert kein Zugang mehr sauber...;(...logisch, denke ich)

Mein Ziel ist, dass alle VLAN's ins Internet können. Besser noch, ich kann bestimmen, welche VLAN's das dürfen ;)
Etwas am HP ist wohl noch nicht ok...kann mir jemand helfen?


Lancom 1711 FW V8.62
3 VLAN an Port 1

VLAN 1 192.168.1.1 LAN1
VLAN 2 192.168.2.1 LAN1
VLAN 3 192.168.3.1 LAN1




HP 2910

Running configuration:

; J9145A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-24G"
module 1 type j9145a
trunk 24 trk1 trunk
ip default-gateway 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip routing
snmp-server community "public" unrestricted
spanning-tree
spanning-tree Trk1 priority 4
vlan 1
name "VLAN1"
no untagged 3-6
untagged 1-2,7-23
tagged Trk1
ip address 192.168.1.2 255.255.255.0
ip igmp
exit
vlan 2
name "VLAN2"
untagged 3-4
tagged Trk1
ip address 192.168.2.2 255.255.255.0
ip igmp
exit
vlan 3
name "VLAN3"
untagged 5-6
tagged Trk1
ip address 192.168.3.2 255.255.255.0
ip igmp
exit
no autorun
password manager
password operator


Die Clients bekommen per DHCP vom Lancom
VLAN1 192.168.1.100-192.168.1.110 MASK 255.255.255.0 GW 192.168.1.2 DNS1 192.168.1.1
VLAN2 192.168.2.100-192.168.2.110 MASK 255.255.255.0 GW 192.168.2.2 DNS1 192.168.2.1
VLAN3 192.168.3.100-192.168.3.110 MASK 255.255.255.0 GW 192.168.3.2 DNS1 192.168.3.1

Mitglied: brammer
17.07.2013 um 14:17 Uhr
Hallo,

dein Problem dürfte die Verbindung zwischen dem Router und dem Switch sein.
Der Router hat keinen Trunk, respektive dieKonifguration des Routers unf des Switches ergeben keinen lauffähigen Trunk.
Also überträgt er die anderen VLAN's auch nicht in's Internet...
Ich befürchte das die HP Gruke und der Lancom nur schwer davon zu überzeigen sind so zusammenzuarbeiten...

Verusche mal ein Transfer Netzwerk zwischen Switch und Router.

brammer
Bitte warten ..
Mitglied: TEXRanger
17.07.2013 um 14:31 Uhr
Hi Brammer,

danke für deine schnelle Antwort.
hm...die Grundlage für die Nutzung eines vorhandenen L1711 war dieser Link

http://www2.lancom.de/kb.nsf/1275/52781272AD84ED9CC12574AB00432192?Open ...
Bitte warten ..
Mitglied: MrNetman
17.07.2013 um 14:36 Uhr
Hi ölhaltiger Naturfan,

Der HP Switch kann einen Uplink zum Router bekommen.
Wenn der HP Routet, dann braucht er nur einen ungetaggten uplink und eine weitere Route.
Wenn der Lancom routet, dann benötigt der HP keine Routen und einen Uplink mit getaggten Paketen.
Mal es auf und du siehst, da fehlt eine Kleinigkeit.

Und wenn der LANCOM routen soll, dann darf der HP das natürlich vorher nicht auch noch.

Gruß
Netman
Bitte warten ..
Mitglied: Arbeitstier207
17.07.2013 um 14:44 Uhr
Hi TEXRanger

ich bin nicht wirklich gut im Umgang mit HP, aber schau dir doch nochmal bitte deine Running an. Sollte nicht, wenn du schon ein default-gateway gesetzt hast, die 0er Route überflüssig sein? Bei Cisco jedenfalls hast du je nach Ansicht entweder das eine oder das andere.

Ansonsten könnte ich auch nur vermuten, dass es am Trunking liegt.
Hast du Subinterfaces am Router mit VLAN-Zugehörigkeit?

Wie gesagt, ich bin kein Fachmann für HP...

Grüße
Bitte warten ..
Mitglied: TEXRanger
17.07.2013, aktualisiert um 14:49 Uhr
Hi MrNetman,

soweit klar...es soll nur der HP routen (1GBit) der Lancom nicht...leider ist mir nicht klar...was am Lancom falsch eingerichtet ist.
Bitte warten ..
Mitglied: TEXRanger
17.07.2013, aktualisiert um 14:56 Uhr
auch ohne default-gw geht es nicht

Subinterfaces...ja

VLAN 1 192.168.1.1 LAN1 192.168.1.1 VLAN-ID 1
VLAN 2 192.168.2.1 LAN1 192.168.2.1 VLAN-ID 2
VLAN 3 192.168.3.1 LAN1 192.168.3.1 VLAN-ID 3

Running configuration:

; J9145A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-24G"
module 1 type j9145a
trunk 24 trk1 trunk
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip routing
snmp-server community "public" unrestricted
spanning-tree
spanning-tree Trk1 priority 4
vlan 1
name "VLAN1"
no untagged 3-6
untagged 1-2,7-23
tagged Trk1
ip address 192.168.1.2 255.255.255.0
ip igmp
exit
vlan 2
name "VLAN2"
untagged 3-4
tagged Trk1
ip address 192.168.2.2 255.255.255.0
ip igmp
exit
vlan 3
name "VLAN3"
untagged 5-6
tagged Trk1
ip address 192.168.3.2 255.255.255.0
ip igmp
exit
no autorun
password manager
password operator
Bitte warten ..
Mitglied: MrNetman
17.07.2013, aktualisiert um 15:04 Uhr
Hi Ranger, Naturfreund.

Wenn der Lancom nicht routen darf, dann muss er entweder in einem der Segemente/VLANs des HP sein und eine spezielle Route bekommen, die vom HP kommen muss. ...
Dann ist auch dein Link zur Lancom Webseite überflüssig.
Oder du spendierst dem Lancom ein viertes VLAN und wunderst dich, dass alles so einfach ist.
Der LANCOM hat nicht 3VLANs an einem Port, sondern 3 Netze an einem Port, was einen erheblichen Unterschied ausmacht.
Der LANCOM kann seinen DHCP dann nur mittels der DHCP-helper Funktion des HP ausführen. Sonst kann er ja nicht erkennen, welche IPs er ausliefern soll.

Netman
Bitte warten ..
Mitglied: aqui
17.07.2013, aktualisiert um 15:42 Uhr
Im Internet Router (Lancom) musst du natürlich auch statische Routen für deine VLAN IP Netze eintragen mit next Hop IP auf die VLAN IP des HPs die mit dem Lanvom verbunden ist !
Ansonsten fehlt logischerweise dem Lancom die IP Routen zu den VLAN IP Netzen und in Ermangelung dieser Routen würde er sie dann an den Provider routen wo sie im Nirvana verschwinden...(dieser filtert private RFC 1918 IP Netze und schmeisst die Pakete wech..) genau das was bei dir passiert !
Trag also die Routen nach dann klappt das auch !
Diese Tutorials versoregn dich mit dem Grundwissen dafür:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
und
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Bitte warten ..
Mitglied: TEXRanger
17.07.2013 um 16:06 Uhr
Hi,
die Routen hatte ich eingetragen...das ging leider auch nicht. Nur Vlan 1 kann raus.
naja...wenn mein verständnis vom routing richtig ist...

192.168.1.0/24 192.168.1.2
192.168.1.0/24 192.168.2.2
192.168.1.0/24 192.168.3.2

mit einem Routingtag passend zur schnittstellen route leider auch nicht...
Bitte warten ..
Mitglied: TEXRanger
17.07.2013 um 16:10 Uhr
hm...3Netze an einem Port...aber warum vergebe ich dann eine VLAN-ID für die Netze?
DHCP funktioniert ja vür alle VLAN's...alle Geräte am HP bekommen die richtige IP-Konfiguration...
Ich habe 2 1711er...ich werde den einen mal mit umkonfigurieren. Bin leider nicht der Meister im VLAN und Routin...ich will es ja lernen...und nur lesen reicht nicht ;(
Bitte warten ..
Mitglied: MrNetman
17.07.2013 um 16:19 Uhr
Entweder der HP oder der LANCOM routet zwischen den VLANs
Das Routing am HP dektivieren und dann nach deinem Link von Lancom vorgehen.
Bitte warten ..
Mitglied: TEXRanger
17.07.2013 um 16:24 Uhr
wenn ich das Routing den Lancom machen lasse, dann geht alles über den, mit 100Mbit ;(
Der Lancom versteht anscheinend den tagged port 24 (trk1) vom HP, denn wenn ich den im VLAN1 auf untagged schalte, geht nicht mehr. ;)
Wenn ich falsch liege, dann bitte kurz erklären. Danke
Bitte warten ..
Mitglied: MrNetman
17.07.2013 um 16:28 Uhr
probiere es doch mal mit einem bild und eingetragenen IPs.
Und dann malst du dir von jedem Port zu jedem Port eine Route. Male so, als ob der Switch drei Switche wären. Dann kannst du erkennen, dass du zwei Router hast, die zum Teil das selbe machen.

Da der HP vorher routet, kommen die Pakete wohl kaum zum Lancom. Was soll er denn dann machen?
Bitte warten ..
Mitglied: aqui
17.07.2013, aktualisiert um 16:31 Uhr
Das ist ja auch Bullshit mit dem Routing auf dem Lancom !! Macht kein vernünftiger Netzwerker. Bitte lies dir die Tutorials von oben durch, da steht doch alles drin !
Der Lancom muss NUR die statischen Routen haben zu den VLANs mehr nicht !
Das Routen macht der Switch, sprich die Endgeräte in den VLANs haben immer die Switch IP als default Gateway !
Der HP Switch ist über ein "Internet" VLAN mit dem Lancom verbunden.
Default Route des HPs zeigt auf die Lancom IP im Internet VLAN
Statische Routen der VLANs im lancom zeigen auf die IP des HPs im Internet VLAN.
Fertisch !
Macht dir jeder IT Azubi in 5 Minuten so ein popeliges Standardsetup !
Bitte warten ..
Mitglied: TEXRanger
17.07.2013 um 16:37 Uhr
ich denke, es hat klick gemacht...der Router muss ja die VLAN's nicht kennen, er dient ja lediglich als FIREWALL und Internet-GW vür die Defaultroute des HP..
Bitte warten ..
Mitglied: TEXRanger
17.07.2013 um 16:38 Uhr
Jo...in dem Moment hat es klick gemacht...boa...toll, wenn mann sich mit vlan versucht...und sich dann ver-vlahmt...lol...ich baue schnell um.
Bitte warten ..
Mitglied: TEXRanger
17.07.2013, aktualisiert um 19:22 Uhr
...alles reset neu und...fein...ohne "vervlahmung"...hab wohl ne Kelle gebraucht...vielen dank dafür...
Bitte warten ..
Mitglied: Dobby
18.07.2013 um 09:47 Uhr
Wenn es das dann war wäre ein Beitrag ist gelöst nicht schlecht, Danke.
Bitte warten ..
Mitglied: TEXRanger
18.07.2013 um 14:08 Uhr
;) ...macht sinn ;) danke für eure Hilfe
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
gelöst HP VLAN routing (5)

Frage von homermg zum Thema Router & Routing ...

Netzwerkmanagement
gelöst HP 1920 24G Switch QOS-Problem bei Portzuweisung mit DHCP Relay (2)

Frage von farbschmelz zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
gelöst VLAN Routing - L3 oder Firewall? (17)

Frage von pataya zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...