Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Html-Code relativer Link

Frage Entwicklung HTML

Mitglied: poisoncrow

poisoncrow (Level 1) - Jetzt verbinden

17.05.2011 um 15:49 Uhr, 3484 Aufrufe, 23 Kommentare

Hallo!

Ich möchte auf meiner Seite in Beschreibungen einen relativen Link zu einer anderen Seite auf meiner Homepage einfügen.
Bis jetzt hat das alles wunderbar funktioniert. Nur bei einigen Links, wird mir auf der Seite dann ein Teil der Adresse angezeigt.

Also ein Beispiel am Produkt Cassady

Wenn ich schreibe: Bestellen Sie den passenden Slip gleich mit. Soll bei klicken auf "Slip" die Produktseite von dem Slip erscheinen.
der relative Link dazu wäre ja: <a href="artikel_detail_1293____konrad_slip_cassady.html">Slip</a>

Jetzt zeigt er mir aber auf der Seite: Bestellen Sie den passenden CASSADY.html">Slip gleich mit.

Das scheint bei allen Produkten so zu sein, deren Namen mit CA oder DI anfangen.

Woran liegt das? Muss ich an dem Code irgendwas ändern, damit der Link trotzdem vernünftig angezeigt wird?

Liebe Grüße

poisoncrow
Mitglied: Snowman25
17.05.2011 um 16:02 Uhr
Hallo poisoncrow,

Benutzt du ein CMS? Liest sich nämlich so, als würde ein CMS CA und DI gegen etwas anderes austauschen. Was steht denn im Quelltext der Seite, wenn du sie im Browser öffnest an dieser Stelle?

Gruß
Snow
Bitte warten ..
Mitglied: awagner82
17.05.2011 um 16:02 Uhr
hi poisoncrow

Zitat von poisoncrow:
der relative Link dazu wäre ja: <a href="artikel_detail_1293____konrad_slip_cassady.html">Slip</a>

ja

Jetzt zeigt er mir aber auf der Seite: Bestellen Sie den passenden CASSADY.html">Slip gleich mit.
Das scheint bei allen Produkten so zu sein, deren Namen mit CA oder DI anfangen.

nein, da muss was anderes dahinter stecken

Woran liegt das? Muss ich an dem Code irgendwas ändern, damit der Link trotzdem vernünftig angezeigt wird?

ohne Quellcode schwierig. wird der Code generiert oder ist er statisch?
Wenn ich den o.g Link kopiere, wird das Richtige (Slip) angezeigt.

gruß
Bitte warten ..
Mitglied: brammer
17.05.2011 um 16:03 Uhr
Hallo,

bitte mal den Quelltext posten.

brammer
Bitte warten ..
Mitglied: kopie0123
17.05.2011 um 16:03 Uhr
Hey,

irgendwas stimmt in deiner Wiedergabe nicht:

Einmal schreibst du cassady klein, einmal groß.

Wie ist denn der Quelltext im Browser?

01.
 
02.
Bestellen Sie den passenden <a href="artikel_detail_1293konrad_slip_cassady.html">Slip</a> gleich mit. 
03.
 
Wäre der HTML Code Deiner Wahl.

Gruß
Bitte warten ..
Mitglied: kopie0123
17.05.2011 um 16:03 Uhr
puh, da waren einige aber schneller :D
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:11 Uhr
Also im Quelltext steht dann:

<a href="artikel_detail_1250_11_45_133_konrad_push_up_<font class="suchwort">CASSADY</font>


öhm zu den Fragen vom Quellcode: Ich bin ein Dummie was das angeht *ggg*

Ich habe ein Onemore Shop-System, da muss ich mit Quellcodes nix machen.
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:14 Uhr
@ StingerMac: Das mit dem groß und klein schreiben passiert irgendwie im html code ... ich kopiere die links nur in den code rein.

so wie du den code geschrieben hast, habe ich ihn in meiner artikelbeschreibung auch geschrieben.
überall anders funktioniert das, nur eben da nicht.
Bitte warten ..
Mitglied: kopie0123
17.05.2011 um 16:16 Uhr
hm, dann schick doch bitte mal den Quelltext des Browsers

Gruß
Bitte warten ..
Mitglied: awagner82
17.05.2011 um 16:16 Uhr
Und wie gehts weiter?
Wo ein <a> anfängt, muss doch auch eins aufhören.

Woher kommt das sog. Suchwort?
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:19 Uhr
Also den ganzen Seiten-Quelltext hier posten?
Bitte warten ..
Mitglied: kopie0123
17.05.2011 um 16:21 Uhr
nur den Teil des Links, vllt den ganzeen DIV oder td, je nach Seitendesign.

oder wenn es online steht -> LINK
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:22 Uhr
<td valign="top"><a href="image_detail_1293.html" onclick="neuesFenster(this.href,
'ViewImage','466','700','no','yes');return false"><img src="images/klein/1305374698_1.jpg" width="130" border="0" alt="Konrad Slip Cassady"></a><br><img src="images/layout/clear.gif" width="5" height="5"><br><a href="javascript:history.back(-1)" class="window_normal_link">[ Übersicht ]</a><br>

<a href="image_detail_1293.html" onclick="neuesFenster(this.href,
'ViewImage','466','700','no','yes');return false" class="window_normal_link">[ Produktbild vergrößern ]<br></a><a href="produktanfrage_1293.html" class="window_normal_link">[ Produktanfrage ]</a></td>
<td width="10"><img src="images/layout/clear.gif" height="10" width="10"></td>
<td valign="top"><p align=justify><font class="window_normal_text">Sexy Slip mit frechem Pünktchenmuster und mit wunderschöner Blütenstickerei verziert. Den passenden Push Up finden Sie unter <a href="artikel_detail_1250_11_45_133_konrad_push_up_<font class="suchwort">CASSADY</font>.html">Konrad Push Up <font class="suchwort">CASSADY</font></a><br><br>58% Polyamid,12% Elasthan,30% Baumwolle</font></p></td>
</tr><tr>
<td><a name="select"><img src="images/layout/clear.gif" height="20" width="10"></a></td>
<td width="10"><img src="images/layout/clear.gif" height="20" width="10"></td>

<td valign="top"><img src="images/layout/clear.gif" height="20" width="10"></td>
</tr>
<tr>
Bitte warten ..
Mitglied: awagner82
17.05.2011 um 16:30 Uhr

<a href="artikel_detail_1250_11_45_133_konrad_push_up_<font class="suchwort">CASSADY</font>.html">
Konrad Push Up
<font class="suchwort">CASSADY</font>
</a>


Ich an Deiner Stelle würde mich nochmal darauf konzentrieren, wo genau der Link hinzeigt.
Also über die Oberfläche schauen, was genau darin steht. Sieht mir aus, wie zu viel reinkopiert.

Warum sollte das font class=suchwort sonst zweimal autauchen?
An der ersten Stelle macht es üebrhaupt keinen Sinn.
Bitte warten ..
Mitglied: kopie0123
17.05.2011 um 16:31 Uhr
Genau,

du kannst in das href Attribut keine weiteren HTML-Tags setzen.
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:31 Uhr
Aber das font class=suchwort habe ich gar nicht geschrieben

mein code war wirklich nur: <a href=<a href="artikel_detail_1293konrad_slip_cassady.html">Slip</a>
Bitte warten ..
Mitglied: awagner82
17.05.2011 um 16:33 Uhr
Zitat von poisoncrow:
mein code war wirklich nur: <a href=<a href="artikel_detail_1293konrad_slip_cassady.html">Slip</a>

da ist aber schon wieder was doppelt ;)
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:33 Uhr
So sieht meine ganze Artikelbeschreibung aus:

Sexy String mit frechem Pünktchenmuster und mit wunderschöner Blütenstickerei verziert. Den passenden Push Up finden Sie unter <a href="artikel_detail_1250_11_45_133_konrad_push_up_cassady.html">Konrad Push Up Cassady</a>

58% Polyamid,12% Elasthan,30% Baumwolle




Mehr hab ich nicht geschrieben und was im Quelltext dabei raus kommt seht ihr oben.
Bitte warten ..
Mitglied: kopie0123
17.05.2011 um 16:36 Uhr
Mit welchen System erstellst du die Seite? Anscheint wird etwas hinzugefügt...
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:37 Uhr
Das ist ein Onemore Shopsystem ... vielleicht sollte ich einfach den Support mal anschreiben.

Bei allen anderen Artikelnamen funktioniert es ... nur nicht bei Cassady, Divine und Carnival

komisch
Bitte warten ..
Mitglied: awagner82
17.05.2011 um 16:39 Uhr
ok ...

Hast du irgendwo Wörter definiert, die auf der Seite hervorgehoben werden sollen?
Gibt es eine Funktion für die Definition von Suchbegriffen?

Wenn das Programm tatsächlich das Wort Cassidy ersetzt, dann muss das irgendwo definiert sein.

Das kannst Du prüfen indem du es im "href" einfach mal mit einem "s" schreibst.
Dann siehst Du es ja.

Gruß
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:43 Uhr
Also wenn ich Kassady schreibe funktioniert es.

Aber definiert habe ich nix irgendwo. Das Wort taucht auch nirgendwo auf, ausser im Artikelnamen und in der Artikelbeschreibung
Bitte warten ..
Mitglied: awagner82
17.05.2011 um 16:49 Uhr
hm ...

... dann bin ich ehrlich gesagt auch ratlos.
Support wäre sicherlich eine Möglichkeit, dauert aber vermutlich lange.

Workaround:
HTML Seiten umbenennen: Cassidy -> Kassidy etc. und eben diese verlinken.
Die Bezeichnung kann ja gleich bleiben.
Parallel kannst Du dann immer noch n Support Ticket aufmachen.

Gruß
Bitte warten ..
Mitglied: poisoncrow
17.05.2011 um 16:51 Uhr
Dann mach ich das mal.

Danke an alle, die geantowrtet haben. Jetzt weiss ich auf jeden Fall, das es nicht an mir liegt

Ich schliesse den Beitrag hiermit.

Vielen Dank nochmal!
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
HTML
HTML, CSS: Mapping auf dynamischen Hintergrund (2)

Frage von Judo99 zum Thema HTML ...

HTML
HTML Programmierung (5)

Frage von Alex29 zum Thema HTML ...

Hardware
Sicherheitsrisiko durch "KVM" USB Link Kabel? (3)

Frage von D1Ck3n zum Thema Hardware ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (20)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...