Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

HTML Schriftfont benoetigt aber nicht ausfuehrbar

Frage Entwicklung HTML

Mitglied: Shaddy

Shaddy (Level 1) - Jetzt verbinden

26.05.2011, aktualisiert 11:10 Uhr, 3590 Aufrufe, 4 Kommentare

Beim Entwickeln der Seite eines Kunden, bin ich auf ein, mir bisher nicht lösbares, Problem gestoßen.
Es handelt sich um das Einbinden eines Schriftfonts, welcher auf Windows95-WinXP nicht standardmäßig installiert ist.

Mein Vorwort hat schon einiges erläutert.

Die zu entwickelnde Seite basiert grundliegend auf dem Design, da dort Designprodukte verscherbelt werden.

Es handelt sich hierbei um den Schriftfont Zurich Bold Extended BT (TrueType).

Eingebunden habe ich den Schriftfont via

<span style="font-family:Zurich BdEx BT">
oder
<font face="Zurich BdEx BT">

Sobald ich die Fontdatei "ZURCHBE.TTF" geöffnet habe, liegt sie logischerweise im RAM und kann problemlos abgerufen werden.
Das ist ja aber nicht sinn und zweck :-P

Sinn und zweck ist es den font moeglichst einfach abrufbar einzubinden.
Ich nenne bewusst keine mir eingefallenen Ideen, da ich sowohl nach langer Suche nichts gefunden habe, als auch Platz lassen möchte für kreative Ideen.

Ihr seid meine letzte Hoffnung

Gruß ein verzweifelter Shaddy

PS: Der Schriftfont muss zwangsweise verwendet werden & kann nicht durch einen "ähnlichen" ersetzt werden
Mitglied: kristov
26.05.2011 um 11:24 Uhr
Via CSS3 etwa so:

01.
/* Schriftart einbinden */ 
02.
@font-face { 
03.
   font-family: Zurich; 
04.
   src: url(‘ZURCHBE.TTF’); 
05.
06.
 
07.
/* Die Schrift in eine Klasse einbauen */ 
08.
.schriftklasse { 
09.
   font-family: Zurich; 
10.
   font-size: 10px; 
11.
}
Die ZURCHBE.TTF muß natülich unter dem in src: url() angegebenen Pfad erreichbar sein.

kristov
Bitte warten ..
Mitglied: Snowman25
26.05.2011 um 11:46 Uhr
Hinzufügend zu dem, was kristov ereits gepostet hat, sollte man noch sagen, dass die Font-Datei unter der gleichen Adresse erreichbar sein sollte, wie das CSS bzw. die Website, da hier sonst die Same-Domain-Policy des jeweiligen Browsers greifft.
Soll heißen:
Wenn du die URL im CSS ausschreibst, dann lässt der Browser den Font auch nur für diese Domain + Subdomain zu.
Gleiches gilt für die Angabe des Pfads zur CSS-Datei im HTML-Dokument. Weicht die Domain der CSS-Datei von der Website ab (z.B. heise.de und www.heise.de), dann wird die Font-Datei nicht geladen, obwohl die Domains von CSS und Font gleich sind.

Beispiel:
http://blauerwolf.eu vs. http://www.blauerwolf.eu

Hier ist der Pfad der CSS-Datei absolut angegeben. Ohne www wird der Font geladen und benutzt. mit www nicht, obwohl die Font-Datei unter dem Pfad erreichbar ist.

Gruß
Snow
Bitte warten ..
Mitglied: Shaddy
26.05.2011 um 13:52 Uhr
Vielen Dank euch beiden ich habe zwar noch ein wenig zu knobeln, dass es auch funktioniert, aber das möge ja nicht lange hin sein
Schöne Woche noch. Fast geschafft
Bitte warten ..
Mitglied: kristov
30.05.2011 um 10:06 Uhr
Hallo nochmal,

was ich hier so rausgelesen habe, müßte das in Deinem Fall etwa so lauten:


01.
@font-face {   
02.
	  font-family: "Zurich BdEx BT";   
03.
	  src: url(http://wastemail.wa.ohost.de/ZURCHBE.EOT); /* IE */   
04.
	  src: url(http://wastemail.wa.ohost.de/ZURCHBE.TTF)) format("truetype"); /* non-IE */   
05.
	}  
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
HTML
HTML, CSS: Mapping auf dynamischen Hintergrund (2)

Frage von Judo99 zum Thema HTML ...

HTML
HTML Programmierung (5)

Frage von Alex29 zum Thema HTML ...

Batch & Shell
gelöst Erneute Frage: Powershell in Batch mit Html (6)

Frage von michi-ffm zum Thema Batch & Shell ...

Batch & Shell
HTML in Batch und Powershell (13)

Frage von michi-ffm zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...