Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hyper-V, Exchange 2013 und Windows Server 2012R2

Frage Virtualisierung Hyper-V

Mitglied: DrEmmettBrown

DrEmmettBrown (Level 1) - Jetzt verbinden

14.02.2014, aktualisiert 21.02.2014, 2987 Aufrufe, 12 Kommentare, 3 Danke

Guten Tag zusammen,

hier eine Übersicht meiner Konfiguration:

Windows Server 2012R2 welcher als AD, Exchange 2013, und als Datenablage dient.
Onboard 2x 1Gbit/s LAN Adapter.

Der Server läuft aktuell mit einem der beiden Adpater der andere ist deaktiviert.

Hyper-V wurde installiert und eine Virtuelle Maschine läuft auch schon.

Nun zu dem eigentlichen Problem. Sobald von mir ein Virtueller Switch über den zweiten Adpater in der Hyper-V Verwaltung installiert wird streikt der Server auf voller Linie.

Der Exchange verschickt bzw. empfängt keine Mails mehr und der VPN-RAS Dienst lässt ebenfalls keine Einwahl mehr zu.

Was muss bei der Installation eines virtuellen Hyper-V Switches zu einem externen Netzwerk beachtet werden. Wenn 2. LAN Adapter aktiv sind?

Über Hilfe wäre ich sehr dankbar.

Beste
Grüße

Mitglied: echo11
14.02.2014 um 12:45 Uhr
Hallo,

zu deinem Problem kann ich nicht viel sagen, ich rate dir aber generell davon ab, den Exchange auf dem DC zu betreiben: http://technet.microsoft.com/de-de/library/ms.exch.setupreadiness.warni ...

Gruß
Bitte warten ..
Mitglied: departure69
14.02.2014 um 12:54 Uhr
Hallo.

Aktuelles Exchange braucht das Protokoll IPv6 aktiv (auch, wenn es nicht bewußt aktiv genutzt wird, es darf jedenfalls nicht deaktiviert sein). Sieh' mal, ob Du in dieser Richtung was findest.

Grüße

von

departure
Bitte warten ..
Mitglied: echo11
14.02.2014, aktualisiert um 13:02 Uhr
Zitat von departure69:

Aktuelles Exchange braucht das Protokoll IPv6 aktiv (auch, wenn es nicht bewußt aktiv genutzt wird, es darf jedenfalls nicht
deaktiviert sein). Sieh' mal, ob Du in dieser Richtung was findest.


Hallo,

das stimmt, ich habe das mal versucht, aber dann hat sich der Exchange noch nicht mal richtig starten lassen. Ich glaube nicht, dass es daher rührt, da der RAS-Dienst auch nicht läuft.
Ist der 2. Netzwerkadapter nur für HyperV gesetzt oder nutzt ihn der physikalische Server nach aktivieren vielleicht auch?

Gruß
Bitte warten ..
Mitglied: departure69
14.02.2014 um 12:59 Uhr
Hab' mir jetzt Dein Eingangsposting nochmal genau durchgelesen.

Kann es sein, daß Du dem DC außer Exchange (was schon nicht mehr empfohlen ist) auch noch zusätzlich HYPER-V draufgeballert hast?

Das ist eine überhaupt nicht supportete Konstellation. Ein HYPER-V ist ein HYPER-V ist ein HYPER-V und sonst nichts weiter. Obendrein verlierst Du dabei die virtuellen Lizenzrechte, wenn Du auf dem physikalischen Rechner außer HYPER-V noch andere Rollen aktiviert (DC) oder andere, gewichtige Software (wie Exchange) installiert hast.

Grüße

von

departure
Bitte warten ..
Mitglied: Dobby
14.02.2014 um 12:59 Uhr
Hallo,

das gleiche wie echo11 und zusätzlich noch folgendes:

Wenn 2. LAN Adapter aktiv sind?
Das Du Dir (Euch keinen) Netzwekloop baust also
einen Schleifen die eventuell alles lahmlegt.

Gruß
Dobby♬
Bitte warten ..
Mitglied: DrEmmettBrown
14.02.2014, aktualisiert um 13:05 Uhr
Zitat von echo11:

> Zitat von departure69:
>
> Hallo.
>
> Aktuelles Exchange braucht das Protokoll IPv6 aktiv (auch, wenn es nicht bewußt aktiv genutzt wird, es darf jedenfalls
nicht
> deaktiviert sein). Sieh' mal, ob Du in dieser Richtung was findest.
>
> Grüße
>
> von
>
> departure

Hallo,

das stimmt, ich habe das mal versucht, aber dann sich hat der Exchange noch nicht mal richtig starten lassen. Ich glaube nicht,
dass es daher rührt, da der RAS-Dienst auch nicht läuft.
Ist der 2. Netzwerkadapter nur für HyperV gesetzt oder nutzt ihn der physikalische Server nach aktivieren vielleicht auch?

Gruß

Durch das aktivieren des zweiten Adapters als virtueller Hyper-V Switch wird dieser ja ohne jegliche Netzwerkeinstellungen gestartet. Meine Verdacht ist eben der das der Server Versucht über diesen Adapter Verbindungen aufzubauen was aber nicht möglich ist. Da ja weder eine IP, eine Gateway oder ein DNS Server bei diesem Adapter hinterlegt sind.
Bitte warten ..
Mitglied: colinardo
14.02.2014, aktualisiert um 16:02 Uhr
Hi,
mach die Kiste Platt, installiere auf dem Host nur die Hyper-V Rolle und stecke deinen DC und Exchange jeweils in eine separate VM, so wie es sich gehört, oder spendiere deinem DC besser noch separate Hardware (damit dein Netz nicht gleich ganz steht wenn der Hyper-V abraucht). So wie du das vorhast wird das zu 100% noch zu diversen weiteren Problemen führen !

Zu Hyper-V und Netzwerke lese folgendes:
http://www.windowspro.de/wolfgang-sommergut/virtual-switch-netzwerke-hy ...

Grüße Uwe
Bitte warten ..
Mitglied: echo11
14.02.2014 um 15:20 Uhr
Zitat von colinardo:

mach die Kiste Platt, installiere auf dem Host nur die Hyper-V Rolle und stecke deinen DC und Exchange jeweils in eine separate
VM, so wie es sich gehört. So wie du das vorhast wird das zu 100% noch zu diversen weiteren Problemen führen !

Sehe ich genauso. Du schaffst dir in der aktuellen Konstellation viele Probleme. Du wirst nachher bei einer solchen Fehlermeldung nicht mehr genau sagen können, welche Installation jetzt Einfluss darauf hat.
Bitte warten ..
Mitglied: Dani
19.02.2014 um 18:57 Uhr
Moin,
Windows Server 2012R2 welcher als AD, Exchange 2013, und als Datenablage dient.
Das ist sowas von unsupportet - Exchange 2013 und Server 2012R2 wird nicht sauber laufen. Gibt dazu massig Probleme im Technet zu lesen... Mit SP1 wird es supportet. Wir erwarten es jeden Tag...


Grüße,
Dani
Bitte warten ..
Mitglied: departure69
20.02.2014 um 07:44 Uhr
Sein Kernproblem ist doch eher ein anderes. SP1 für Exch. 2013 hin oder her, empfehlen würde ich niemals, Exch. auf'm DC zu installieren.

Obendrein ist die Kiste auch noch Fileserver (O.K., je nach Datenmenge, Anzahl der User usw. kann man das wahrscheinlich machen - ich würde trotzdem einen dedizierten Fileserver haben wollen).

Und dann hat er dem ganzen noch die Krone aufgesetzt und die HYPER-V-Rolle aktiviert, hat also aus einem DC, Exchange und Fileserver auch noch einen Hypervisor gemacht, worin er noch weitere VMs betreiben will.

Dreht er das Ganze um, wie auch mehrere Vorposter schon sagten, und beginnt mit HYPER-V als einziger Rolle auf seinem Blech, ergibt das ganze dann schon eher Sinn.

Blech= HYPER-V-Hypervisor (ausschließlich)
virtuelle Maschinen= 1. DC, 2. Exch. 3, Fileserver, 4 u. ff. weitere Server

Wobei auch ich den DC in ein (kleineres) Extra-Blech stecken würde, und dann vielleicht noch 2nd DC u. 2nd DNS in einer VM.

Grüße

von

departure
Bitte warten ..
Mitglied: Dani
LÖSUNG 20.02.2014, aktualisiert 21.02.2014
@departure
Sein Kernproblem ist doch eher ein anderes. SP1 für Exch. 2013 hin oder her, empfehlen würde ich niemals, Exch. auf'm DC zu installieren.
Das mag sein, aber das ist Microsoft supportet, aber nicht empfohlen. Klick.

Und dann hat er dem ganzen noch die Krone aufgesetzt und die HYPER-V-Rolle aktiviert, hat also aus einem DC, Exchange und Fileserver auch noch einen Hypervisor gemacht, worin er noch weitere VMs betreiben will.
Da bin ich nicht drin, ob das supportet wird.

Man muss einfach klar unterscheiden, zwischen technisch sinvoll und Microsoft supportet. Das sind einfach zwei paar Stiefel!


Grüße,
Dani
Bitte warten ..
Mitglied: DrEmmettBrown
21.02.2014 um 20:02 Uhr
Danke für die zahlreichen Kommentare. Die Lösung war ein Hacken beim Anlegen des virtuellen Switches "Gemeinsame Verwendung dieses Netzwerkadapters für das Verwaltungsbetriebsystem zulassen" dieser musste abgehackt werden.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Wo ist der Speicherplatz hin? Festplatte voll, aber womit? Windows Server 2012R2 (9)

Frage von Andinistrator1 zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012R2 in Hintergrund aufbauen (5)

Frage von David2804 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...