Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hyper-V Failover-Cluster als aktiv-aktiv konfigurieren?

Frage Virtualisierung Hyper-V

Mitglied: goodbytes

goodbytes (Level 2) - Jetzt verbinden

09.11.2012, aktualisiert 15:56 Uhr, 4629 Aufrufe, 4 Kommentare

Hallo,
ich habe zwei physische Server (Server 2008 R2), mit denen ich ein Failover-Cluster konfiguriert habe. Dieser Cluster soll einzig für Hyper-V genutzt werden.

Es ist alles fertig konfiguriert, auch bereits VM`s im Cluster. Allerdings ist der Cluster nur im aktiv-passiv Modus.
Ich möchte die Leistung des zweiten Servers aber auch mit nutzen, also einige VM`s im Normalfall auf dem ersten Server, die anderen auf dem zweiten Server laufen. Nur im Fehlerfall sollen die betroffenen VM`s komplett auf dem verbleibenden Server laufen (die Hardware ist dafür ausgelegt).

Nun soll es möglich sein den Modus des Hyper-V-Clusters auch auf aktiv-aktiv zu setzen. Ich kann zwar den gesamten Hyper-V-Clusterdienst auf den anderen Knoten verschieben, aber dann betrifft es halt auch alle VM's.

Wo kann ich den Cluster auf aktiv-aktiv setzen?

Siehe hier: 2

Gruß
Torsten
Mitglied: builder4242
09.11.2012, aktualisiert um 08:55 Uhr
Hallo,

Wie sieht denn deine Umgebung im ganzen aus? Läuft noch eine SAN?

Hast du alle HV Einstellungen vorgenommen, z.B. MAC Spoofing, Multipath E/A usw.?

Gruß
Bitte warten ..
Mitglied: goodbytes
09.11.2012 um 09:41 Uhr
Hallo builder4242,
es handelt sich um zwei Server, welche direkt über zwei SAS-Controller (wegen Redundanz) auf ein gemeinsames Storage zugreifen. Hier befinden sich natürlich die VM`s. Das reine Failover funktioniert auch bestens. Wenn ich den Server, auf dem die VM's gerade gehostet sind herunterfahre übernimmt der zweite Server ordnungsgemäß.

MAC Spoofing hatte ich bei den VM's noch nicht aktiviert, jetzt ist es aber drin. Wo finde ich Multipath E/A ?

Welche Einstellungen sind für den aktiv-aktiv Modus noch relevant?

Gruß
Torsten
Bitte warten ..
Mitglied: b11ck
09.11.2012 um 10:47 Uhr
Hallo

Mir ist bei meinen bisherigen Recherchen gar nicht aufgefallen, wie ein Aktiv-Passiv mit zwei Servern mit dem Failovercluster-Manager unter 2008 R2 zu konfigurieren wäre. Möglicherweise habe ich da aber auch was übersehen.

Kannst du nicht via Live-Migration einige VMs auf den anderen Knoten nehmen?

Hast Du möglicherweise Cluster Shared Volumes ("Freigegeben Clustervolumen") nicht aktiviert? Das führt dazu, dass alle VMS einer Partition auf der gleichen Node laufen müssen.

Google sollte eigentlich genügend Anleitungen hierzu liefern.

Gruss
Bitte warten ..
Mitglied: goodbytes
09.11.2012 um 12:05 Uhr
Hallo b11ck,
siehst du, man lernt nie aus. Ich habe dummerweise den Falschen Weg zur Konfiguration gewählt.

Im Failover-Clustermanager habe ich das Laufwerk auf dem Storage unter dem Punkt "Speicher" aktiviert. Allerdings "sieht" dann immer nur ein Server den Speicher. Erst wenn der Server weg ist wird beim zweiten Server automatisch das (oder die) Laufwerk(e) eingeblendet und die VM`s laufen weiter, da der Inhalt des Arbeitsspeichers ebenfalls in diesem Speicher liegt.

Die Kontrolle wird quasi vom zweiten Server übernommen, wenn kein Heartbeat mehr da ist.. Dadurch könnten auch beide Server nicht gleichzeitig aktiv sein.

Dein Tipp war Gold wert, vielen Dank !!!

Manchmal sieht man den Wald vor lauter Bäumen nicht...

Gruß
Torsten
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Hyper V Failovercluster Verstaendnisproblem Aktiv Aktiv bzw aktiv Passiv
Frage von moekewaHyper-V4 Kommentare

Hallo, ich habe da leider ein kleines Verständnisproblem bei Hyper V Failoverclustering. ich habe es jetzt wie folgt verstanden: ...

Hyper-V
Hyper-V Failover Cluster Best Practise
gelöst Frage von dan0neHyper-V3 Kommentare

Hallo an alle, ich habe mir zu Testzwecken 2 HP Microserver mit jeweils 16GB ECC Ram gekauft. Dazu habe ...

SAN, NAS, DAS
Frage zu Storage für Hyper-V Failover-Cluster
Frage von fanelloSAN, NAS, DAS2 Kommentare

Hi, wir planen für unserer VMs einen Failover Cluster mit Win Server 2012 R2. Leider musste ich feststellen, dass ...

Hyper-V
MS Failover Cluster als VM unter Hyper-V und Snapshots
Frage von emeriksHyper-V13 Kommentare

Hi, kann jemand sagen, ob Hyper-V von VM's mit Windows Server, welche zu einem Failover Cluster gehören, Snapshots erstellen ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 StundeInternet1 Kommentar

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 7 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 18 StundenWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 20 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen13 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...