Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Hyper-V Server 2012 Externer Switch sporadisch keine Verbindung

Frage Microsoft Windows Netzwerk

Mitglied: ItsMe84

ItsMe84 (Level 1) - Jetzt verbinden

11.07.2014 um 14:54 Uhr, 2113 Aufrufe, 8 Kommentare

Hallo, Administrator.de-Gemeinde.

Ich habe ein sporadisch autretendes Problem, dessen Ursache ich leider nicht auf die Schliche komme. Google hilft hier leider auch nicht.
An einem Windows 2012 Std. Server (ProLiant ML 350, 64 GB RAM, alle Updates installiert.) mit installierter Hyper-V Rolle tritt folgendes Problem auf:

In unregelmäßigen, nicht nachvollziehbaren Abständen kann der eingerichtetet externe Swich keine Verbindung mehr zum physikalischen Netz aufbauen. (Bisher innerhalb von zwei Monaten drei Ausfälle)
Die Verbindungen der VMs innerhalb des Switchen ist dann aber noch ok. Wenn dieser Fall eintritt reicht es, den physikalischen NIC kurz zu deaktivieren und wieder aktiv zu schalten, das Problem ist erledigt. Alternativ kann das Netzwerkkabel kurz entfernt und sofort wieder gesteckt werden. -Alles wieder gut.

Leider kann ich das Problem nicht provozieren und es gibt auch keine Fehler oder Hinweise in der Ereignisanzeige. Da es sich hierbei um ein Produktivsystem mit 4 VMs handelt ist dies aber ein Problem, was dringend aus er Welt muss.

Falls jemand eine Idee oder sogar Lösung hat, immer her damit.

Bei Fragen oder falls mehr Informationen gebraucht werden bin ich selbstverständlich sofort zustelle.
Mitglied: aqui
11.07.2014, aktualisiert um 15:16 Uhr
Etwas verwirrend...
kann der eingerichtetet externe Swich keine Verbindung mehr zum physikalischen Netz aufbauen.
Der "externe" Switch ist doch immer das physische Netz ?? Wie ist also diese kryptische Äußerung gemeint ??
Die Verbindungen der VMs innerhalb des Switchen ist dann aber noch ok.
Ooops...ja welchen Switch meinst du denn jetzt ?? Den internen vSwitch im Hypervisor selber oder den externen, physischen der ja das eigentliche physische Netz darstellt.
Deine Beschreibung ist da sehr unklar...
Logisch das der interne vSwitch nie betroffen ist, denn der rennt ja als Software innerhalb des Hypervisors, ist also nur virtuell. Sehr unwahrscheinlich das da Fehler passieren die dann nicht auch Einfluss auf das gesamte OS des Hypervisors hätten...logisch.

OK, versteht man es jetzt so, das du die Verbindung von der physischen Karte des Hypervisor Hosts mit dem physischen Switch meinst, dann kann das mehrere Ursachen haben.
  • Defekte NIC im Hypervisor Host
  • Defektes Kabel
  • Defekter Switchport
  • Defekter Switch
  • Probleme mit der Port Autonegotiation (Speed / Duplex Mode)
Kannst diese Ursachen sicher ausschliessen ??
Häufig ist der letzte Punkt, das passiert hie und da mal wenn nicht die aktuellsten NIC Treiber und die aktuellste Switch Firmware verwendet werden.
Hast du darauf bei dir geachtet das BEIDES auf dem aktuellsten Stand ist ?
Aber auch dann kann das passieren und dann hilft nur die Port Parameter statisch und zwar auf beiden Seiten des Kabels, sprich NIC und Switchport einzustellen ala 1000 Mbit / Fullduplex.
Das fixt in der Regel dieses Problem.
Bitte warten ..
Mitglied: certifiedit.net
11.07.2014 um 15:20 Uhr
Hi aqui,

ich glaube, er meint das Ding von vSwitch auf physik. Netzwerk.

Vermute hier: Treiberupdate.

Grüße
Bitte warten ..
Mitglied: ItsMe84
11.07.2014 um 17:39 Uhr
Sorry, ich habe mich hier in der Tat nicht eindeutig ausgedrückt.

Gemeint ist der vSwitch innerhalb HyperV. Hier können Switche in drei Kategorien mit unterschiedlichen Funktionsweisen konfiguriert werden. (extern, intern, privat)
Der betroffene vSwitch ist einer der Kategorie "extern".
Die aktuellsten NIC-Treiber von HP sind installiert. Das war selbstverständlich mein erster Verdacht. Ggf. muss ich mich direkt mit HP in Verbindung setzen, vlt. ist da ja das Problem zumindest bekannt.

Hardware Probleme wie Kabel usw. kann ich sicher ausschließen. Die Hardware ist brandneu und die Kabel wurden probehalber schon getauscht.

Dass vSwitche nicht funktionieren habe ich eignetlich noch nicht gehört (außer Fehlbedieung natürlich), daher ging meine Vermutung auch eher Richtung Treiber. -Leider ohne Erfolg.
Bitte warten ..
Mitglied: aqui
11.07.2014, aktualisiert 12.07.2014
Hier können Switche in drei Kategorien mit unterschiedlichen Funktionsweisen konfiguriert werden. (extern, intern, privat)
Typisch mal wieder unsinnige Microsoft Nomenklatur aber dafür kannst du ja auch nichts. Das müssen dann Netzwerker wieder ausbaden
Was die sich dann unter einem "externen vSwitch" oder auch einem "privaten" vorstellen wiess der Wind. Netzwerktypisch ist das nicht. Vermutlich sind damit NAT Mode, Host Mode und Bridge Mode gemeint ?!
Hardware Probleme wie Kabel usw. kann ich sicher ausschließen.
Kannst du auch das oben angesprochene Autonegotiation Problem zwischen physischer NIC und physischem Switch sicher ausschließen ?
Bitte warten ..
Mitglied: Pjordorf
11.07.2014 um 21:51 Uhr
Hallo,

Zitat von ItsMe84:
Der betroffene vSwitch ist einer der Kategorie "extern".
Und? Was hängt da Extern drann? Ein Switch, oder? Und der ist als Fehlerquelle auszuschliessen? Mal den Kabelhai auf dieses Interface mitlaufen lassen? Was sagen die Protokolle deines echten Switch wo ja wohl dein Externer vSwitch angepappt ist?

Die Hardware ist brandneu
Das sagt nichts darüber aus das es nicht Defekt ist oder falsch konfiguriert. Was steht in den Protokollen? Ist z.B. erkennbar das der Port seine Übertragungsrate ändert wenn das Problem auftaucht und und und...

Gruß,
Peter
Bitte warten ..
Mitglied: Pjordorf
11.07.2014 um 21:56 Uhr
Hallo aqui,

Zitat von aqui:
Typisch mal wieder unsinnige Microsoft Nomenklatur aber dafür kannst du ja auch nicht.
Siehe mal hier rein http://blogs.technet.com/b/jhoward/archive/2008/06/17/hyper-v-what-are- ... . Irgendwelche Namen mussten die Kinder doch bekommen

Gruß,
Peter
Bitte warten ..
Mitglied: wiesi200
11.07.2014 um 22:10 Uhr
Zitat von aqui:

> Hier können Switche in drei Kategorien mit unterschiedlichen Funktionsweisen konfiguriert werden. (extern, intern,
privat)
Typisch mal wieder unsinnige Microsoft Nomenklatur aber dafür kannst du ja auch nicht.
Was die sich dann unter einem "externen vSwitch" oder auch einem "privaten" vorstellen wiess der Wind.
Netzwerktypisch ist das nicht. Vermutlich sind damit NAT Mode, Host Mode und Bridge Mode gemeint ?!

Tja Microsoft versucht eben auch Hobby Admin kompatibel zu sein. Aber sind deren Begriffe für die entsprechenden Modi

Mich würd bei der Geschichte noch interessieren ob der Verwaltungszugriff auf den Host dann über die Netzwerkkarte auch noch möglich ist.
Bitte warten ..
Mitglied: certifiedit.net
11.07.2014 um 22:21 Uhr
Zitat von wiesi200:

> Zitat von aqui:
>
> > Hier können Switche in drei Kategorien mit unterschiedlichen Funktionsweisen konfiguriert werden. (extern, intern,
> privat)
> Typisch mal wieder unsinnige Microsoft Nomenklatur aber dafür kannst du ja auch nicht.
> Was die sich dann unter einem "externen vSwitch" oder auch einem "privaten" vorstellen wiess der
Wind.
> Netzwerktypisch ist das nicht. Vermutlich sind damit NAT Mode, Host Mode und Bridge Mode gemeint ?!

Tja Microsoft versucht eben auch Hobby Admin kompatibel zu sein. Aber sind deren Begriffe für die entsprechenden Modi

Mich würd bei der Geschichte noch interessieren ob der Verwaltungszugriff auf den Host dann über die Netzwerkkarte auch
noch möglich

Eigtl ist das ganz easy extern geht dahinter. Intern ist vm plus host und privat ist schlussendlich nur die angeschlossenen vms.

Wie gesagt entweder Treiber oder konfigurationsproblem.

Bei Bedarf kann ich mir das ProblemKind aber gerne mal an schauen, dann bitte per PM.
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Hyper V Server 2012
gelöst Frage von timo-bileHyper-V7 Kommentare

Guten Tag. Ich bin gerade beim Einrichten einer Virtualisierung und komme einfach nicht weiter. Ich habe einem Dell Poweredge ...

Hyper-V
Hyper V Server 2012 oder 2016?
gelöst Frage von 129511Hyper-V6 Kommentare

Ich bin gerade dabei meinen Server zu installieren. Soll ich als Host den Hyper-V Server 2012 oder 2016 installieren? ...

Microsoft
Server 2012 Hyper-V kann nicht importieren
Frage von thomasreischerMicrosoft7 Kommentare

Hallo! Ich möchte demnächst meinen WSUS in einer virtuellen Server 2012 R2 Instanz installieren. Diese Instanz wird von einem ...

Hardware
USV für HYPER-V-2012-Server
Frage von MiStHardware3 Kommentare

Hallo, ich habe 2 Hyper-V-2012R2-Server (Core-Version) auf dem 2 VM´s laufen. Die beiden Server arbeiten im Replica-Betrieb. VM1: Win2008R2 ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 3 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...