Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hyper V Virtuelle Maschine wird nicht mehr angezeigt

Frage Virtualisierung

Mitglied: floges

floges (Level 1) - Jetzt verbinden

14.01.2012, aktualisiert 00:34 Uhr, 9255 Aufrufe, 6 Kommentare

Hallo werte Kollegen

Bei mir hat sich ein Problem mit einem unter HyperV virtualisierten Exchange ergeben.
Kurz zur Umgebung:

Hostsystem:
Server 2008 R2 mit HyperV Rolle
Raid 5 für die VMS 2,7TB groß

Im HyperV sind 5 virtuelle Maschinen angelegt. Bei dem Exchange war noch ein Snapshot vorhanden, der leider schon 16GB groß war/ist. Ich habe die VM´s sauber heruntergefahren, der Exchange blieb dann ca, 1 Stunde im Zustand "beenden" hängen. Nach einer Stunde habe ich das Hostsystem dann neugestartet.
Es werden nach dem Neustart alle anderen VM´s angezeigt nur der Exchange taucht nicht mehr in der MMC auf...?!
Folgende Artikel habe ich schon abgearbeitet:

http://www.hyper-v-server.de/hypervisor/wiederherstellen-einer-nicht-ex ...

wobei ich sagen muss, dass die alten XML Dateien vom Exchange noch an den Zielorten vorhanden waren und auch richtig verknüpft sind.

Auch die Foreneinträge bezogen auf den Virenscanner habe ich abgearbeitet, TrendMicro ist jetzt so konfiguriert, dass die HyperV Verzeichnisse und der Speicherort der VMs nicht mehr gescanned werden.

Diesen Artikel möchte ich ungern in Angriff nehmen, da ich ja immer noch den Snapshot brauche http://www.necron.mcseboard.de/2008/10/26/hyper-v-vms-verschieben-und-w ...

Eine Datensicherung von dem Exchange ist zwar vorhanden, allerdings von gestern. Und ich möchte das nur als letzte Option nehmen.

Die Exchange VM und die Snapshots sind auch noch vollständig inkl. aller XML Dateien vorhanden... nur werden Sie nicht angezeigt.

Es wäre echt Super wenn noch einer einen Tipp hätte oder vielleicht sogar die Lösung, stehe hier etwas auf dem Schlauch...

Vielen Dank schon mal im Vorraus und gute Nacht!
Mitglied: floges
14.01.2012 um 11:34 Uhr
Guten Morgen,

im Ereignisprotokoll habe ich noch folgenden Eintrag zur VM gefunden.

Die Konfiguration eines virtuellen Computers kann nicht geladen werden, da sie beschädigt ist (ID des virtuellen Computers: 2117F8BB-D735-46C7-93F8-7F0E64D52BF6). Löschen Sie die Konfigurationsdatei des virtuellen Computers (XML-Datei), und erstellen Sie den virtuellen Computer neu.

Aber wie soll ich den di XML neuerstellen? Ich meine die wird doch automatisch beim erstellen einer VM erstellt?!.
Bei der ID handelt es sich um die VHD des Exchange nicht um die des Snapshots.
Bitte warten ..
Mitglied: Pjordorf
14.01.2012 um 15:03 Uhr
Hallo,

Zitat von floges:
Löschen Sie die Konfigurationsdatei des virtuellen Computers (XML-Datei), und erstellen Sie den virtuellen Computer neu.
Hast du dir diesen Satz überhaupt durchgelesen und verstanden? Dann tu es doch!

Gruß,
Peter
Bitte warten ..
Mitglied: floges
14.01.2012 um 15:10 Uhr
Hallo Peter,

ja den Satz habe ich mir richtig durchgelesen, und dass wäre ja auch einfach gemacht, aber ich bin mir nicht sicher wie es sich mit dem Snapshot verhält der ja irgendwie mit der VHD Verknüpft sein muss. Soll ich den die XML von der VHD und dem Snapshot löschen?

Wenn ich keinen Snapshot hätte, müsste ich ja nur eine neue VM erstellen, dann die VHD als vorhande Festplatte hinzufügen, ein paar Einstellungen in der Konfiguration anpassen, starten und gut ist die Sache, Aber bei der Snapshotdatei....`?!
Bitte warten ..
Mitglied: Pjordorf
14.01.2012 um 19:22 Uhr
Hallo,

Zitat von floges:
aber ich bin mir nicht sicher wie es sich mit dem Snapshot verhält
Ich habe daher mal für dich gesucht und nach 30 sekunden folgendes gefunden: http://itproctology.blogspot.com/2008/06/how-to-manually-merge-hyper-v- ...

Aber bei der Snapshotdatei
Warum benutzt du Snapshot Dateien bei einem Exchange wo du dir keinen Datenverlust leisten kannst?

Gruß,
Peter
Bitte warten ..
Mitglied: floges
14.01.2012 um 20:14 Uhr
Auf dem Exchange wurden vor einiger Zeit Updates installiert, und vorher wurde ein Snapshot gemacht... naja und der wurde danach aus irgendwelchen Gründen nicht wieder gelöscht...

Ich bin mittlerweile auf dieses Tutorial gestoßen http://www.it-cast.de/alle/videocast-hyper-v-vhds-und-avhds-zusammenfhr ...

Gut gemacht und vom Inhalt das gleiche was Peter gepostet hat.

Im Moment kopiere ich die AVHD und VHD Dateien noch aufs NAS um dann gleich mal die zusammenführung zu machen.
Bitte warten ..
Mitglied: floges
14.01.2012 um 22:04 Uhr
Das Zusammenführen der VHD hat geklappt. Ich habe dann eine neue VM erstellt und die VHD Datei angehängt. Nach der Installation der Integrationstools, ein paar Einstellungen und einem Neustart lief alles wieder.
Sogar der zickige Blackberry Enterprise Express....

@ Peter: Danke für die Hilfe, schönen Sonntag noch!
Bitte warten ..
Ähnliche Inhalte
Backup
gelöst Windows Server Sicherung v. virtueller Maschine (HYPER-V), wie recovern? (3)

Frage von departure69 zum Thema Backup ...

Windows Server
Bestehenden Hyper-V virtualisieren? (4)

Frage von StephanB84 zum Thema Windows Server ...

Hyper-V
gelöst Hyper-V-Maschinen träge bzw. langsam (16)

Frage von 133523 zum Thema Hyper-V ...

Windows Server
Terminalserver auf Hyper-V friert ein (10)

Frage von anaxagoras83 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (22)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Drucker und Scanner
Erfahrungen mit Enterprise-Tintenstrahldruckern A4 und A3 (14)

Frage von User1000 zum Thema Drucker und Scanner ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Webentwicklung ...