Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Hyper-V VM startet nicht wegen angeblich fehlendem Speicher

Frage Microsoft Windows Server

Mitglied: Chriz73

Chriz73 (Level 1) - Jetzt verbinden

01.06.2011 um 14:44 Uhr, 12798 Aufrufe, 4 Kommentare

Hyper-V VM auf Server 2008 R2 Enterprise mit SP1 startet wegen fehlenden Speicher nicht, obwohl noch genügend Speicher zumindest im Standby steht.

Hallo zusammen,

folgendes Szenario:

Fujitsu TX300S2 - Intel Xeon 5405, 2,0 GHz - 18 GB RAM
Windows Server 2008 Enterprise R2 SP1

VM1 mit SBS 2008 und 8 GB statisch - läuft
VM2 mit Server 2008 R2 SP1 (oder anderes, ist egal) mit 4 GB statisch oder dynamisch - läuft nicht und soll gestartet werden

Speicherauslastung: In Verwendung: 9390 MB - Geändert: 43 MB - Standby: 8990 MB - Frei: 7 MB

VM2 per Hyper-V Manager gestartet, Meldung ID 3122: "Im System ist nicht genügend Arbeitsspeicher vorhanden..."

Host rebooted, Speicherauslastung wie oben, nur über 8000 MB Frei... startet trotzdem nicht, gleicher Fehler...

verkleiner ich den Speicher der VM2 auf unter 1024 MB, startet die. Stelle ich auf dynamisch 1024MB bis 4096 MB ein, startet die VM, hat aber nur 1024 MB Speicher und nimmt sich nicht mehr...

Irgendwelche Antworten, Tipps, Anregungen?

Danke im voraus...

Chriz73
Mitglied: jenni
01.06.2011 um 22:07 Uhr
Nabend

Wie viel GB hast du der Parent Partition gegeben?
Bitte warten ..
Mitglied: Grave111
02.06.2011 um 17:38 Uhr
Hallo,

Reboot des lokalen Servers schon Probiert?

Hatte eine ähnliches Problem nach einem Neustart gings...

Gruß,
Bitte warten ..
Mitglied: Chriz73
03.06.2011 um 11:33 Uhr
Hi,

Problem gelöst. Im Key HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Virtualization\MemoryReserve stand 2048 (um der Parent Partition bzw. dem Host 2 GB Speicher zu reservieren) in hexadezimal anstatt in dezimal, was 8264 MB reservierten Speicher für den Host ergibt. Es blieb daher zu wenig Speicher übrig für weitere VMs. Key geändert, reboot, läuft...

Vielen Dank!

Gruß

Chriz
Bitte warten ..
Mitglied: Mr-IKS
15.09.2011 um 19:23 Uhr
Hi,

ich habe quasi das selbe Problem ... dumm nur das es bei mir den Reg Eintrag nicht gibt.
Was nun ???

VG ! Mr IKS
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Server
Windows server 2012 r2 hyper v vm startet nur schwarz (5)

Frage von meister00 zum Thema Windows Server ...

Hyper-V
Hyper-V VM verliert Festplatte im Betrieb und startet neu (1)

Frage von derLenhart zum Thema Hyper-V ...

Xenserver
gelöst Windows VM startet nur, wenn die CD eingelegt ist (1)

Frage von DaveDave zum Thema Xenserver ...

Hyper-V
Hyper-V VM Umzug (3)

Frage von Bytedreher zum Thema Hyper-V ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...