Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Hyperterminal empfängt Antwort, andere Terminalprogramme nicht

Frage Netzwerke

Mitglied: seppi123

seppi123 (Level 1) - Jetzt verbinden

08.03.2006, aktualisiert 10.03.2006, 5230 Aufrufe, 5 Kommentare

Hallo!

ich möchte einen Befehl an eine COM Schnittstelle rausschicken. Das klappt mit Hyperterminal prima. Es kommt auch eine Antwort vom Gerät zurück. Wenn ich es mit einem anderen Programm (TestXpert) mache dann kann ich nur schicken aber nichts empfangen. auch andere Terminalprogramme können nichts empfangen...

Habe XP SP1 ohne Firewall etc. Sende/Empfangspuffer ist auf minimal gesetzt.
Mitglied: aqui
08.03.2006 um 20:59 Uhr
Ist bei diesen Programmen ggf. per default Hardware oder Software Handshaking für die COM Schnittstelle eingeschaltet ??? Das könnte der Grund sein ! Über das Setup kannst du das ausschalten und dann sollte es klappen
Bitte warten ..
Mitglied: seppi123
08.03.2006 um 21:16 Uhr
Hallo!

Die ganzen Einstellungen sind gleich (Datenbits, Parität etc.) Das mit dem Handshaking muss ich noch suchen. Kann es sein wenn das falsch eingestellt ist das das Senden trotzdem funktioniert?? Oder müsste dann eher gar nichts gehen?

Danke!
Bitte warten ..
Mitglied: aqui
08.03.2006 um 21:56 Uhr
Das kann so sein je nachdem wie der logische Zustand deiner Handshaking Pins an der COM Schnittstelle ist. Das kann vom Kabel usw. abhängen. Am besten alles ausschalten, dann sollte es klappen.
Jedes Terminal Programm sollte ein Setup haben in dem das einzustellen ist. Sehr populär ist z.B.TeraTerm:
http://hp.vector.co.jp/authors/VA002416/teraterm.html
Dort ist das natürlich konfigurierbar
Bitte warten ..
Mitglied: seppi123
09.03.2006 um 20:09 Uhr
Hi! Also das mit dem Handshake ist richtig eingestellt. Ich muss dazu sagen das einige andere Maschinen auch angesteuert werden und es bringen eigentlich alle Meldungen zurück die es sollen nur ein neues "Lecroy Messgerät" mach dies NUR mit Hyperterminal und TeraTerm.
Bitte warten ..
Mitglied: aqui
10.03.2006 um 21:40 Uhr
Dann wirds schwierig. Um da jetzt tiefer einzusteigen brauchst du eine sog. Break Out Box. Das ist ein Kasten durch den du die serielle Schnittstelle durchschleifst und der dir den Status der Leitungen mit einer Leuchtdiode anzeigt. Hier müsstest du jetzt Step by Step vergleichen um den Schuldigen rauszufinden.
Wenn Hyperterm und TeraTerm es richtig machen vermute ich mal vage das die anderen Programme die Handshake Leitungen nicht richtig bedienen oder ggf. auf Steuerzeichen falsch reagieren...
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Übertrag in eine andere Tabelle (6)

Frage von charmeur zum Thema Microsoft Office ...

Outlook & Mail
Automatische Antwort Email Exchange Oulook (3)

Frage von kingsepp zum Thema Outlook & Mail ...

Administrator.de Feedback
Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen (2)

Tipp von pattern zum Thema Administrator.de Feedback ...

Router & Routing
LTE Router von Vodafone Verbindung ins interne andere Netz (7)

Frage von WinLiCLI zum Thema Router & Routing ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...