Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Icinga Monitoring Problem (No output returned from plugin)

Frage Netzwerke Monitoring

Mitglied: speedy-luis

speedy-luis (Level 1) - Jetzt verbinden

24.09.2012, aktualisiert 10:34 Uhr, 4787 Aufrufe, 5 Kommentare

Hallo,

ich habe ein Problem mit meinem Icinga Server.

Ich muss dazu sagen, ich bin ein Anfänger in diesem Bereich.

Grundsystem ist ein Debian Squeeze 6.0.5.

Die Überwachung unserer Windowsserver funktioniert soweit problemlos. Nun habe ich mich an die Linux Server gewagt.

NRPE auf Client und Server ist installiert.
Ein Test mittels "/usr/lib/nagios/plugins/check_nrpe -H 192.168.4.10" funktioniert, auch Tests wie "/usr/lib/nagios/plugins/check_nrpe -H 192.168.4.10 -c check_load" funktionieren.

Das Webinterface gibt aber keinen Output (No output returned from plugin).

Woran könnte das liegen?

Hier mal die relevanten Auszüge aus den Config-Dateien:

## Host Definition
define host{
use linux-server
host_name samba.xx.com
alias samba
address 192.168.4.10
}

## Service Definition
define service{
use local-service
host_name samba.xx.com
service_description CPU check
check_command check_nrpe!check_load
}

## Command Definition
define command{
command_name check_local_load
command_line /usr/lib/nagios/plugins/check_load -w $ARG1$ -c $ARG2$
}


Vielleicht könnt ihr mir ja helfen.

Gruß Speedy
Mitglied: Deepsys
24.09.2012 um 11:36 Uhr
Hallo,


Zitat von speedy-luis:

## Service Definition
define service{
....
check_command check_nrpe!check_load
}

## Command Definition
define command{
command_name check_local_load
command_line /usr/lib/nagios/plugins/check_load -w $ARG1$ -c $ARG2$
}
Ähm, der Service ruft aber nicht dieses Check Command auf.
Das hier ist der check_load und nicht der check_nrpe.

Stimmt das nur hier nicht, oder auch in deiner Konfig nicht, denn so hätte der Service gar kein Command ...

VG
Deepsys
Bitte warten ..
Mitglied: speedy-luis
24.09.2012 um 11:47 Uhr
Hallo,

wie gesagt, ich bin auf diesem Gebiet ein Neuling.

Wie müsste die Config denn aussehen? Meinst du vielleicht das hier:

define command{
command_name check_nrpe
command_line /usr/lib/nagios/plugins/check_nrpe -H $HOSTARDRESS
}

Gruß Speedy
Bitte warten ..
Mitglied: Deepsys
24.09.2012 um 12:30 Uhr
Hi,

schon besser, nur weiß nrpe dann immer noch nicht was es damit machen soll.

Richtiger wäre:
01.
command_line /usr/lib/nagios/plugins/check_nrpe -H $HOSTARDRESS -c $ARG1$
Dann kann nrpe auch mit deinem check_load was machen
Ich frage mich aber wie da das dann bei den Windows-Maschinen laufen hast ....

VG
Deepsys
Bitte warten ..
Mitglied: speedy-luis
24.09.2012 um 13:11 Uhr
Super, jetzt funktioniert es.

Vielen Dank!

Wenn du willst, kann ich dir gerne die Configs schicken, damit du siehst, wie das mit den Windows-Maschinen läuft..

Gruß Speedy
Bitte warten ..
Mitglied: Deepsys
24.09.2012 um 13:32 Uhr
Hi,

bitte schön.

Und wenn jetzt alles läuft, brauche ich auch keine weitere Konfig

VG
Deepsys
Bitte warten ..
Ähnliche Inhalte
Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Netzwerkgrundlagen
Multi NAT Problem (9)

Frage von Gr33n93 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (17)

Frage von montylein1981 zum Thema Windows Server ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst ZIP-Archive nach Dateien durchsuchen und Pfade ausgeben (33)

Frage von evinben zum Thema Batch & Shell ...

Router & Routing
Routingproblem in Homerouter-Kaskade mit Raspi (19)

Frage von Oldschool zum Thema Router & Routing ...

Server
Freenas schlechte Schreib Performance bei NFS (16)

Frage von janosch12 zum Thema Server ...

Windows Server
Fehler Vertrauensstellung im AD (14)

Frage von thomas-99 zum Thema Windows Server ...