Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Icinga Monitoring Problem (No output returned from plugin)

Frage Netzwerke Monitoring

Mitglied: speedy-luis

speedy-luis (Level 1) - Jetzt verbinden

24.09.2012, aktualisiert 10:34 Uhr, 4869 Aufrufe, 5 Kommentare

Hallo,

ich habe ein Problem mit meinem Icinga Server.

Ich muss dazu sagen, ich bin ein Anfänger in diesem Bereich.

Grundsystem ist ein Debian Squeeze 6.0.5.

Die Überwachung unserer Windowsserver funktioniert soweit problemlos. Nun habe ich mich an die Linux Server gewagt.

NRPE auf Client und Server ist installiert.
Ein Test mittels "/usr/lib/nagios/plugins/check_nrpe -H 192.168.4.10" funktioniert, auch Tests wie "/usr/lib/nagios/plugins/check_nrpe -H 192.168.4.10 -c check_load" funktionieren.

Das Webinterface gibt aber keinen Output (No output returned from plugin).

Woran könnte das liegen?

Hier mal die relevanten Auszüge aus den Config-Dateien:

## Host Definition
define host{
use linux-server
host_name samba.xx.com
alias samba
address 192.168.4.10
}

## Service Definition
define service{
use local-service
host_name samba.xx.com
service_description CPU check
check_command check_nrpe!check_load
}

## Command Definition
define command{
command_name check_local_load
command_line /usr/lib/nagios/plugins/check_load -w $ARG1$ -c $ARG2$
}


Vielleicht könnt ihr mir ja helfen.

Gruß Speedy
Mitglied: Deepsys
24.09.2012 um 11:36 Uhr
Hallo,


Zitat von speedy-luis:

## Service Definition
define service{
....
check_command check_nrpe!check_load
}

## Command Definition
define command{
command_name check_local_load
command_line /usr/lib/nagios/plugins/check_load -w $ARG1$ -c $ARG2$
}
Ähm, der Service ruft aber nicht dieses Check Command auf.
Das hier ist der check_load und nicht der check_nrpe.

Stimmt das nur hier nicht, oder auch in deiner Konfig nicht, denn so hätte der Service gar kein Command ...

VG
Deepsys
Bitte warten ..
Mitglied: speedy-luis
24.09.2012 um 11:47 Uhr
Hallo,

wie gesagt, ich bin auf diesem Gebiet ein Neuling.

Wie müsste die Config denn aussehen? Meinst du vielleicht das hier:

define command{
command_name check_nrpe
command_line /usr/lib/nagios/plugins/check_nrpe -H $HOSTARDRESS
}

Gruß Speedy
Bitte warten ..
Mitglied: Deepsys
24.09.2012 um 12:30 Uhr
Hi,

schon besser, nur weiß nrpe dann immer noch nicht was es damit machen soll.

Richtiger wäre:
01.
command_line /usr/lib/nagios/plugins/check_nrpe -H $HOSTARDRESS -c $ARG1$
Dann kann nrpe auch mit deinem check_load was machen
Ich frage mich aber wie da das dann bei den Windows-Maschinen laufen hast ....

VG
Deepsys
Bitte warten ..
Mitglied: speedy-luis
24.09.2012 um 13:11 Uhr
Super, jetzt funktioniert es.

Vielen Dank!

Wenn du willst, kann ich dir gerne die Configs schicken, damit du siehst, wie das mit den Windows-Maschinen läuft..

Gruß Speedy
Bitte warten ..
Mitglied: Deepsys
24.09.2012 um 13:32 Uhr
Hi,

bitte schön.

Und wenn jetzt alles läuft, brauche ich auch keine weitere Konfig

VG
Deepsys
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
VBA Excel Problem mit UserForm, ListBox und TextBox

Frage von abuelito zum Thema Microsoft Office ...

Windows Server
Ordner erstellen Problem (1)

Frage von IrgendEinName zum Thema Windows Server ...

Windows Update
WSUS Problem, einige Clients ziehen keine Updates mehr (7)

Frage von Leo-le zum Thema Windows Update ...

LAN, WAN, Wireless
Problem mit W-LAN Einbindung bei UniFi AP-AC-Mesh (1)

Frage von mayli01 zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Viren und Trojaner
Ransomware .nm4 (14)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

iOS
16 iPads zentrall verwalten (14)

Frage von simonlohr zum Thema iOS ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (11)

Frage von Matsushita zum Thema Microsoft Office ...