Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ICS - WLAN-Client konfigurieren für Gemeinsam genutzte Internetverbindung

Frage Netzwerke

Mitglied: petersch41

petersch41 (Level 1) - Jetzt verbinden

04.12.2009, aktualisiert 18.10.2012, 8364 Aufrufe, 4 Kommentare

Guten Abend,
ich bitte um Eure Unterstützung - ich stehe auf dem berühmten Schlauch...

Mein Desktop-PC hängt per Ethernet-Kabel an einer Fritz!Box, die als (WLAN-)Router dient. Mein Notebook greift via WLAN auf den Desktop zu (und vice cersa), alle Ressourcen auf beiden Rechnern (WinXP Home SP3) sind freigegeben. Funktioniert problemlos.

Neuerdings betreibe ich am Desktop ein UMTS-Modem (Huawei E156G) für den Internet-Zugriff. Auch das funktioniert einwandfrei. Um nun auch das Notebook ins Internet zu bringen, möchte ich ICS einsetzen. Auf dem Desktop als Host habe ich gemäß MS-Anleitung die "DFÜ-Verbindung" zum UMTS-Provider für ICS freigeschaltet; dadurch bekommt die LAN-Karte, die mit dem Router verbunden ist, automatisch die Netzwerkadresse 192.168.0.1. Damit das LAN/WLAN funktioniert, bekam die Fritz!Box manuell die Adresse 192.168.0.20 verpasst, der DHCP-Server ist aktiviert und kann Adressen im Bereich 192.168.0.2 bis...19 vergeben. Der WLAN-Adapter im Notebook ist weiterhin auf "Adresse automatisch beziehen" eingestellt. Das Datenverkehr zwischen den beiden Rechnern funktioniert wieder einwandfrei.

So, nach der MS-Anleitung ist das nun alles, was getan werden muss...

Auf der Client-Seite ist jedoch keine Spur zu entdecken, wie der Internetzugang über das WLAN/LAN funktionieren soll. Offensichtlich muss hier auch noch einiges getan werden (?), worüber sich die Anleitung ausschweigt. Und hier nun hoffe ich auf Eure Tipps, damit ich weiter komme.

Dank für jeden Hinweis!
Peter
Mitglied: aqui
04.12.2009, aktualisiert 18.10.2012
Nein, es muss nix weiter getan werden. Alle Schritte dafür erklärt dir auch dieses Tutorial nochmal im Detail:

http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Dein Laptop muss als Gateway und DNS Server die 192.168.0.1 bekommen haben von der DHCP Option des ICS Rechners, der dann auch das NAT ins UMTS macht.
Mit ipconfig -all in der Eingabeaufforderung kannst du das prüfen. Ein Ping einer Internet IP Adresse wie 193.99.144.85 (heise.de) oder 195.71.11.67 (spiegel.de) sollte dir dann eine Antwort bescheren !
Ggf. hilft eine Traceroute (tracert) oder pathping auf die IP Adressen um den Weg zu prüfen !
Bitte warten ..
Mitglied: petersch41
05.12.2009 um 12:46 Uhr
Zitat von aqui:
Dein Laptop muss als Gateway und DNS Server die 192.168.0.1 bekommen haben von der DHCP Option des ICS Rechners, der dann auch das NAT ins UMTS macht.

Tja, mein Laptop hat vom Router (!) die Gateway- und DNS-Server-Adresse 192.168.0.20 erhalten (dies ist ja die IP-Adresse des Routers)! Und mein Desktop ebenfalls...

Beschert mir der Umstand, dass ein "Bein" des LAN eine WLAN-Anbindung ist, Schwierigkeiten?

Hier die ipconfig-Ergebnisse:

Desktop-Rechner:
G:\Dokumente und Einstellungen\Peter>ipconfig /all

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : host
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Unbekannt
IP-Routing aktiviert. . . . . . . : Ja
WINS-Proxy aktiviert. . . . . . . : Nein

Ethernetadapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) Family PCI-E GBE NIC
Physikalische Adresse . . . . . . : 00-1F-D0-A4-8D-0E
DHCP aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.0.1
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.0.20
DNS-Server. . . . . . . . . . . . : 192.168.0.20

Notebook:
C:\Dokumente und Einstellungen\Peter>ipconfig /all

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : notebook
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Unbekannt
IP-Routing aktiviert. . . . . . . : Nein
WINS-Proxy aktiviert. . . . . . . : Nein

Ethernetadapter WLAN:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network Connection
Physikalische Adresse . . . . . . : 00-0E-35-EF-AE-7B
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.0.3
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.0.20
DHCP-Server . . . . . . . . . . . : 192.168.0.20
DNS-Server. . . . . . . . . . . . : 192.168.0.20
Lease erhalten. . . . . . . . . . : Samstag, 5. Dezember 2009 12:19:50
Lease läuft ab. . . . . . . . . . : Dienstag, 15. Dezember 2009 12:19:50

Was ist denn da noch falsch???
Bitte warten ..
Mitglied: aqui
05.12.2009 um 15:13 Uhr
Folgende wichtige Punkte:
  • Wie du den ICS Rechner nutzt per WLAN oder LAN spielt keine Rolle !!!
  • Ganz wichtig ist das du zwingend den DHCP Server auf deinem Router deaktivierst !! Sobald der Desktop ICS aktiv hat wird er selber zum DHCP Server und vergibt "von oben" selber IP Adressen, was auch zwingend so sein muss ! Der DSL Router darf KEINE IPs mehr per DHCP vergeben !!! (Steht auch so im Tutorial !!)
  • Am Laptop darf immer nur entweder WLAN oder LAN aktiv sein ! Niemals beides zusammen. Damit wärst du aktiv mit beiden Adaptern im gleichen IP netz und damit kann Windows nicht umgehen !! Deaktivier also dein WLAN (Schalter) wenn das LAN aktiv ist. Andersrum gehts immer automatisch wenn das LAN Interface keinen aktiven Link (kein gestecktes kabel) hat !

Genau das geht nämlich schief bei dir oben wie du selber sehen kannst !!! Dein DHCP Server ist die .20 und das ist definitiv NICHT der ICS rechner denn der hat ja logischerweise die .1 !!
Du solltest also Desktop und Laptop erstmal ganz isoliert in einem ICS Setup funktionstüchtig zum Laufen bringen ! Laptop und Desktop dann mal per Crossover mit ihren LAN Verbindungen zusammenstecken. Der Laptop bekommt so eine IP vom ICS Rechner was auch sein muss !!
Das muss dann so autark problemlos laufen.
Erst dann steckst du den DHCP passivierten Router wieder dran und testest die verbindung via WLAN. LAN kabel am Laptop dabei abziehen !
Auch hier bekommt der Laptop wieder eine IP (192.168.0.x) vom ICS Rechner was auch im WLAN so sein muss !!

Das Szenario ist ein sehr gängiges und rennt problemlos wenn man denn alles richtig macht !!
Bitte warten ..
Mitglied: petersch41
06.12.2009 um 08:45 Uhr
Danke, ich hab's kapiert..

Und es läuft jetzt!

Peter
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
gelöst Zwei separate Internet-Anschlüsse + gemeinsam genutzte Ethernet-Geräte (4)

Frage von FaulePflaume zum Thema Router & Routing ...

LAN, WAN, Wireless
Über WLAN nur temporär eine Internetverbindung

Frage von Dani zum Thema LAN, WAN, Wireless ...

Sicherheits-Tools
NCP-Client blockt Internetverbindung (2)

Frage von Judgelg zum Thema Sicherheits-Tools ...

Router & Routing
Zwei Fritzboxen, WLAN-Brücke und zwei VLANs - Routing konfigurieren (6)

Frage von no-idea zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...