Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ID 1085 Userenv Softwareverteilung

Frage Microsoft Windows Server

Mitglied: Alternativende

Alternativende (Level 2) - Jetzt verbinden

02.07.2008, aktualisiert 24.07.2008, 10245 Aufrufe, 12 Kommentare

Hallo zusammen,
ich wollte zwecks Arbeitsentlastung mit der Softwareverteilung einsteigen und habe alles soweit für den AdobeReader und JRE vorbereitet.
Nun habe ich eine VM XP Testmaschine auf dem DC laufen um diese Dinge auszuprobieren.
Die beiden Anwendungen sind zugewiesen und beim hochfahren taucht auch immer die Meldung auf das der Adobe Reader und JRE installiert werden, aber leider ohne das es passiert .

Die Fehlermeldung ist wie gesagt nun 1085 Userenv. Die Hilfeseiten von Microsoft habe ich nun mittlerweile alle abgearbeitet und auch die Hinweise bei Eventid.Net helfen nicht wirklich.

C:\Softwareinstall
Freigabe = Jeder (Vollzugriff )
Sicherheit = Administratoren ( Vollzugriff )
Authentifizierte Benutzer ( lesen,Ausführen )
Domänen Benutzer ( Lesen, Ausführen )
Domänencomputer ( Lesen, Ausführen )
Jeder ( Lesen, Ausführen )
System ( Lesen, Ausführen )

In diesem Ordner liegen die .msi Pakete. Die GPO Objekte werden durch Authentifizierte Benutzer delegiert.

d796e57b1aa75bc07ba7557850587435-softwareverteilung - Klicke auf das Bild, um es zu vergrößern


Der DC zeigt in seinem Ereignisprotokoll keine Fehler an.

Des weiteren habe ich noch einen kleinen eher ärgerlichen Fehler. Ich habe für alle Benutzer ein Hintergrundbild eingestellt, welches aber auf allen Clients erst richtig angezeigt wird, wenn man den Desktop aktualisiert. Dies ist nach jeder Anmeldung der Fall.
Es handelt sich um ein.jpg was sich unter Sysvol befindet.

Ärgerliche Dinge..
Mitglied: Logan000
02.07.2008 um 15:17 Uhr
Moin

Die Fehlermeldung ist wie gesagt nun 1085 Userenv.
Ich kenne wirklich alle Event ID und die Fehlermeldungen auswendig aber diese eine ist mir gerade entfallen

Ein paar Fragen:
- Weist du die Pakete unter Computer- oder Benutzerkonfiguration zu?
- Hast Du als Bereitstellungsquelle einen UNC Pfad angegeben?
- Woher hast Du die Pakete? Evtl. selbst erstellt?

Gruß L.
Bitte warten ..
Mitglied: Alternativende
02.07.2008 um 15:31 Uhr
Hi,
ja soetwas sollte man auch auswendig kennen ;)

The Group Policy client-side <extension> failed to execute. Please look for any errors reported earlier by that extension.

1. In der Computerkonfiguration.
2. \\DCNAME\Softwareinstall\
3. Ich habe es bei Adobe nach dieser Anleitung gemacht http://www.stepone2000.de/doku/Softwareverteilung_mit_Gruppenrichtlinie ... und das .MSI dementsprechend von C:\Dokumente blabla\Administrator\Lokale\Einstellungen\Temp\AcroRead.msi kopiert.

Der einzige Unterschied zu der Anleitung ist, dass ich eine eigene OU Softwareinstall erstellt habe in den ich den TestPC verschoben habe.
Bitte warten ..
Mitglied: Logan000
02.07.2008 um 16:04 Uhr
Ok

Das sieht eigentlich alles super aus.

Die Meldung besagt ja das es vorrangegangene Fehler im Ereignisprotokoll (des Clients) dazu gibt. Ist da irgend ein Hinweis?

Werden andere GPOs angewendet?

Ich nehme mal an Du hast schon versucht nur eine, deiner 2 Installations GPOs anzuwenden?

Gutes HowTo übrigens.
Bitte warten ..
Mitglied: Alternativende
03.07.2008 um 14:42 Uhr
Hi,
ja es werden auch andere GPO´s angewendet. Ich habe noch eine GPO für allgemeine Beschränkungen der User und eine andere für die Clients.
Alle GPO´s befinden sich aber in unterschiedlichen OU´s. Ich probiere jetzt das ganze mal indem ich die Softwareinstallation mit in die GPO für die Clients nehme mit dem AdobeReader 9.

Mal sehen ob das klappt...Vielleicht stimmt auch etwas mit der OU nicht ?
Bitte warten ..
Mitglied: Alternativende
03.07.2008 um 15:29 Uhr
So nun haben wir folgende Dinge in der Ereignisanzeige zu verzeichnen.
01.
ID 1807 
02.
 
03.
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert. 
Ich denke das ist soweit ganz richtig da ich sonst auch Probleme mit der Remotesteuerung bekomme.

01.
ID 101, 103 und 108 
02.
 
03.
Die Zuweisung der Anwendung Adobe Reader 9 - Deutsch der Richtlinie ClientsPolicy ist fehlgeschlagen. Fehler: Die Gruppenrichtlinienumgebung sollte die Erweiterung in der synchronen Vordergrundrichtlinienaktualisierung aufrufen.

Nach einem Neustart bekomme ich nun zur Abwechslung mal ein paar andere Fehlermeldungen.


01.
Fehler beim Lesen von Datei: \\Servername\Softwareinstall\Data1.cab Systemfehler 64. 
02.
 
Die Datei ist aber da. Sie befand sich in dem temporären Setupverzeichnis von Adobe und ist 120MB groß.


Ich habe jetzt mal das Java Paket zu dieser Richtlinie hinzugefügt und bekomme da die Fehlermeldung.

01.
Fehler: Das System kann nicht vom angegebenen Gerät lesen.
Bitte warten ..
Mitglied: Alternativende
07.07.2008 um 18:25 Uhr
Hallo noch mal,
das Problem ist leider immer noch nicht behoben. Wenn ich die Pfade der MSI Dateien manuell verusche zu öffnen bekomme ich bei Java die Fehlermeldung wie oben beschrieben und bei Adobe sagt er lustigerweise das der AdobeReader9 den IE 6 oder höher benötigt (IE 7 ist installiert) .
Danach bricht es ab.
Bitte warten ..
Mitglied: Logan000
10.07.2008 um 14:42 Uhr
Ich hoffe ich habe das richtig verstanden:
Wenn Du als Admin am Client versuchst dein(e) MSI Paket(e) zu starten erhälst du Fehlermeldungen?
Dann liegt das Problem entweder am Paket selbst oder an den Systemvorraussetzungen.
Wobei
bei Adobe sagt er lustigerweise das der AdobeReader9 den IE 6 oder höher benötigt (IE 7 ist installiert)
Natürlich nicht wirklich nachvollziehbar ist.

Gruß L.
Bitte warten ..
Mitglied: Alternativende
10.07.2008 um 17:42 Uhr
Witzig ist das ich gestern genau das gleiche in einer anderen Domäne ausprobiert habe und der Adobe Reader9 und JRE problemlos (!!) beim ersten mal installiert wurden. Alles ohne irgendwelche Macken.

Die Unterschiede der beiden Domänen.

Domäne A ( Softwareverteilungsprobleme, DHCP vom IPCop, WSUS funktioniert )

Domäne B ( Softwareverteilung ok, DHCP vom PDC, WSUS erkennt keine Clients )

Liegt es jetzt also daran, dass ich bei den DHCP und DNS Einstellungen etwas falsches eingestellt habe wodurch bei Domäne B WSUS nicht geht, aber die Softwareverteilung schon ? Oder sind es Einstellungen in der Benutzerpolicy der Domäne A wodurch die Softwareverteilung nicht klappt ? Denn die Benutzerpolicy wirkt auf meinen Testuser.

Bei der Domäne A habe ich auch ein Problem mit dem zentralen Bildschirmhintergrund , wenn ich den TestPc aus der normalen ClientPolicy nehme. bleibt der Hintergrund schwarz. Rechte Maustaste -> Aktualisieren behebt das Problem.

Das Problem besteht auch wenn ich mich als User anmelde.

Probiere heute Abend noch mal was aus und melde mich dann.
Bitte warten ..
Mitglied: Logan000
11.07.2008 um 08:39 Uhr
Moin

Also DHCP (ob und welchen) ist echt egal.
DNS allerdings ist Kriegsentscheidend fürs AD.
Den solltest Du dir mal näher ansehen. Ereignisprotokolle und so.

WSUS erkennt keine Clients
Nur so am Rande: die Clients melden sich beim WSUS.

Gruß L.
Bitte warten ..
Mitglied: Alternativende
23.07.2008 um 13:41 Uhr
Hallo,
kleiner Nachtrag zu der Sache. Es lag am Testclient. Es war eine VM Maschine und damit schien es nicht zu funktionieren. Ich kann nicht 100%ig bestätigen, dass das der Grund war, aber mit anderen neuen Clients funktioniert es tadellos.

Was mache ich nun wegen dem WSUS ?
Wie kann ich dafür sorge tragen, dass die den WSUS finden ?
Bitte warten ..
Mitglied: Logan000
23.07.2008 um 14:25 Uhr
DAs ist nicht zufällig das Gleiche problem wie hier?

Gruß L.
Bitte warten ..
Mitglied: Alternativende
24.07.2008 um 14:16 Uhr
Doch und ich habe es gestern Nachmittag auch noch zufällig gelöst.
Ich habe ein GPO Objekt nur für WSUS erstellt und es über die ganze Domäne verteilen lassen.

Wichtig schien die Einstellung für den internen Pfad zu sein.

http://SERVERNAME:8530

In meinem Fall schien es zwingend GROßGESCHRIEBEN zu werden müssen.

Nun funktioniert es.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
User-ID zu Application Crash

Frage von pablovic zum Thema Windows Server ...

Hyper-V
gelöst Hyper-V gleiche Datenträger-ID bzw. Volume-ID (10)

Frage von Bernd16 zum Thema Hyper-V ...

Windows Systemdateien
gelöst Computer ID nach dem Image zurückspielen ändern (19)

Frage von M.Marz zum Thema Windows Systemdateien ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...