Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ID will sich nicht erhöhen lassen wollen!

Frage Entwicklung PHP

Mitglied: 46356

46356 (Level 2)

30.12.2007, aktualisiert 12:09 Uhr, 4670 Aufrufe, 7 Kommentare

Hallo!

Ich sitz hier schon eine Stunde und löse das Problem einfach nicht!
Wer kann mir hier weiterhelfen?

Die ID wird nicht erhöht!
Es wird immer nur eine 0 ausgegeben und eine 0 in die DB geschrieben!

01.
 
02.
 $abfrage = "SELECT ID FROM GENERALLY LIMIT 1"; 
03.
 $ergebnis = mysql_query($abfrage); 
04.
 while($row = mysql_fetch_object($ergebnis))    
05.
06.
    $ID = "$row->ID"; 
07.
    echo $ID; 
08.
    $new_id = $ID++; 
09.
    echo $new_id; 
10.
  
11.
    $eintrag = "INSERT INTO GENERALLY (ID) VALUES  
12.
    ('$new_id');"; 
13.
    $eintragen = mysql_query($eintrag);  
14.
15.
 
Dieses Script soll die aktuellste ID von der DB ausgeben und anschließend um 1 erhöhen

Vielen Dank für Eure Mithilfe,
Alexander

Edit:

$ID = "$row->ID";
funktioniert sowohl mit Anführungszeichen als auch ohne " nicht!
Mitglied: Dani
30.12.2007 um 00:53 Uhr
Abend Alex,
äh...du wirst doch nicht im ERnst eine Tabelle haben mit einem Spalte (ID) oder? Sowas macht nämlich keinen Sinn! Des Weitern was möchtest du eigentlich damit erreichen? Denn es gibt eigentlich eine Autoinkrementfunktion die dir sowas abnimmt.
Schilder einfach mal, was du machen willst?


Grüße
Dani
Bitte warten ..
Mitglied: 42503
30.12.2007 um 09:53 Uhr
Guten Morgen,

natürlich stimmt das was Dani sagt. Aber wenn du so willst....

$sql = "SELECT ID FROM tabelle ORDER BY id ASC";
$query = mysql_query($sql);
while($row = mysql_fetch_array($query)){
$AktuelleId = $row["id"];
}
$AktuelleId++;
// Hier der Eintrag....

Wenn du es "professionel" machen möchtest setze den Typ von ID wie Dani schon sagt auf Autoinkrement. Danach passiert das erhöhen der ID automatisch.

Beispiel:

Letzer Eintrag in Tabelle:
id name strasse
1 max musterstraße

Nun möchtest du Anette Mustermann noch hinzufügen. Die Query lautet so:

INSERT INTO tabelle (name, strasse) VALUES ('anette','bahnhofstrasse');

Nun sieht die Tabelle (auch wenn keine ID eingiebst ) so aus:
id name strasse
1 max musterstraße
2 anette bahnhofstrasse

Viele Grüße

Gespenst
Bitte warten ..
Mitglied: 46356
30.12.2007 um 10:52 Uhr
Hallo!

Habs mit autoinkrement versucht, hat aber leider nicht geklappt...
In phpmyadmin habe ich die Spalte ID ausgewählt und anschließend
als Extra Autoinkrement hinzugefügt...

4f92f8c3d25c11955b4e50cd580e8eb3-autoinkrement - Klicke auf das Bild, um es zu vergrößern

Leider bekam ich folgende Fehlermeldung:

#1075 - Incorrect table definition; there can be only one auto column and it must be defined as a key


Wer kann mir da weiterhelfen?


Lg. Alex
Bitte warten ..
Mitglied: 42503
30.12.2007 um 11:36 Uhr
Hallo,

hier ein Beispiel Abfrage:

CREATE TABLE IF NOT EXISTS `tabelle` (
`id` int(11) NOT NULL auto_increment,
`name` text collate latin1_german1_ci NOT NULL,
`strasse` text collate latin1_german1_ci NOT NULL,
PRIMARY KEY (`id`)
) ENGINE=MyISAM AUTO_INCREMENT=1;


Viele Grüße
Philipp
Bitte warten ..
Mitglied: masterG
30.12.2007 um 11:38 Uhr
Hast du die Attribute auf UNSIGNED gegeben und ist ID primärschlüssel?!?

masterG
Bitte warten ..
Mitglied: 46356
30.12.2007 um 12:01 Uhr
Hallo!

Hab nun die ID Spalte gelöscht und durch eine neue ausgetauscht ;)

Dort konnte ich alle Einstellungen problemlos vornehmen!

Danke nochmals für den Tip!

Lg. Alex
Bitte warten ..
Mitglied: masterG
30.12.2007 um 12:09 Uhr
Dann Thread gelöst und geschlossen!

masterG(Moderator)
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Update
Bestimmte Server nicht updaten lassen (6)

Frage von WinLiCLI zum Thema Windows Update ...

Linux
Rdesktop Linux Benutzername leer lassen (3)

Frage von opc123 zum Thema Linux ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
gelöst Telefonanlage gesucht (39)

Frage von Xaero1982 zum Thema TK-Netze & Geräte ...

Windows Netzwerk
Anmeldung an Domäne schlägt oft fehlt (Fehlermeldung: falsches Passwort) (24)

Frage von harald.schmidt zum Thema Windows Netzwerk ...

Exchange Server
gelöst Wie freigegebenes Postfach immer als primäre Sendeadresse verwenden? (18)

Frage von Flinxit zum Thema Exchange Server ...

Microsoft Office
Outlook 2016 - Keine Mails sichtbar (nach Suche schon) (17)

Frage von Hirschix3 zum Thema Microsoft Office ...