Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IE, ActiveDirectory und WPAD

Frage Microsoft Windows Netzwerk

Mitglied: Schnick

Schnick (Level 1) - Jetzt verbinden

06.02.2006, aktualisiert 28.01.2008, 7330 Aufrufe, 6 Kommentare

IE-Suche nach WPAD anders als mit den FF.

Hallo,

ich experimentiere gerade mit der automatischen Proxykonfiguration herum und bin da auf einige Eigenheiten gestoßen, die ich mir so nicht wirklich erklären kann.

Ich habe hier eine Testdomain mit einem Win2003-AD-Server, 2 ISA2004-Server und einem XP-Client.
Auf dem Win2003-AD-Server läuft der IIS und DNS. Der WPAD-Eintrag im DNS verweist auf den IIS.

Frage 1:

Wenn ich den WPAD-Eintrag im DNS lösche, dann sucht der XP-Client nach wie vor die wpad.dat auf dem IIS. Das macht aber nur der IE. ping und nslookup auf wpad funktionieren nicht. Woher hat der IE denn die Information, daß auf dem IIS eine wpad.dat-Datei sein soll? Das bleibt auch Wochen später so. Gibt es im AD einen Cache, der sich nicht automatisch leert?

Das gleiche Problem habe ich auch, wenn ich denn wpad-Eintag im DNS änder. Der IE sucht nach wie vor auf dem alten Server die wpad.dat.

Frage 2:

Um dem ganzen etwas auf den Zahn zu fühlen habe ich auf allen Servern den Netzwerkmonitor installiert. Wenn ich im FF eine URL angebe, dann schickt der Client eine Anfrage an den DNS-Server, bekommt die WPAD-Info und geht in's Internet.

Mit dem IE scheint es anders zu laufen. Der IE schickt eine Anfrage an den DNS/AD, der DomainServer sucht dann nach der wpad.dat usw.usw.

So ganz bin ich noch nicht dahinter gekommen. Ich denke, das der IE nicht nach wpad.dat sucht, sondern diese Info vom AD oder vom DNS bekommt.
Wenn ich z.B. auf einem Server 2 Webseiten betreibe mit der gleichen IP, dann sucht das AD/DNS oder IE immer auf der ersten Webseite nach wpad.dat, d.h. Er geht nur nach der IP. Der FF macht das alles korrekt.

Kann mir mal hier bitte irgendeiner erklären, was Microsoft da produziert hat?

Gruß

Viktor
Mitglied: Shakerman
07.02.2006 um 10:00 Uhr
Hallo,

Versuch mal folgendes:

geh auf dem XP Client in die Eingabeaufforderung und gebe dort:

ipconfig /flushdns ein

der Befehl bewirkt dass auf dem Client der Cache von dem DNS geleert wird

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Schnick
08.02.2006 um 09:05 Uhr
Hi,

man kann ja mit ipconfig /displaydns den Cache anschauen. Dort existiert kein wpad-Eintrag. Habe dennoch den Cache geleert mit ipconfig /flushdns. Der Client greift immernoch auf den nicht mehr existierenden wpad-Ort zu. Wie gesagt, das macht nur der IE.

Ich habe einfach das ActiveDirectory in Verdacht. Nur wo kann ich da suchen?

Was Microsoft da produziert hat ist echt ein Graus.

Gruß

Viktor
Bitte warten ..
Mitglied: leipy
27.01.2008 um 19:31 Uhr
Hallo !
auch wenns schon eine Weile her ist - konnte das Problem gelöst werden ?

Ich stehe gerade vor demselben Problem - WPAD mit Firefox funktioniert tadellos, nur der IE mag net. Dabei ist es sogar so, wenn ich dem IE sage, wo er die wpad.dat findet, dann gehts. Nur halt eben mit der Einstellung "automatische Suche der Einstellungen" gehts nicht.

Habe auch in einer Testumgebung ein AD aufgesetzt, Clientanmeldung usw. funktioniert soweit auch alles tadellos. Kein ISA-Server, es wird lediglich die DNS-Variante verwendet.

Was mir noch aufgefallen ist und vielleicht auch ein Hinweis sein könnte, wenn ein Client die wpad.dat per "Ziel speichern unter" herunterlädt, steht im Infofeld des Downloads "unbekannter Typ" drin - obwohl im IIS bei den Mime-Types "application/x-ns-proxy-autoconfig" für ".dat" eingetragen wurde. Die wpad.dat liegt im Verzeichnis "wwwroot".

Hat evtl. noch jmd. einen Tip ?
Danke & Gruss
Stefan
Bitte warten ..
Mitglied: Schnick
28.01.2008 um 14:06 Uhr
Hi Stefan,


ich konnte das Problem nicht lösen. Habe es dann auch erstmal aufgegeben und es jetzt so gelöst, daß er auf eine proxy.pac-Datei zugreift und sich dort weitere Infos zieht.

Was der IE da veranstaltet war für mich einfach nicht nachvollziehbar.

Gruß

Viktor
Bitte warten ..
Mitglied: leipy
28.01.2008 um 18:19 Uhr
Hi Viktor,
danke für die Antwort.

Ganz krass: Habe das ganze heut mal in der Produktiv-Umgebung mit identischen Daten (DNS, Skript welches Netzabhängig den Proxy wählt) installiert - und es hat auch noch funktioniert.
Ist zwar toll, dass es funktioniert, aber für die Fehlersuche bringt das nix, wenn man net weiss, worans lag.

Man muss nicht alles verstehen
Gruss, Stefan
Bitte warten ..
Mitglied: Schnick
28.01.2008 um 18:22 Uhr
Hi Stefan,


das habe ich bei Microsoft schonlange aufgegeben

Gruß

Viktor
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Netzwerk
Android und IE Proxykonfiguration WPAD.dat (4)

Frage von aRanIoN zum Thema Windows Netzwerk ...

DNS
gelöst Kann wpad Eintrag nicht erstellen (3)

Frage von Ex0r2k16 zum Thema DNS ...

Windows Server
gelöst Deaktivieren IE Meldung geschützter Modus (4)

Frage von nano1994 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...