Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IE8 LAN-Einstellungen via Policy

Frage Microsoft Windows Userverwaltung

Mitglied: Andreas-123

Andreas-123 (Level 1) - Jetzt verbinden

01.10.2010, aktualisiert 18.10.2012, 7603 Aufrufe, 12 Kommentare

Hallo Zusammen,

folgendes möchte ich auf einem WinXP SP3 PC mit IE8 realisieren:

Bei allen User die sich neu an einem PC anmelden soll die automatische Suche unter den LAN-Einstellungen des IE-Explorers deaktiviert werden (Internetoptionen > Verbindungen > LAN-Einstellungen > "Automatische Suche der Einstellungen" deaktivieren). Vorerst geht es nur um einen PC.

Ich habe schon versucht über gpedit.msc die Einstellungen anzupassen, habe aber anscheinend nicht den richtigen Punkt gefunden. Auch in der Registry bin ich zwar über einen Key gestolpert, welcher mich aber ebenfalls nicht weitergebracht hat.

Habt ihr eine Idee, wie ich das am besten umsetzen kann?

Vielen Dank im voraus!
Gruß
Andreas
Mitglied: Pjordorf
01.10.2010 um 14:03 Uhr
Hallo,

Zitat von Andreas-123:
Habt ihr eine Idee, wie ich das am besten umsetzen kann?
Schon mal bei Gruppenrichtlinien geschaut?

Peter
Bitte warten ..
Mitglied: Andreas-123
01.10.2010 um 15:36 Uhr
Hallo Pjordorf,

ja, ich habe verschiedene Einstellungen in der Gruppenrichtlinie für Lokale Computer (gpedit.msc) ausprobiert und auch auf der von dir geposteten Seite gesucht. Aber ohne Erfolg bisher.

Gruß
Bitte warten ..
Mitglied: Pjordorf
01.10.2010, aktualisiert 18.10.2012
Hallo andreas,

Zitat von Andreas-123:
ja, ich habe verschiedene Einstellungen in der Gruppenrichtlinie für Lokale Computer (gpedit.msc) ausprobiert und auch auf
der von dir geposteten Seite gesucht. Aber ohne Erfolg bisher.
Naaaaajaaa.

Ich habe mal für dich ein bischen gesucht und auch etwas gefunden. Ist hier und sogar hier im Forum einiges zu finden.

Und hier gibt es nocht mehr.

Peter
Bitte warten ..
Mitglied: Andreas-123
01.10.2010, aktualisiert 18.10.2012
Zitat von Pjordorf:
Hallo andreas,

> Zitat von Andreas-123:
> ja, ich habe verschiedene Einstellungen in der Gruppenrichtlinie für Lokale Computer (gpedit.msc) ausprobiert und auch
auf
> der von dir geposteten Seite gesucht. Aber ohne Erfolg bisher.
Naaaaajaaa.

Ich habe mal für dich ein bischen gesucht und auch etwas gefunden. Ist
hier und sogar [http://www.administrator.de/forum/ie8-%c3%bcbernimmt-keine-proxyeinstellungen-per-gpo-127729.html
hier] im Forum einiges zu finden.

Und hier gibt es nocht mehr.

Peter

Danke, ich werde mir das Ganze nochmal zu Gemüte führen.

Aber noch als Anmerkung: Es geht nicht um die Proxykonfiguration sondern um den Unterpunkt "LAN-Einstellungen"

Gruß
Bitte warten ..
Mitglied: Florian.Sauber
02.10.2010 um 00:13 Uhr
Hallo Andreas!

Dann versuchs ich mal:

Zitat von Andreas-123:
Auch in der Registry bin ich zwar über einen Key gestolpert, welcher mich aber ebenfalls nicht weitergebracht hat.

Wenn Du über den Key "Internet Settings" in HKCU/HKLM und "AutoConfigURL" gestolpert bist, warst Du schon mal auf dem richtigen Weg...
Wenn der fehlt, ist Dein Häkchen weg.

Interessanter für Dich wird aber das DWORD "Autoconfig" in Software\Policies\Microsoft\Internet Explorer\Control Panel (s.a. http://www.pctools.com/guides/registry/detail/537) Mit "Wert"=1 kannst Du für HKCU bzw. HKLM verhindern, dass unter "Automatische Suche der Einstellungen" ein Häkchen gesetzt werden kann. Der ganze Bereich "Automatische Konfiguration" ist dann ausgegraut.

Mit
reg add "HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Control Panel" /v AutoConfig /t REG_DWORD /d 1
bzw.
reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Control Panel" /v AutoConfig /t REG_DWORD /d 1
kannst Du den Schlüssel/DWORD erstellen und mit Wert 1 aktiviern ("Automatische Konfiguration" ist ausgegraut)

Mit
reg add "HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Control Panel" /v AutoConfig /t REG_DWORD /d 0
Kannst Du es dann wieder deaktivieren oder mit
reg delete "HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Control Panel" /v AutoConfig
wieder entfernen. Der zusäztliche Paramter /f würde die Sicherheitsabfrage beim umbenenen/löschen überspringen.

Ich hoffe das war das, was Du suchst...

LG Florian
Bitte warten ..
Mitglied: Andreas-123
04.10.2010 um 09:07 Uhr
Hallo Florian,

der Tipp ist wirklich gut, leider ist damit nur der Dialog ausgegraut, der Haken ist aber standardmäßig noch immer gesetzt, sobald sich ein neuer User anmeldet.

Gruß
Andreas
Bitte warten ..
Mitglied: Andreas-123
04.10.2010 um 10:03 Uhr
Ich habe nun mal mit dem Process Monitor nachverfolgt, was passiert, wenn ich den besagten Haken setze:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections] 
"DefaultConnectionSettings"=hex:46,00,00,00,0b,00,00,00,01,00,00,00,00,00,00,\ 
  00,07,00,00,00,2a,2e,6c,6f,63,61,6c,00,00,00,00,01,00,00,00,14,00,00,00,68,\ 
  74,74,70,3a,2f,2f,77,70,61,64,2f,77,70,61,64,2e,64,61,74,70,4a,62,9f,3e,5b,\ 
  cb,01,00,00,00,00,00,00,00,00,00,00,00,00,01,00,00,00,02,00,00,00,c0,a8,66,\ 
  0c,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00 
"SavedLegacySettings"=hex:46,00,00,00,5c,00,00,00,01,00,00,00,00,00,00,00,07,\ 
  00,00,00,2a,2e,6c,6f,63,61,6c,00,00,00,00,01,00,00,00,14,00,00,00,68,74,74,\ 
  70,3a,2f,2f,77,70,61,64,2f,77,70,61,64,2e,64,61,74,70,4a,62,9f,3e,5b,cb,01,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,01,00,00,00,02,00,00,00,c0,a8,66,0c,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\ 
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
Diese Keys werden geändert. Merkwürdigerweise ist ihr Wert beim Haken deaktivieren wieder ein völlig neuer und nicht der zu erwartende Alte.

Nichtsdestotrotz habe ich versucht diese Keys in HKLM einzutragen. Meldet sich dann ein neuer User an, ist der Haken bei "Automatische Suche" in "LAN-Einstellungen" immernoch gesetzt.

Gruß
Andreas
Bitte warten ..
Mitglied: Florian.Sauber
04.10.2010 um 14:40 Uhr
Hallo Andreas!

Ich habe mal in meiner Db nachgeschaut, wo ich den Tipp damals her hatte. In dem Thread wurde auch die von Dir angesprochene Hexbelegung kurz diskutiert. Habs jetzt nur Überflogen, aber vielleicht hifts Dir weiter. Der Link wäre [zotero://attachment/1455/ hier].

Grüße Florian
Bitte warten ..
Mitglied: Andreas-123
05.10.2010 um 10:22 Uhr
Zitat von Florian.Sauber:
Hallo Andreas!

Ich habe mal in meiner Db nachgeschaut, wo ich den Tipp damals her hatte. In dem Thread wurde auch die von Dir angesprochene
Hexbelegung kurz diskutiert. Habs jetzt nur Überflogen, aber vielleicht hifts Dir weiter. Der Link wäre
[zotero://attachment/1455/ hier].

Grüße Florian

Hallo Florian,
leider kann ich mit dem Link nichts anfangen.
Gruß
Andreas
Bitte warten ..
Mitglied: Florian.Sauber
05.10.2010 um 11:30 Uhr
Sorry Andreas,

da hab ich nicht aufgepasst und meinen lokalen link verwendet,
http://www.visualbasicscript.com/m30518.aspx sollte funktionieren.

LG Florian
Bitte warten ..
Mitglied: Andreas-123
05.10.2010 um 15:47 Uhr
Vielen Dank Florian, das ist auf jeden Fall der richtige Weg:

reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v DefaultConnectionSettings /t REG_BINARY /d 46000000020000000100000000000000070000003c6c6f63616c3e000000000000000000000000000000000000000000000000000000000000000000000000 /f 
 
reg add "HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxySettingsPerUser /t REG_DWORD /d 0 /f 
 
reg add "HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Control Panel\Autoconfig" /v AutoConfig /t REG_DWORD /d 1
Allerdings klappt das nur, wenn ich das als angemeldetetr User ausführe.

Ändere ich die Keys aber für HKLM oder in der ntuser.dat für den Defaultuser, sodass es alle sich neuanmeldenden User betreffen soll, ist der Haken trotzdem noch gesetzt.

Gruß
Bitte warten ..
Mitglied: Andreas-123
12.10.2010 um 09:42 Uhr
Da ich leider bisher nicht weitergekommen bin, habe ich die Diskussion ebenfalls hier gestartet:

http://social.technet.microsoft.com/Forums/de-DE/gruppenrichtliniende/t ...

Gruß
Andreas
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst GPO Audit Policy nur in Default Domain Policy konfigurierbar? (12)

Frage von tombola22 zum Thema Windows Server ...

Windows Userverwaltung
gelöst TeamViewer mit Software Restriction Policy (9)

Frage von geocast zum Thema Windows Userverwaltung ...

Windows Netzwerk
Windows Einstellungen in WIN10 sperren

Frage von Sepi zum Thema Windows Netzwerk ...

Windows Server
Einstellungen einer GPO werden nicht übernommen (12)

Frage von halington zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (15)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...