Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IFMEMBER Domänen-Benutzer

Frage Entwicklung Batch & Shell

Mitglied: tekila

tekila (Level 1) - Jetzt verbinden

04.09.2007, aktualisiert 13:53 Uhr, 10697 Aufrufe, 5 Kommentare

Login Skript funktioniert nicht mit internen Benutzergruppen (Domänen-Admins, -Benutzer etc.)

Hallo!

Ich bekomme es einfach nicht hin: In meinem Login Skript funktioniert die IFMEMBER - Funktion nicht mit integrierten Benutzergruppen wie Domänen-Admins, -Benutzer etc. Mit selbst angelegten Gruppen funktioniert es einwandfrei!
01.
@Echo off 
02.
 
03.
NET TIME \\Server /SET /YES 
04.
 
05.
 
06.
:Mapping 
07.
 
08.
Echo Laufwerke werden verbunden... 
09.
Echo. 
10.
 
11.
:EDV 
12.
 
13.
\\server\NETLOGON\ifmember.exe Domänen-Admins 
14.
if %errorlevel%==1 ( 
15.
 
16.
Echo ### Domänen-Admins ### 
17.
Echo. 
18.
  
19.
NET USE G: /DELETE /YES 
20.
 
21.
NET USE G: \\Server\Allgemein /PERSISTENT:NO 
22.
 
23.
24.
pause
Ich bekomme immer den Wert "0" zurück.

Habe schon alle möglichen Schreibweisen probiert: COMPANY\Domänen-Admins oder "COMPANY\Domänen-Admins". Auch exakt auf Groß und Kleinschreibung geachtet. Nichts zu machen.

Mit "IFMEMBER /list" wird mir jede Gruppe angezeigt, auch die Domänen-Benutzer etc.

Die IFMEMBER.EXE befindet sich wie zu sehen auf dem Server im Netlogon.

Bin über jede Hilfe dankbar!
Mitglied: einwegglas
04.09.2007 um 12:01 Uhr
domänen-admins findet er auch nicht. sonder nur domõnen-admins. probier doch mal danach zu fragen.

An­mer­kung: Der Au­tor hat Pro­ble­me mit den Um­lau­ten äöüß in den Grup­pen­na­men, so z.B. mit Domä­nen-Ad­mins, die sich nicht ve­ri­fi­zie­ren las­sen. (WindowsNT Administrattion)
Bitte warten ..
Mitglied: tekila
04.09.2007 um 13:19 Uhr
Hatte ich noch nicht ausprobiert. Es hilft allerdings auch nicht.

Wenn ich im logon.cmd "Domänen-Admins" schreibe erscheint es in der DOS-Box bei Ausführung als "Dom­õnen-Admins".

Wenn ich im Skript sofort "Domõnen-Admins" schreibe erscheint in der DOS "Dom§nen-Admins" (??).
Bitte warten ..
Mitglied: Dani
04.09.2007 um 13:43 Uhr
Hallo ihr beiden,

@bigbossAUT
Geh hin, mache eine Eingabeaufforderung auf und tippe "edit" ein. Darüber dann das Script öffenen und die ö,ä,ü & ß korrigieren. Das speichern am Ende nicht vergessen. Nun sollte das Script laufen.


Grüße
Dani
Bitte warten ..
Mitglied: tekila
04.09.2007 um 13:51 Uhr
Heureka ;)

Script mit DOS Editor laden und die "ä" noch einmal neu geschrieben (nicht õ!).

Vielen Danke!

Kennt jemand einen guten Windows Editor wo dieser "Fehler" nicht auftritt?
Bitte warten ..
Mitglied: Dani
04.09.2007 um 13:53 Uhr
Kein Problem...schau dir mal Notepad++ an. Dort gibt es ein kl. Plugin für diesen "BUG". *g*
Haben wir hier auch im Einsatz. Sind recht zufrieden damit.


Grüße
Dani
Bitte warten ..
Ähnliche Inhalte
Windows Systemdateien
Benutzer aus der Domäne, Profil wiederherstellen
Frage von Str0mb3rgWindows Systemdateien8 Kommentare

Moin Leute, ja, ich habe *facepalm* ausversehen einen Benutzer gelöscht. Warum, tut nichts zur Sache. Leider haben wir nur ...

Windows Userverwaltung
Softwareinstallation als Domänen Benutzer
gelöst Frage von manuelwWindows Userverwaltung4 Kommentare

Hallo! Ist es möglich einem Active Directory Benutzer die Benutzerrechte so zu geben, damit dieser auch Software installieren darf ...

Exchange Server
Kalenderberechtigung aller Benutzer in einer Domäne zurücksetzen
gelöst Frage von Type02Exchange Server3 Kommentare

Hallo Kollegen, benötige Eure Hilfe! Mitarbeiter im Unternehmen haben Kalenderfreigaben untereinander eigenverantwortlich verwaltet. Nun ist die Mitarbeiterzahl stark gestiegen ...

Microsoft
GPO wird nicht auf Domänen Benutzer angewendet
gelöst Frage von ResolvMicrosoft13 Kommentare

Hallo Leute, eine Frage an die Gruppenrichtlinien Spezialisten hier. Ich sitze seit 2 Stunden und versuche den Fehler zu ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 4 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 4 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 16 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 22 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
Remotesteuerung der Sitzung (Kennung XX) fehlgeschlagen
gelöst Frage von Stefan91Windows Server14 Kommentare

Hallo Zusammen, seit kurzem bekomme ich oben genannte Fehlermeldung, wenn ich versuche eine Remotesitzung über den Taskmanager fernzusteuern (Rechtsklick ...