Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IFMEMBER Domänen-Benutzer

Frage Entwicklung Batch & Shell

Mitglied: tekila

tekila (Level 1) - Jetzt verbinden

04.09.2007, aktualisiert 13:53 Uhr, 10666 Aufrufe, 5 Kommentare

Login Skript funktioniert nicht mit internen Benutzergruppen (Domänen-Admins, -Benutzer etc.)

Hallo!

Ich bekomme es einfach nicht hin: In meinem Login Skript funktioniert die IFMEMBER - Funktion nicht mit integrierten Benutzergruppen wie Domänen-Admins, -Benutzer etc. Mit selbst angelegten Gruppen funktioniert es einwandfrei!
01.
@Echo off 
02.
 
03.
NET TIME \\Server /SET /YES 
04.
 
05.
 
06.
:Mapping 
07.
 
08.
Echo Laufwerke werden verbunden... 
09.
Echo. 
10.
 
11.
:EDV 
12.
 
13.
\\server\NETLOGON\ifmember.exe Domänen-Admins 
14.
if %errorlevel%==1 ( 
15.
 
16.
Echo ### Domänen-Admins ### 
17.
Echo. 
18.
  
19.
NET USE G: /DELETE /YES 
20.
 
21.
NET USE G: \\Server\Allgemein /PERSISTENT:NO 
22.
 
23.
24.
pause
Ich bekomme immer den Wert "0" zurück.

Habe schon alle möglichen Schreibweisen probiert: COMPANY\Domänen-Admins oder "COMPANY\Domänen-Admins". Auch exakt auf Groß und Kleinschreibung geachtet. Nichts zu machen.

Mit "IFMEMBER /list" wird mir jede Gruppe angezeigt, auch die Domänen-Benutzer etc.

Die IFMEMBER.EXE befindet sich wie zu sehen auf dem Server im Netlogon.

Bin über jede Hilfe dankbar!
Mitglied: einwegglas
04.09.2007 um 12:01 Uhr
domänen-admins findet er auch nicht. sonder nur domõnen-admins. probier doch mal danach zu fragen.

An­mer­kung: Der Au­tor hat Pro­ble­me mit den Um­lau­ten äöüß in den Grup­pen­na­men, so z.B. mit Domä­nen-Ad­mins, die sich nicht ve­ri­fi­zie­ren las­sen. (WindowsNT Administrattion)
Bitte warten ..
Mitglied: tekila
04.09.2007 um 13:19 Uhr
Hatte ich noch nicht ausprobiert. Es hilft allerdings auch nicht.

Wenn ich im logon.cmd "Domänen-Admins" schreibe erscheint es in der DOS-Box bei Ausführung als "Dom­õnen-Admins".

Wenn ich im Skript sofort "Domõnen-Admins" schreibe erscheint in der DOS "Dom§nen-Admins" (??).
Bitte warten ..
Mitglied: Dani
04.09.2007 um 13:43 Uhr
Hallo ihr beiden,

@bigbossAUT
Geh hin, mache eine Eingabeaufforderung auf und tippe "edit" ein. Darüber dann das Script öffenen und die ö,ä,ü & ß korrigieren. Das speichern am Ende nicht vergessen. Nun sollte das Script laufen.


Grüße
Dani
Bitte warten ..
Mitglied: tekila
04.09.2007 um 13:51 Uhr
Heureka ;)

Script mit DOS Editor laden und die "ä" noch einmal neu geschrieben (nicht õ!).

Vielen Danke!

Kennt jemand einen guten Windows Editor wo dieser "Fehler" nicht auftritt?
Bitte warten ..
Mitglied: Dani
04.09.2007 um 13:53 Uhr
Kein Problem...schau dir mal Notepad++ an. Dort gibt es ein kl. Plugin für diesen "BUG". *g*
Haben wir hier auch im Einsatz. Sind recht zufrieden damit.


Grüße
Dani
Bitte warten ..
Ähnliche Inhalte
Windows Server
Fehler bei Remote PowerShell mit einem Domänen-Benutzer (4)

Frage von xcabur zum Thema Windows Server ...

Windows Server
Domänen-Benutzer Anmelde-Überwachung (1)

Frage von PseudoNym zum Thema Windows Server ...

Windows Server
gelöst SID vom Benutzer übertragen, hat jedoch keine Rechte in anderen Domäne (8)

Frage von absurt77 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...