Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IIS 6.0 plus PHP 5.2.4 -gleich- Fehler 404?

Frage Internet Server

Mitglied: 53631

53631 (Level 1)

24.09.2007, aktualisiert 25.09.2007, 9822 Aufrufe, 2 Kommentare

Fehler 404 wenn ich eine .php öffnen will.

[Problembeschreibung:]

Wenn ich bei mir auf dem server eine .php datei ausführen willl (über internet und auch local)
bekomme ich vom Browser Fehler 404.

(bei HTML klappt alles und bei ASP auch.

[System]

Windows Server 2003 Web Edition (root Server)
IIS 6.0
PHP 5.2.4

[Installation:]

- .zip von php.net heruntergeladen.
- .zip endpackt.
- PATH Variable editiert, (C:\Programme\PHP; ).
- PHPRC hinzugefügt, (C:\Programme\PHP; ).
- php.ini editiert (extension_path).
- IIS Gestartet Weberweiterungen PHP hinzugefügt (php5isapi.dll)
- phpisapi.reg editiert ("C:\Programme\PHP\php5is api.dll").
- phpisapi.reg hinzugefügt.
- index.php erstellt (<?php php_info(); ?>).
- IIS gestartetm default webpage editiert (dokumente index.php hinzugefügt).
- Verzeichnisse editiert (c:\Programme\PHP, C:\inetpub\wwwroot). Iusr (internetgustaccount) Rechte ändern.

[Erreichen des Problems]

meine Domain aufrufen (index.htm) -> Erfolg
meine Domain aufrufen (index.php) -> Fehler 404

[Frage:]

- Hat einer von euch eine idee woran das liegen kann?
- Hat einer von euch einen Lösungsansatz oder gar "Die Lösung" ?




Mit freundlichen Grüßen,

Euer verzweifelter #Cloud#

[EDIT]


Habe forher bisschen an der configuration gespielt (ISAPI Filter php5isapi.dll hinzugefügt)
und bei der anwendungs ka wie das heißt da wo ich .php hinzufügen kann habe ich php auch noch hinzugefügt.)nach dem verstellen habe ich fehler 500 bekommen.


Habe mal bei IE 7 kurze Fehler meldungen anzeigen abgeschaltet und nun bekomme ich nur noch ne weiße seite...
Mitglied: gi-networx
24.09.2007 um 22:53 Uhr
Hi,

also pauschal fällt mir keine Lösung ein. Aber weil ich das mit dem 500er gelesen habe: Kann es sein das Du die x64-Version von Windows Server hast?
Ich weiß nicht wie die aktuelle Situation ist, aber ich hatte vor ein paar Monaten das selbe Problem (mit dem HTTP 500) weil ich versucht hatte PHP als (32 bit-)ISAPI-Modul auf einem x64-Windows auszuführen. Damals gab es nämlich PHP nicht als ISAPI-Modul für x64 iirc.

Ansonsten könnte ich mir vorstellen, dass Du die NTFS-Rechte evtl. trotzdem noch nicht richtig eingestellt hast.

Gruß, Michl
Bitte warten ..
Mitglied: 53631
25.09.2007 um 16:28 Uhr
1. Ich wollte mich erstmal Herzlich für die Hilfe bedanken.

2. Ich habe die Lösung gefunden ich habe die .php erweiterung über die konsole hinzugefügt nach dem ich jede einstellung 2x durch hatte bin ich drauf gestoßen dass Windows den Pfad misshandelt hat. (C:Pro~1 usw.) als ich das geändert hab und den IIS neugestartet habe klappte es ;) )
Bitte warten ..
Neuester Wissensbeitrag
Microsoft Office

MS Office Excel - Formel wird angezeigt, aber nicht berechneter Wert!

Tipp von holli.zimmi zum Thema Microsoft Office ...

Ähnliche Inhalte
PHP
gelöst PHP erzeugte Datei gleich als Email versenden (4)

Frage von facebraker zum Thema PHP ...

CMS
PHP - WordPress auf Apache schneller als auf IIS? (13)

Frage von Rene1976 zum Thema CMS ...

Microsoft Office
gelöst 3 Excel Dateien, gleich umkodieren? (10)

Frage von Akeipra zum Thema Microsoft Office ...

Windows Server
ARR und IIS in DMZ (2)

Frage von Philipp.S zum Thema Windows Server ...

Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (21)

Frage von Winuser zum Thema Hyper-V ...

Exchange Server
Bestehende eMails autoamatisch weiterleiten (21)

Frage von metal-shot zum Thema Exchange Server ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (16)

Frage von ProfessorZ zum Thema Router & Routing ...