Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IIS 6.0 Service unavailable bei großer Anwendung

Frage Internet Server

Mitglied: ThomasR

ThomasR (Level 1) - Jetzt verbinden

20.03.2008, aktualisiert 25.03.2008, 4981 Aufrufe, 2 Kommentare

asp.net framework 3.5 Windows Server 2003 und IIS 6

Hallo,

da ich neu hier bin, möchte ich mich kurz vorstellen. Ich bin beruflich Softwareentwickler und habe jetzt privat eine Webanwendung als asp.net Anwendung entwicklet. Um diese Anwendung der Welt auch zugänglich zu habe ich einen Windows V-Server mit Windows Server 2003 als Betriebssystem angemietet. Auf dem Server ist außer dem Betriebsystem, dem IIS 6 und einem MS SQL Server Express 2005 und dem .net framework 3.5 von mir nichts installiert worden. Wenn ich einen Teil meiner Anwendung jetzt auf den Server kopiere (also nur eine default.aspx mit entsprechender Code behind Datei, eine web.config, ein paar eingebundene Assemblys und ein paar ccs files) dann funktioniert alles wunderbar. Sobald ich aber die komplette Anwendung (ca 40 Seiten) auf den Server kopiere bekomme ich nur noch ein Service unavailable ausgeliefert.

Wenn ich die Anwendung auf meinem Entwicklungsrechner starte (der deutlich stärker als der Server ist) dann dauert das Starten ca. 10 Sekunden, da zum Starten ja alles compiliert/precompiliert wird. Kann es sein, dass das Service unavailable durch einen Time out vom ISS kommt, weil der es einfach nicht schaft, die komplette Anwendung so schnell zu kompilieren?

Ich wäre für jeden Hinweis was ich tun kann dankbar.

Gruß

ThomasR
Mitglied: ThomasR
22.03.2008 um 08:11 Uhr
Noch ein Nachtrag:

im httperr1.log findet sich nach einem Aufruf der Seite immer folgender Eintrag:

2008-03-22 07:07:04 89.166.229.105 1221 87.230.89.25 80 HTTP/1.1 GET / - 2060276093 Connection_Abandoned_By_AppPool DefaultAppPool
Bitte warten ..
Mitglied: ThomasR
25.03.2008 um 14:10 Uhr
Hallo,

ich kämpfe immer noch mit dem IIS. Ich habe jetzt weil das in einem anderen Service not available Tread empfohlen wurde den IIS einmal deinstalliert und neu installiert. Das hat die ganze Situation auch etwas verändert. Ich bekomme jetzt nicht mehr die Meldung Service not available, sondern nur noch ein "Die Seite kann nicht angezeigt werden". Diese Meldung dafür aber jetzt immer wenn ich eine aspx Seite aufrufe. Nicht nur bei großen Seiten. Einfache html Seiten werden sauber ausgeliefert.

Im error.log steht aber immer noch die selbe Meldung mit connection abanndoned bei app_pool. Falls irgend jemand eine Tipp hat, auch wenn es nur ein Verweis auf ein anderes Forum ist, wäre ich wirklich dankbar.

Gruß

Thomas
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Zugriff auf IIS und Apache Tomcat Anwendung übers Internet (3)

Frage von horstvogel zum Thema Windows Server ...

Windows Server
IIS in Win2012 Server: Web-Anwendung im Unterverzeichnis installieren (1)

Frage von cellardoor zum Thema Windows Server ...

Windows Netzwerk
Konfiguration Linux VM in IIS-Manager (10)

Frage von HansWerner1 zum Thema Windows Netzwerk ...

Netzwerkgrundlagen
gelöst Aufbau mittlerer bis großer Netzwerke (5)

Frage von MasterPhil zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...