Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IIS 8 mit mehreren Domains und SSL Zertifikaten

Frage Sicherheit Verschlüsselung & Zertifikate

Mitglied: m.reeger

m.reeger (Level 2) - Jetzt verbinden

04.08.2013 um 11:10 Uhr, 5523 Aufrufe, 11 Kommentare

Hallo,

ich bins schon wieder...

ich habe einen Windows Server 2012 mit dem IIS als Rolle.

Auf dem IIS sind ca. 40 Websiten (inkl. Subdomains)
Also http://www.domain1.de; http://mysql.domain1.de usw.

Nun habe ich mir bei StartCom SSL 4 Zertifikate ausgestellt.

*.domain1.de
*.domain2.de
*.domain3.de
*.domain4.de

Sitebindung: (Domain1)
Typ: https
IP: 212.224.xxx.xxx
Port: 443
Hostname: domain1.de
SSL Zertifikat: *.domain1.de
SNI Server Name Indication erforderlich: Ja

Sitebindung: (Domain2)
Typ: https
IP: 212.224.xxx.xxx
Port: 443
Hostname: domain2.de
SSL Zertifikat: *.domain2.de
SNI Server Name Indication erforderlich: Ja

Wenn ich jetzt https://domain1.de oder https://mysql.domain1.de aufrufe nimmt er das richtige Zertifikat und alles ist gut.

Nun rufe ich aber https://domain2.de auf und er nimmt das Zertifikat von https://domain1.de
Das gibt dann aber leider eine Fehlermeldung im Browser was nicht sein darf!

Ich bitte um euere Hilfe!




Mitglied: Dani
04.08.2013 um 11:32 Uhr
Moin,
poste doch bitte Screenshots von den relevanten Einstellungen (SSL-Einstellungen, Website-Eigenschaften, etc...)


Grüße,
Dani
Bitte warten ..
Mitglied: m.reeger
04.08.2013, aktualisiert um 11:42 Uhr
Moin,


d8ed36a3c7e7ae1845cf214fd8184be3 - Klicke auf das Bild, um es zu vergrößern
949332c6ae94653b2c655b330500a280 - Klicke auf das Bild, um es zu vergrößern
db1abac64000e6b8eee82ea41c4a9499 - Klicke auf das Bild, um es zu vergrößern
1c71a2ad0612269fdd86de8c64e6beb5 - Klicke auf das Bild, um es zu vergrößern
428cbe552f10ea9015510c831fa35473 - Klicke auf das Bild, um es zu vergrößern
057219eb77eab6ff461bc8523a3b953d - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Dani
04.08.2013 um 11:47 Uhr
Die letzten zwei Screenshots sind aber nicht die SSL-Einstellungen. Diese findest du in der jeweiligen Website.


Grüße,
Dani
Bitte warten ..
Mitglied: m.reeger
04.08.2013 um 11:52 Uhr
Entschuldigung, sind die Einstellungen gemeint?

d4587f1186c65545a201b864232f703c - Klicke auf das Bild, um es zu vergrößern
c866fe1cf47a6c086d87cc3f13dcee6d - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Dani
04.08.2013, aktualisiert um 11:59 Uhr
Bingo. Setz dort den Haken bei "SSL erforderlich". Danach den IIS neustarten und nochmals testen.
mit welchen Betriebssystem und Browser rufst du die Seiten auf? Es gibt dort nämlich Einschränkungen


Grüße,
Dani
Bitte warten ..
Mitglied: m.reeger
04.08.2013, aktualisiert um 12:15 Uhr
Haken gesetzt, läuft leider immernoch nicht....

jetzt das nächste Problem:

da war ne Domain "webmail.reeger.net" mit einem Zertifikat von Positive SSL CA2 diese Domain verwendet jetzt auch auf ein schlag *.reeger.net


Jede meiner Websiten nutzt nun *.reeger.net als Zertifikat.

Clients:
Windows Vista Buisness Firefox 22
Windows 7 Prof Chrome Version 28.0.1500.95 m | Internet Explorer 10
Windows 8 Prof. Chrome Version 28.0.1500.95 m | Internet Explorer 11 | Firefox 22

Ich sehe hier gerade noch eine seltsame Fehlermeldung, vielleicht ist das die Ursache...
91d5fe48647ce30eea30a1671198c43a - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Dani
04.08.2013 um 12:19 Uhr
Es ist eine Warnung, kein Fehler...
welche Domains hast du aufgerufen um zu Testen... 1:1 bitte schreiben.


Grüße,
Dani
Bitte warten ..
Mitglied: m.reeger
04.08.2013 um 12:36 Uhr
https://banana-gaming.net
https://reeger.net
https://t-voltmer.net
https://webmail.reeger.net

Vielleicht wird der Fehler ja durch die Warnung ausgelöst ich weiß es nicht ^^
Bitte warten ..
Mitglied: Dani
04.08.2013 um 12:40 Uhr
Mit Wilcard-Zertifikaten habe ich es noch nie gemacht oder gesehen.
Schau dir folgenden Blogartikel an.


Grüße,
Dani
Bitte warten ..
Mitglied: m.reeger
04.08.2013, aktualisiert um 13:18 Uhr
Ja ich könnte mir auch einfach ein Zertifikat ausstellen ich bin da Class 2 Verified also würde es auch gehen das Zertifikat auf *.reeger.net mit allen DNS Namen einzupflegen, sieht aber etwas komisch aus wenn man auf der Seite "https://banana-gaming.net" ist und dort steht, dass das Zertifikat für *.reeger.net ausgestellt ist. Finde ich nicht sehr Vertrauensvoll ^^

Vielen Danke für deine Hilfe!
Habe hier noch was gefunden...ich probiers gleich mal aus
http://blogs.msdn.com/b/omnia/archive/2012/11/11/how-to-use-sni.aspx

€dit 1
ok es geht auch nicht....
anscheinend bin ich zu doof für SSL oder der IIS spackt rum...

€dit 2.

Ok ich habs hinbekommen....bei einer https war SNI erforderlich nicht angeklickt...aber bei 40 Sub/Domains...verliert man mal den Überblick.


Vielen Vielen Dank!

Schönen Sonntag noch
Ich werd mich jetzt auch erstmal an den See legen ;)
Bitte warten ..
Mitglied: Dani
04.08.2013 um 13:34 Uhr
Ok ich habs hinbekommen....bei einer https war SNI erforderlich nicht angeklickt...aber bei 40 Sub/Domains...verliert man mal den Überblick.
Darum gibt es Powershell.

Hier regnet es schon...

GRüße,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
E-Mail
Mailinglisten mehrerer Domains

Frage von tobilektri zum Thema E-Mail ...

Windows Netzwerk
Konfiguration Linux VM in IIS-Manager (10)

Frage von HansWerner1 zum Thema Windows Netzwerk ...

Windows 10
Open SSL VPN - Usability mit Win10 (8)

Frage von cuilster zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...