Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IIS akzeptiert kein Samba Laufwerke für virtuelles Verzeichnis

Frage Linux Samba

Mitglied: Regenschein

Regenschein (Level 1) - Jetzt verbinden

07.08.2006, aktualisiert 15:17 Uhr, 6947 Aufrufe, 4 Kommentare

Ein als Laufwerk gemountetes Samba Share wird im IIS nicht als Verzeichnis für ein virtuelles Verzeichnis akzeptiert

Guten Tag,

wir haben einen tollen Fileserver, der via Samba ein Share bereitstellt. Darauf wollen wir nun Inhalte packen (statische Seiten und Grafiken), die via IIS ins Internet gestellt werden sollen.

So haben wir ein Startskript für alle User erstellt, so dass der Samba Share automatisch als Laufwerk gemountet wird (net use).
Dies funktioniert auch wunderbar - das Laufwerk ist stets sichtbar.

Wenn wir nun jedoch versuchen, ein darin liegendes Verzeichnis als Pfad für ein virtuelles Verzeichnis auf unserem W2003 Server im IIS einzustellen, wird dieses Verzeichnis nicht akzeptiert. Auch mit dem Durchsuchen-Button kann man zwar das Verzeichnis anwählen, jedoch ist der OK-Button ausgegraut, so dass eine Übernahme nicht möglich ist.

Natürlich haben wir auch versucht, direkt die Netzwerkressource als Pfad anzugeben und uns mit Benutzer und Passwort zu verbinden. Auch dies führt jedoch leider nicht zum Erfolg.

In anderen Foren als auch hier konnte ich keinen Lösungsansatz finden, der uns weitergeholfen hätte.
Daher freue ich mich über möglichst zahlreiche Tipps, was wir noch versuchen könnten.

Viele Grüße
Regenschein
Mitglied: Regenschein
07.08.2006 um 14:48 Uhr
Der Trick ist: Der User, mit dem man sich zum Samba verbindet, muss auch als Benutzer auf Windows angelegt sein. Dann geht's. Verstehe einer das.
Bitte warten ..
Mitglied: buerotiger
07.08.2006 um 15:15 Uhr
Der Trick ist: Der User, mit dem man sich zum
Samba verbindet, muss auch als Benutzer auf
Windows angelegt sein. Dann geht's. Verstehe
einer das.

Ist doch verständlich?!

Wenn jemand fremdes mit seinem Schlüssel ein Auto aufsperrt, kannst du dich zwar reinsetzen, du wirst es ohne den Schlüssel nicht starten können.
Bitte warten ..
Mitglied: Regenschein
07.08.2006 um 15:17 Uhr
Nein. Ich habe doch einen Dialog, mit dem ich Benutzer und Passwort eingeben kann. Wenn ich mich per Telnet/SSH irgendwo einlogge, muss ich ja auch nicht den User lokal anlegen, mit dem ich mich verbinden will. Ferner: Auch ohne User anzulegen kann ich ja das Verzeichnis mounten, nur der IIS verweigert seine Teilnahme. Das finde ich merkwürdig.

Viele Grüße
Regenschein
Bitte warten ..
Mitglied: marsmars
12.04.2010 um 13:56 Uhr
ich denke mal das nicht aktuell ist, aber ich vermute mal, dass iis ein NTFS-verzeichnis haben will...
Wenn noch akut, dann probier doch mal ne netzwerk freigabe unter windows (ntfs-Laufwerk) aus ...
Bitte warten ..
Ähnliche Inhalte
Server
Smartphone kein Wlan, Laptop aber schon!?? (1)

Frage von Sabse91 zum Thema Server ...

Exchange Server
gelöst Exchange 2013 kein Support für Windows Server 2016? (1)

Frage von vBurak zum Thema Exchange Server ...

Samba
Samba 3 - Neuer Logonserver (2)

Frage von schneerunzel zum Thema Samba ...

Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...