Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IIS-HTTP-Server nicht erreichbar

Frage Internet Server

Mitglied: nullplan001

nullplan001 (Level 1) - Jetzt verbinden

08.03.2006, aktualisiert 12.03.2006, 15771 Aufrufe, 13 Kommentare

Hi all,
ich habe mir vor einigen Wochen den IIS besorgt, da ich für gewisse Zwecke einen FTP-Server brauchte. Der HTTP-Server kam gleich mit. Gut, muss ich mir halt keinen Indianer besorgen. Ich habe nun alles nach gutdünken konfiguriert und eine index.html in den Ordner mit dem sinnigen Namen %systemdrive%\httpserv gepackt. Der IIS wurde auch dahingehend konfiguriert. Ich gab dem Zugreifenden sogar alle Rechte, außer schreiben. Nun, Opera meldet sich bei jedem Versuch, die Seite zu besuchen mit "Es ist keine Webseite an dieser Adresse konfiguriert". OK, nächster Test: IE: Seite kann nicht angezeigt werden, wegen HTTP 404 (Datei nicht gefunden). Noch ein Test: telnet: Das gleiche wie Opera. Na gut, wer nicht will... In der Konfig steht übrigens, dass die index.htm eine Startseite ist. Zusammen mit index.asp und index.php. Die Fehlermeldungen stehen alle auf Standard und eine Standardanwendung für den Server läuft auch. Wieso geht das jetzt nicht?
Tschö,
nullplan
P.S.: Ich habe den IIS von der Win2k-Prof-CD, genauso wie mein OS. IP-Adresse steht auf "alle nicht zugeordnet", obwohl ich eine statische IP habe, aber de FTP-Server hat auch nicht funktioniert, als ich die eingestellt hatte.
Mitglied: RSRconnect
08.03.2006 um 20:04 Uhr
Tja, was soll man sagen, da gibts unendlich viele Möglichkeiten.

Grundsätzlich: Warum liegt das HTTP-Verzeichnis in %systemdrive%\httpserv

Die Meldungen besagen eigentlich genau, das der IIS die Seiten nicht finden kann. Und Zugriff auf das Verzeichnis muß nicht der angemeldete Benutzer haben sondern IUSR_Maschinenname!

Wenn vorgenannter keinen Zugriff hat, dann klappts auch nicht mit den Seiten.
Bitte warten ..
Mitglied: Strangemeister
09.03.2006 um 07:50 Uhr
Tach,

du hast geschrieben, Du hast eine index.html erstellt. Versuch zuerst mal, die Datei in index.htm umzubenennen. Könnte u. U. der Grund dafür sein.


Grüße
Bitte warten ..
Mitglied: GeneralGunrider
09.03.2006 um 13:04 Uhr
hmmm
ruft du evtl. die Seite falsch auf?

am besten probrierst dus lokal per http://localhost/ oder http://localhost/index.html
Bitte warten ..
Mitglied: nullplan001
09.03.2006 um 15:49 Uhr
Also am Aufruf liegts nicht. Ich rufe immer localhost auf. Auch wenn schon "Jeder" auf den Ordner den Vollzugriff hatte, ich habe IUSR_%computername% noch extra den Vollzugriff gegeben. Und wieso sollte ich den IIS-Standard-Ordner verwenden? Dort kam übrigens das gleiche Ergebnis. aber ich kann es ja nochmal probieren... Weder IE noch Opera melden einen Fund (Aufruf von http://localhost/localstart.asp nach setzen des Basisverzeichnisses auf %systemdrive%\Inetpub\wwwroot) Tjo, irgendwas geht da nicht. Aber was?
Nach wie vor tschö,
nullplan
Bitte warten ..
Mitglied: RSRconnect
09.03.2006 um 22:46 Uhr
Also "Jeder" bringt sowieso nix für den IIS, kannst Du getrost rausnehmen.

Der IUSR darf um Himmelswillen keinen Vollzugriff haben, für eine HTML-Seite reicht absolut lesen.

Fakt ist, das er Dein Verzeichnis nicht findet. Mach dochmal die MMC vom IIS auf und klicke einfach auf den Standardserver. Wird rechts die index.html angezeigt? wenn nicht, findet er das Basisverzeichnis nicht.

Sind Screenshots möglich? Kannst Du auch gerne mailen.
Bitte warten ..
Mitglied: nullplan001
10.03.2006 um 15:34 Uhr
Hmmm... jetzt wird's interressant: Er zeigt mir aber die index.html an. Ich dachte an einen plötzlichen Sinneswandel des Servers und rief sofort die Seite im Browser auf. "Es ist keine Webseite an dieser Addresse konfiguriert." Ich habe nun einmal geguckt, ob dieser Text vielleicht in der index.html steht, aber dem ist nicht so. Screenshot willst du haben? Sollst du kriegen. Per Mail.
Tschö,
nullplan
P.S.: In Ermangelung einer anderen Adresse schicke ich den Shot an die Info-Adresse auf deiner HP
Bitte warten ..
Mitglied: RSRconnect
10.03.2006 um 19:19 Uhr
Gut, und die ganzen anderen Dateien, die der IIS anzeigt findest Du auch bei Dir im Verzeichnis wieder, ja?

Dann mach mal einen Doppelklick auf die index.html und schau sie Dir an, ist das Deine?
Bitte warten ..
Mitglied: nullplan001
10.03.2006 um 20:34 Uhr
Jup, eindeutig, oder würde Microsoft eine Datei mit dem Text "Gut, scheint zu funktionieren " als Standarddatei benutzen?
Tschö,
nullplan
Bitte warten ..
Mitglied: RSRconnect
10.03.2006 um 23:46 Uhr
Hmm, merkwürdig, was sagt das logfile?
Bitte warten ..
Mitglied: nullplan001
11.03.2006 um 11:00 Uhr
Seltsam, ich finde nur ein Log vom 13.12.05. Steht folgendes drin:
<div class="code">#Software: Microsoft Internet Information Services 5.0
#Version: 1.0
#Date: 2005-12-13 17:28:52
#Fields: time c-ip cs-method cs-uri-stem sc-status
17:28:52 127.0.0.1 GET /iisstart.asp 302
17:28:52 127.0.0.1 GET /localstart.asp 401
17:29:00 127.0.0.1 GET /localstart.asp 200
17:29:00 127.0.0.1 GET /web.gif 200
17:29:00 127.0.0.1 GET /warning.gif 200
17:29:00 127.0.0.1 GET /win2000.gif 200
17:29:00 127.0.0.1 GET /mmc.gif 200
17:29:00 127.0.0.1 GET /help.gif 200
17:29:00 127.0.0.1 GET /print.gif 200
17:29:00 127.0.0.1 GET /favicon.ico 404
17:29:23 127.0.0.1 GET /iishelp/Default.htm 200
17:29:23 127.0.0.1 GET /iishelp/iis/misc/default.asp 200
17:29:23 127.0.0.1 GET /favicon.ico 404
17:29:23 127.0.0.1 GET /iishelp/iis/misc/coflat.htm 200
17:29:23 127.0.0.1 GET /iishelp/iis/misc/navbar.asp 200
17:29:23 127.0.0.1 GET /iishelp/iis/misc/Cont.gif 200
17:29:23 127.0.0.1 GET /iishelp/iis/htm/core/iiwltop.htm 200
17:29:28 127.0.0.1 GET /iishelp/iis/misc/NoIndex.gif 200
17:29:28 127.0.0.1 GET /iishelp/iis/misc/NoSearch.gif 200
17:29:28 127.0.0.1 GET /iishelp/iis/misc/navpad.gif 200
17:29:28 127.0.0.1 GET /iishelp/iis/misc/ismhd.gif 200
17:29:28 127.0.0.1 GET /iishelp/common/cocss.css 200
17:29:28 127.0.0.1 GET /iishelp/common/HHCtrl.class 200
17:29:28 127.0.0.1 GET /iishelp/iis/misc/MS_logo.gif 200
17:29:28 127.0.0.1 GET /iishelp/iis/misc/synch.gif 200
17:29:28 127.0.0.1 GET /iishelp/iis/htm/core/iis_banr.gif 200
17:29:28 127.0.0.1 GET /iishelp/common/TreeView.class 200
17:29:28 127.0.0.1 GET /iishelp/common/IndexPanel.class 200
17:29:28 127.0.0.1 GET /iishelp/common/RelatedDialog.class 200
17:29:28 127.0.0.1 GET /iishelp/common/ElementList.class 200
17:29:28 127.0.0.1 GET /iishelp/common/TreeCanvas.class 200
17:29:29 127.0.0.1 GET /iishelp/common/loc.prp 200
17:29:29 127.0.0.1 GET /iishelp/common/Element.class 200
17:29:36 127.0.0.1 GET /iishelp/common/cntimage.gif 200
17:29:36 127.0.0.1 GET /iishelp/common/SitemapParser.class 200
17:29:36 127.0.0.1 GET /iishelp/iis/misc/cohhc.hhc 200
17:29:45 127.0.0.1 GET /iishelp/iis/htm/core/iiiisin.htm 200
17:30:02 127.0.0.1 GET /iishelp/iis/htm/core/iifeats.htm 200
17:30:02 127.0.0.1 GET /iishelp/iis/htm/core/iinew1.gif 200
17:30:24 127.0.0.1 GET /iishelp/iis/htm/core/iinewtp2.htm 200
17:34:34 127.0.0.1 GET /iishelp/iis/htm/core/iiwebcon.htm 200
17:35:25 127.0.0.1 GET /iishelp/iis/htm/core/iisvadm.htm 200
17:36:07 127.0.0.1 GET /iishelp/iis/htm/adminsamples/iiasabt.htm 200
17:36:55 127.0.0.1 GET /iishelp/iis/htm/adminsamples/adsutil.htm 200
17:37:01 127.0.0.1 GET /iishelp/iis/htm/adminsamples/dispnode.htm 200
17:37:07 127.0.0.1 GET /iishelp/iis/htm/adminsamples/default.htm 200
17:37:29 127.0.0.1 GET /iishelp/iis/htm/core/iiregovr.htm 200
17:37:40 127.0.0.1 GET /iishelp/iis/htm/core/iiregglo.htm 200
17:38:25 127.0.0.1 GET /iishelp/iis/htm/core/iisnapin.htm 200
17:54:02 127.0.0.1 GET /iisstart.asp 302
17:54:02 127.0.0.1 GET /localstart.asp 200
17:54:19 127.0.0.1 GET /iishelp/iis/misc/default.asp 200
17:54:19 127.0.0.1 GET /iishelp/iis/misc/navbar.asp 200
17:54:19 127.0.0.1 GET /iishelp/iis/htm/core/iiwltop.htm 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/coflat.htm 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/navpad.gif 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/ismhd.gif 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/MS_logo.gif 304
17:54:19 127.0.0.1 GET /favicon.ico 404
17:54:19 127.0.0.1 GET /iishelp/iis/misc/Cont.gif 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/NoIndex.gif 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/NoSearch.gif 304
17:54:19 127.0.0.1 GET /iishelp/common/cocss.css 304
17:54:19 127.0.0.1 GET /iishelp/iis/htm/core/iis_banr.gif 304
17:54:19 127.0.0.1 GET /iishelp/iis/misc/synch.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/coflat.htm 304
17:54:30 127.0.0.1 GET /iishelp/iis/htm/core/iiwltop.htm 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/Cont.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/default.asp 200
17:54:30 127.0.0.1 GET /favicon.ico 404
17:54:30 127.0.0.1 GET /iishelp/iis/misc/navbar.asp 200
17:54:30 127.0.0.1 GET /iishelp/iis/misc/NoSearch.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/NoIndex.gif 304
17:54:30 127.0.0.1 GET /iishelp/common/cocss.css 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/ismhd.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/MS_logo.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/navpad.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/htm/core/iis_banr.gif 304
17:54:30 127.0.0.1 GET /iishelp/iis/misc/synch.gif 304</div>
Ich entsinne mich auch, das der Server mal funktioniert hat. Dann habe ich den FTP-Server konfiguriert und seitdem geht es nicht mehr. Es sind aber auch noch eine Menge anderer Dinge auf dem Rechner seit dem letzten Aufruf geschehen. Z.B. habe ich Cygwin, vim, MikTeX, u.v.a. installiert. Auch, was vielleicht am wichtigsten ist, die Debugging Tools for Windows. Ich habe keine Ahnung, in wieweit sich ein Symbol-Repositorium auf den IIS auswirkt. Im Log steht jedenfalls, soweit ich das entnehmen kann, nur, dass alles funktioniert. Was nicht der Fall ist. Im FTP-Log steht auch nichts schlimmes. Und jetzt wird's ganz interessant: Der ganze IIS leugnet, dass jemand seit dem 8.3.06 auf den Server zugreifen wollte. Opera leugnet die Existenz der Datei index.html und der IE leugnet die Existenz des Servers. Mal den HTTP-Server runterschmeißen und nochmal neu drauf machen?
Bitte warten ..
Mitglied: RSRconnect
11.03.2006 um 19:51 Uhr
Das ist auch das Logfile, das in den Eigenschaften des Web konfiguriert wurde? Wenn ja hast Du aber ein grösseres Konfigurationsproblem.

Schau nochmal nach, ob es wirklich das richtige Log ist. Wenn ja, nochmal neu installieren. Und dann leg ein neues Web an und halte das Stammweb an.
Bitte warten ..
Mitglied: nullplan001
11.03.2006 um 22:03 Uhr
Also gut, runtergeschmissen ist. Aber nur SMTP- und HTTP-Server. Der FTP-Server hat ja nichts verbrochen. Und den SMTP-Server hab ich nie genutzt. Ok, jetzt wieder draufmachen... Neustart-Blabla. Ich melde mich, wenn der Rechner wieder hochgefahren ist.
Tschö,
nullplan
Nachtrag: *gelöst lächel* et jeht. Naja, fast. Jetzt will er Nutzername und Kennwort von mir. Na, dem werde ich mal die anonyme Anmeldung beibringen. Und dass der Server in echt geht, habe ich festgestellt, indem ich http://localhost/iishelp aufgerufen habe. Und das ging.
Na toll, so ein ewig langer Thread und dann als Lösung die Holzhammer-Methode. Tja, manchmal sind es eben die einfachen Dinge, die uns nicht sofort einfallen. Ich danke allen Beteiligten. DAAAAAAAAANKEEEEEEE.
Bitte warten ..
Mitglied: RSRconnect
12.03.2006 um 08:04 Uhr
Na, dann viel Spaß mit dem IIS und denk an den IUSR.....
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkprotokolle
gelöst Site 2 Site VPN - Server erreichbar, Webseite nicht (5)

Frage von 1410640014 zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
gelöst Website vom IIS nach außen erreichbar machen (2)

Frage von dkgk91 zum Thema Netzwerkgrundlagen ...

Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

Windows Server
Server 2008R2 IIS Zertifikatsproblem

Frage von Alchemy zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...