Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IIS (und ISAPI-Rewrite) erzeugt(en) beim 1. Aufruf eines PHP-Scripts weiße Seite

Frage Internet Server

Mitglied: shrimps

shrimps (Level 1) - Jetzt verbinden

22.06.2009, aktualisiert 20:14 Uhr, 4309 Aufrufe, 1 Kommentar

Entwickler ist am Verzweifeln wegen weißer Seite beim 1. Aufruf!

Hallo Administratoren,

Ich weiß nicht mehr weiter und hoffe, dass ich mich an Euch wenden darf.

Es geht um einen IIS6 mit ca. 30 WebSeiten, die teilweise die kostenlose ISAPI REWRITE von Helicon nutzen.

Bei einer WebSite hab ich folg. Phänomen: Man ruft die "index2.php" auf und erhält eine weiße Seite. Drückt man F5 oder STRG+R erscheint der eigentliche, richtige Content...

Die weiße Seite bringt folg. Output:
<!DOCTYPE HTML PUBLIC " -W3CDTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>

Die Tags mit diesen Inhalten verwende ich zu keiner Zeit in meiner PHP-Datei. Als Charecter-Encoding verwende ich iso-8859-1, was nach einem Refresh auch korrekt ausgegeben wird.

Wenn ich mir nun die IIS-Stats anzeigen lassen, sehe ich den Aufruf der index2.php, allerdings mit nur 375 Bytes Inhalt:
2009-06-22 14:11:25 GET /index2.php - - 8X.148.X4.249 HTTP/1.1 Mozilla/4.0 - 200 375

Nach dem Refresh sieht das Log korrekt so aus:
2009-06-22 14:35:41 GET /index2.php - - 8X.148.X4.249 HTTP/1.1 Mozilla/4.0 - 200 59445

Ich bin mir nicht sicher, ob die ISAPI von Helicon dazwischen funkt, aber für die index2.php existiert kein Eintrag in der .ini.

Eine phpinfo()-Ausgabe testweise in der index2.php funktioniert auch erst beim 2. Seitenaufruf. Ich dachte schon erst an Cookies oder Sessions, aber das kann ich inzwischen (hoffentlich) ausschließen

Ich bin langsam am Verzweifeln. Phänomen. Ich würde mich freuen, wenn ein andere Admin vielleicht einen Ansatz hat, wo ich am Besten suchen soll oder was ich versuchen soll auszuschließen?

MfG
shrimps
Mitglied: shrimps
30.09.2010 um 07:18 Uhr
Das einzige was hier geholfen hat war das erneute Aufsetzen des IIS mit anschließender neuinstallation von Exchange, Sharepoint, etc...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
CMS
PHP - WordPress auf Apache schneller als auf IIS? (13)

Frage von Rene1976 zum Thema CMS ...

PHP
PHP PDO Problem (1)

Frage von Tiggr1994 zum Thema PHP ...

Ubuntu
Cron spamt root mit mails zu (php sessionclean) (4)

Frage von tommy1735 zum Thema Ubuntu ...

Windows Server
IIS https binding mag nicht (11)

Frage von H41mSh1C0R zum Thema Windows Server ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (18)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (16)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...