Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IIS7 - Wie konfiguriere ich eine Website, so dass Fehlermeldungen im Browser ausgegeben werden?

Frage Internet Server

Mitglied: diwaffm

diwaffm (Level 2) - Jetzt verbinden

18.08.2010 um 18:43 Uhr, 3632 Aufrufe, 2 Kommentare

Hi Leute,

Ich bin gerade dabei eine Website von einem IIS 5 auf einen IIS 7 zu verschieben.
Nach der Transfer der Daten treten nun einige Fehler in den (ASP-) Skripten auf - doch leider wird im Browser nur "500 - interner Serverfehler" angezeigt.

Beim alten Server wurde der Name des Skripts, der Fehler und die Position an der der Fehler auftritt angezeigt.
Gibt es einen Schalter in der Konfiguration des IIS 7, mit dem man dieses Verhalten wieder aktivieren kann? Ich sehe den Grund für die eingeschränkte Fehlermeldung und würde diese auch nach erfolgreichter Migration wieder aktivieren.

Doch immer in der Ereignissanzeige nach den Fehler suchen zu müssen ist nicht wirklich bequem - zumal ich über 2 RDC-Verbindungen mit dem Server verbunden bin...

ciao

dirk
Mitglied: filippg
18.08.2010 um 21:04 Uhr
Hallo,

eine Internetsuche nach "asp debugging iis7" sollte dir weiterhelfen.

Gruß

Filipp
Bitte warten ..
Mitglied: diwaffm
18.08.2010 um 22:48 Uhr
Leider nicht - bzw. nicht mit Erfolg.

Im Moment habe ich folgende Settings:

appAllowClientDebug = False
scriptErrorSentToBrowser = True
errorsToNTLog = True (und ausgegraut)
logErrorRequest = True (und ausgegraut)
appAllowDebugging = False
calcLineNumber = True

Ich habe es auch schon mit appAllowClientDebug = True probiert - aber leider ohne positives Ergebnis.
Ich vermute, es liegt am aktivierten errorsToNTLog... Und da komme ich nicht ran...

Auch wenn ich auf der Serverroot errorToNTLog auf FALSE setze, kann ich es für die Website nicht ändern.

Ciao

dirk
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Instant Messaging
Krypto-Messenger Threema jetzt im Web-Browser nutzbar

Link von magicteddy zum Thema Instant Messaging ...

Webbrowser
Surfsperre beim browser (6)

Frage von jensgebken zum Thema Webbrowser ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (20)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (16)

Frage von smartino zum Thema Mac OS X ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...