Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Image.dd nach sda oder sda1 zurücksichern.

Frage Linux

Mitglied: TorstenE

TorstenE (Level 1) - Jetzt verbinden

22.06.2011 um 08:04 Uhr, 6769 Aufrufe, 14 Kommentare

Wie erkenne ich, was es für eine Image-Datei ist, bzw. wohin diese gehört ?

Ich habe eine Image-Datei, welche mit dd erstellt wurde.
Wie muss diese Image-Datei zurückgespielt werden

1.
dd if=image.dd of=/dev/sda

2.
dd if=image.dd of=/dev/sda1


Torsten
Mitglied: micneu
22.06.2011 um 08:10 Uhr
mounte doch dein image und schaue nach was drinn ist.
mount -o loop ~/loop_image.img /media/loop_mount
danach kannst du es in die richtige partition zurückspielen.

gruß michael
Bitte warten ..
Mitglied: ullic
22.06.2011 um 08:13 Uhr
sda ist die gesamte Festplatte, sda1 ist die erste Partition auf der Festplatte. Wenn dein inFile für das Image die gesamte Platte war, musst du nach sda zurückkopieren...

Tschüss

- Ulli -
Bitte warten ..
Mitglied: TorstenE
22.06.2011 um 09:11 Uhr
Zitat von micneu:
mounte doch dein image und schaue nach was drinn ist.
> mount -o loop ~/loop_image.img /media/loop_mount
danach kannst du es in die richtige partition zurückspielen.

gruß michael

Hey Michael, ich muss den Dateisystem Typ angeben?
-t ext2 und -t ext3 funktionieren aber nicht

Als Info dazu die image.dd liegt noch auf eine widows freigabe. diese habe ich mir mit

mount -t cifs -o=windowsuser //192.168.20.1/Freigabe /mnt/meinmount

und jetzt

mount /mnt/meinmount/image.dd /media/loop_mount -o loop

mount /mnt/meinmount/image.dd /media/loop_mount -o loop -t ext3 (klappt nicht)
mount /mnt/meinmount/image.dd /media/loop_mount -o loop -t ext2 (klappt auch nicht)

Torsten
Bitte warten ..
Mitglied: TorstenE
22.06.2011 um 09:24 Uhr
Hey Ulli,

ja das dachte ich mir auch, aber ich weis ja nicht was in der image.dd drin ist
Bitte warten ..
Mitglied: 68162
22.06.2011 um 12:40 Uhr
Wenn Du sie mit dem von 'micneu' angegebenen LOOP-Mount-Befehl nicht einbinden kannst, heisst das i.A., das es die gesamte Platte ist.
Denn die Info über das Dateisystem beginnt (wieder im Allgemeinen) bei Sektor 63 (Offset 32256). Mit:

mount -o loop,offset=32256 ~/loop_image.img /media/loop_mount

lässt sich das vielleicht auch mounten.

Das mounten ist aber nicht nötig, wenn Du die gesamte Platte als Ziel des 'dd'-Befehls angibst.

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Florian.Sauber
22.06.2011 um 12:45 Uhr
tach,

dann schau Dir doch die ersten Bytes des Image mit einem Hexeditor an und vergleichst die Inahlte mit potentiellen Inhalten eines MBR/Partitionstabelle. Denn wenn ein MBR vorhanden ist, wird wohl KEINE Partition gesichert worden sein.

Insspezielle kann Dich bei einer ersten Untersuchung Offset 01FE interessieren. Hier ist im MBR bei den allermeisten Systemen die "Magicnumber" 55AA.

Also mal mit
01.
hexdump -C -s 510 DEINEIMAGEDATEI
versuchen....

Grüsse Florian
Bitte warten ..
Mitglied: TorstenE
22.06.2011 um 13:07 Uhr
Zitat von 68162:
mount -o loop,offset=32256 ~/loop_image.img /media/loop_mount

klappt, jetzt sehe ich unter /media/loop_mount vermutlich die Partition ?
ich kann durch die Verzeichisse /root , /usr, usw. blättern.

Wenn ich das jetzt richtig verstehe, bedeutet es, dass in der image.dd die komplette Platte sein muss.

Wenn ich diese jetzt mit dd if=image.dd /dev/sda zurücksichere, ist dann der MBR ebenfalls mit dabei
oder ist der "aussen vor" ?
Bitte warten ..
Mitglied: Florian.Sauber
22.06.2011 um 13:24 Uhr
Tag nochmal,

Wenn ich das jetzt richtig verstehe, bedeutet es, dass in der image.dd die komplette Platte sein muss.
Verstehst Du richtig!
Wenn ich diese jetzt mit dd if=image.dd /dev/sda zurücksichere, ist dann der MBR ebenfalls mit dabei
oder ist der "aussen vor" ?
Der ist dann auch mit dabei. Das waren ja genau die 63 Sektoren (oder 63*512Byte=32256Byte), die Du bei mount offset "ausgeklammert" hast.

Grüsse Florian
Bitte warten ..
Mitglied: TorstenE
22.06.2011 um 14:09 Uhr
Jetzt habe ich mal folgendes gemacht:

dd if=/image.dd of=/dev/sda &
[1] 8512

mit kill -USER1 8512

nachdem ca. ca. 1 GB kopiert waren

mount /medi/loop_mount /dev/sda -o offset=32256

mit mc habe ich dann nachgsehen. Es sind ein paar Verzeichniss vorhanden, aber nicht viele.
Als ich bei ca. 2 GB nachgesehen habe, hat sich noch nichts verändert. D.h. weder mehr
Verzeichnisse noch sonst etwas.

Da die ganze Datei 325 GB gross ist, würde ich schon vor dem Ende erfahren ob es klappt,
sonst warte ich mir hier "einen Wolf" (ca. 30 Stunden) bis alles kopiert ist und das ganze
dann für "die Katz" war.

In der image.dd ist ein "Ubuntu 8.10" Server mit Alfresco. Bei 2 GB dürfte doch schon ein grosser
Teil des Betriebssystemes drüben sein, oder ?
Wenn ich nebenbei mit "GParted" mir die Partitionen von /dev/sda anzeigen lasse, sehe ich nur
"Partition nicht zugeteilt" - Dateisystem nicht zugeteilt" - Größe 500 GIB (das ist die physikalische Grösse der Platte).
Oder sehe ich das erst nach dem kopieren, wenn der Rechner neu gebootet wurde ?
Bitte warten ..
Mitglied: 68162
22.06.2011 um 16:42 Uhr
Was an welcher Stelle im Dateisystem steht, ist leider schwer zu sagen. War es denn nur eine Partition?

Entweder die 30 Stunden warten, oder DOCH mounten und drauf kopieren. Dann allerdings Bootloader reparieren und '/etc/fstab' anpassen.

Neu booten wird nicht nötig sein, aber "GParted" wird schon merken, wenn ein Dateisystem unvollständig/inkonsistent ist. (Was bei teilweisem Schreiben mit 'dd' der Fall sein dürfte.)

Mit freundlichen Grüßen, FM_81
Bitte warten ..
Mitglied: TorstenE
23.06.2011 um 09:22 Uhr
Also Kopiervorgang ist fertig.

"GParted" zeigt "Partition nicht zugeteilt" und "Dateisystem icht zugeteilt" an.

Wenn ich die Platte aber mounte

mount /dev/sda /mnt/test -o offset=32256

und mir dann alles per "mc" ansehe, sieht alles wie gewünscht aus.

Wie komme ich jetzt noch dazu, dass die ganze Sache läuft, bzw. das System von der Platte
natürlich auch bootet.

Testdisk zeigt mir an "Partition sector doesn't have the endmark 0xAA55" ?????
Die Partitionstabelle wurde mit "Testdisk" neu geschrieben, jetzt zeigt "GParted"
auch die Partition korrekt an.

Beim booten von der Platte sehe ich jetzt nur noch

1234F:

Taste 1,2,3,4 bringt nix


Torsten
Bitte warten ..
Mitglied: TheJoker2305
23.06.2011 um 13:03 Uhr
Ich würde die Image Datei mounten, die enthaltenen Daten auf eine separate Platte kopieren (rsync), dann noch den MB neu schreiben und dann sollte es klappen.

Sofern bei der zusammenfassung von Rsync (option -v) kein Unterschied bei der Anzeige vorhandene Daten und kopierte Daten zu sehen ist.

Mirco
Bitte warten ..
Mitglied: TorstenE
23.06.2011 um 13:38 Uhr
Zitat von TheJoker2305:
Ich würde die Image Datei mounten, die enthaltenen Daten auf eine separate Platte kopieren (rsync), dann noch den MB neu
schreiben und dann sollte es klappen.

Sofern bei der zusammenfassung von Rsync (option -v) kein Unterschied bei der Anzeige vorhandene Daten und kopierte Daten zu sehen
ist.

Mirco

Hey Micro,

im Prinzip habe ich doch jetzt die gleiche Situation.
Daten sind auf der Platte drauf, sehe ich ja mit

mount /dev/sda /mnt/meinmount -o offset=32256

danach kann ich mir mit "mc" alles ansehen.

"GParted" zeigt mir die Partition an, auch als boot

Mit "blkid" hab ich nachgesehen, ob die UUID der Partition /dev/sda1 auch dem Eintrag in der fstab entspricht.
Auch das passt.

Ich tippe es ist nur eine Winzigkeit, wo der Fehler noch liegt, damit alles wieder läuft

Torsten
Bitte warten ..
Mitglied: TorstenE
24.06.2011 um 10:30 Uhr
Die Lösung war SuperGrup für den MBR

Der MBR von "Testdisk" hat nicht funktioniert. Dann habe ich es mit "Super Grub"
versucht und auf Anhieb hat es geklappt.

Somit allen ein Dank für die Hilfe und Tipps

Torsten
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Ubuntu
gelöst Plötzlich sehr kleines Image mit dd (5)

Frage von traller zum Thema Ubuntu ...

Virtualisierung
VHD Image import VirtualBox (10)

Frage von oGutIT zum Thema Virtualisierung ...

Batch & Shell
gelöst Appx aus Image auslesen und entfernen (9)

Frage von Markus2016 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (19)

Frage von patz223 zum Thema Windows Userverwaltung ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (15)

Link von Penny.Cilin zum Thema Viren und Trojaner ...