Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ImageMagick installieren auf Windows Server 2008, Plesk9 für Typo3

Frage Microsoft Windows Server

Mitglied: 50tausend

50tausend (Level 1) - Jetzt verbinden

20.04.2009, aktualisiert 11:36 Uhr, 8695 Aufrufe

Zugriff auf die ImageMagick-Installation ist nicht möglich.

Hallo an alle; ich bin am verzweifeln weil weder ImageMagick noch GraphicsMagic in irgendeiner Art ans laufen zu bringen sind.
Hier meine bestehende Server Konfiguration:

          • Windows Server 2008
          • PHP 5.2.6 als ISAPI-Erweiterung
          • IIS 7
          • Mietserver bei Strato SW-5 aktuelles Image von letzter Woche
          • Plesk 9.0

Ich glaube ich kenne nun so ziemlich jeden Thread, habe alles mögliche getestet und der Fehler ist immer der selbe:
im Typo3-Install-Tool erhalte ich die Fehlermeldung: 'It seems that there is no adequate ImageMagick Installation available....'
In der Image Processing erhalte ich den Heinweis, das IM disabled wäre, obwohl IM=1 in der Konfiguration steht

Meine jetzige Konfiguration ist identisch mit der in dem ersten Post enthaltenen Konfiguration: http://www.typo3forum.net/forum/atta...inden-typo.pdf

Vom Gefühl her habe ich bereits jede verfügbare Version von IM und GM installiert und getestet...
Folgende Beiträge habe ich gefunden und getest:
http://www.typo3forum.net/forum/104841-post18.html (ImageMagick / GraphicsMagick nicht gefunden)
http://www.typo3forum.net/forum/faq-...erweigert.html (ImageMagick (IM) ist installiert, das Typo3 Install Tool jedoch verweigert)
s9y: Enable Imagemagick under Windows with IIS (Installation) • Serendipity PHP Blog
ImageMagick Typo3 IUSR_ Problem - Parallels Forums

Ist IM nicht unter 2008 mit IIS7 lauffähig? Kann das jemand bestätigen?

Ich werde jetzt mal exakt das Beschreiben was ich hier gemacht habe
- nach der Deinstallation aller bisherigen IM und GM-Versionen gibts einen Neustart
- von imagemagick.org lade und installiere ich ImageMagick-6.5.1-3Q16-windows-x64-static.exe und danach Neustart
- Installationsverzeichnis ist c:\im
- die Path-Variable wurde bei der Installation hinzugefügt

Rechte des IM-Verzeichnisses:
Verweigern - psaadm - Vollzugriff - geerbt von C: - diesen Ordner, Unterordner und Dateien
Verweigern - psacln - Vollzugriff - geerbt von C: - diesen Ordner, Unterordner und Dateien
Zulassen - Administrators - Vollzugriff - geerbt von C: - diesen Ordner, Unterordner und Dateien
Zulassen - SYSTEM - Vollzugriff - geerbt von C: - diesen Ordner, Unterordner und Dateien
Zulassen - ERSTELLER-BESITZER - Speziell (Vollzugriff) - geerbt von C: - nur Unterordner und Dateien
Zulassen - Users - Speziell (ähnlich Ändern) - geerbt von C: - Diesen Ordner, Unterordner
Zulassen - Users - Speziell (ähnlich Lesen) - geerbt von C: - Nur Dateien

Somit hat unter dem Reiter 'effektive Berechtigung' der IUSR keine Berechtigung!

Ich habe dann die Vererbung aufgehoben und dem IUSR und der Gruppe Jeder für das Verzeichnis C:\IM den Vollzugriff gegeben.
Bei Typo3 gibt es keine Veränderung. Der ProzessMonitor zeigt keinen Zugriff auf das Verzeichnis! Es gibt tonnenweise Zugriffe auf D:\InetPub und dessen Unterverzeichnisse, zuvor noch ein paar auf web.config, isapi und Plesk, des Weiteren Zugriffe auf die Registry sowie erfolglose auf C:\ , C:\php und C:\apache. Ok, letzteres lassen wir mal außen vor.
Als letzten Transfer gibt es noch ein paar TCP-Daten zur Datenbank über den Port 3306

Mit dem ProcessMonitor habe ich die Zugriffe überprüft. Es gibt keinen Zugriff auf C:\IM

Da stimmt doch was nicht!?!?


Ich hoffe, dass jemand einen Rat hat!!! DANKE IM VORAUS!!!
Ähnliche Inhalte
Windows Server
Anbindung SSO über Typo3 an Windows Server 2008R2 (8)

Frage von Coreknabe zum Thema Windows Server ...

CMS
gelöst Menütitel in Typo3 zu lang (3)

Frage von honeybee zum Thema CMS ...

Windows Server
gelöst Windows Server 2016 - Windows Search installieren oder nicht? (6)

Frage von jojo0411 zum Thema Windows Server ...

Neue Wissensbeiträge
Entwicklung

Exploit Development

Anleitung von burhanudinn123 zum Thema Entwicklung ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(1)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (14)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...