Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Import-module ActiveDirectory funktioniert unter Win8.1 nicht

Frage Microsoft Windows Tools

Mitglied: Messerjocke

Messerjocke (Level 1) - Jetzt verbinden

25.03.2014, aktualisiert 26.03.2014, 2016 Aufrufe, 3 Kommentare, 1 Danke

Hallo da draußen,

ich habe vor einiger Zeit zu Win7 Zeiten ein schönes Powershellskript geschrieben, mit dem ich Exchange2010-Benutzer anlege und im weiteren Verlauf auf die eigenen Bedürfnisse verbiege.
Zum Verbiegen nutze ich verschiedene Kommandos aus der ActiveDirectory Powershell, die ich mit import-module in die Exchange Verwaltungsshell importiere.
Seit dem Umstieg auf Win8.1 und dessen RSATools harmoniert das nun aber nicht mehr mit der Exchange Management Shell 2010.

Soweit ich das nun herausgefunden habe ergeben sich folgende Fakten / Probleme unter Windows 8.1:

- Die Exchange Powershell (EMS) läuft in der Version 2.0, die ActiveDirectory Powershell mit den RSAT Tools in Version 4.0
- Ein Start der EMS in Version 3.0 oder 4.0 verursacht einen Fehler, sodass die Exchange 2010 Kommandos nicht genutzt werden können und die Powershell stürzt ab
- Ein Start der EMS in Version 1.0 oder 2.0 funktioniert für Exchange Kommandos, aber ein Import-Module activedirectory schmeißt Fehler
(Import-Module : The 'C:\Windows\system32\WindowsPowerShell\v1.0\Modules\activedirectory\activedirectory.psd1' module ca
nnot be imported because its manifest contains one or more members that are not valid. The valid manifest members are (...). Remove t
he members that are not valid ('HelpInfoUri'), then try to import the module again.

Import-Module <<<< activedirectory

+ CategoryInfo : InvalidData: (C:\Windows\syst...edirectory.psd1:String) [Import-Module], InvalidOperationException) )

Hat jemand spontan eine Idee, wie man das harmoniert bekommt? Braucht ihr noch mehr Infos?

Gruß
Messerjocke
Mitglied: certifiedit.net
25.03.2014, aktualisiert um 17:27 Uhr
Hallo,

und wie ist der Code des Skriptes? Möchtest du Antworten oder nur "Glaskugel" Blicke?
Bitte warten ..
Mitglied: colinardo
LÖSUNG 25.03.2014, aktualisiert 26.03.2014
Hallo Messerjocke,
also ich habe es hier mit einem Windows 8.1 Enterprise Client und einem Server 2008R2 mit installiertem Exchange 2010 aktuellsten RSAT-Tools und Powershell 4.0 auf dem Client erfolgreich ohne Fehler getestet. Kann deinen erwähnten Fehler hier nicht provozieren.
Zum Herstellen der Verbindung zum Exchange nutze ich folgenden Code auf dem Client in einer Powershell mit Admin-Rechten für den Exchange-Remotezugriff:
01.
$session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri "http://serverXYZ.domain.local/powershell" -Authentication Kerberos 
02.
import-pssession $session
Ein extra Import der AD-CMDLets ist bei mir nicht nötig, die werden hier automatisch mitgeladen.

Grüße Uwe
Bitte warten ..
Mitglied: Messerjocke
26.03.2014 um 09:16 Uhr
Hallo Uwe,
dein Vorschlag war zielführend!

Zur Info für andere Lesende, bisher hatte ich das Skript mit einer .cmd so aufgerufen:
01.
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -noexit -command ". 'C:\Program Files\Microsoft\Exchange Server\V14\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto;. '[Pfad]\Benutzeranlage.ps1'"
und im Powershellskript
01.
Import-Module activedirectory;
Mit Uwes Vorschlag wird es zwar kein reines EMS Fenster sondern bleibt ein natives Powershellfenster, aber es funktioniert.
Nun sieht es so aus:
01.
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -noexit -command "$session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri "http://FQDN/powershell" -Authentication Kerberos; import-pssession $session;. '[Pfad]\Benutzeranlage.ps1'"

Danke!
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Netzlaufwerk RemoteApp auf Win 2012 R2 Terminalserver funktioniert nicht (12)

Frage von grenzde zum Thema Windows Server ...

Windows Server
gelöst Lizenzfrage durch VM Import (4)

Frage von rudeboy zum Thema Windows Server ...

Windows Server
Con2Prt funktioniert auf Windows RDS 2012 R2 nicht (1)

Frage von scout71 zum Thema Windows Server ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...