Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Index.php liefert leere Seite

Frage Internet Server

Mitglied: RaSi23

RaSi23 (Level 1) - Jetzt verbinden

17.09.2012 um 10:44 Uhr, 9415 Aufrufe, 6 Kommentare

Hallo Gemeinde,

ich habe einen neuen Debian-Server mit Apache und PHP Version 5.3.3-7+squeeze14 aufgesetzt.
Der Server dient als Ersatz Hardwaretausch) für einen alten Debian Etch.
Er arbeitet einzig als Webserver für ca 300 Domains.

- Nach der Grundinstallation habe ich alle Domains (Daten) übernommen.
- Dazu habe ich noch die php.ini vom alten System übernommen.
- Die virtuellen Hosts werden bei meiner Konfiguration gefunden
- In den jeweiligen DocRoots liegt eine index.php, die einen redirect in ein Unterverzeichnis macht
- In dem entsprechenden Unterverzeichnis liegt die eigentliche index.php

So, jetzt kommt's:

Rufe ich eine beliebige Domain auf, wird ja zuerst die index.php im docroot aufgerufen. Der Redirect funktioniert also und somit wird php auch ausgeführt. Die eigentliche index.php liefert aber nur eine leere (weiße) Seite.
Ich habe nun 6 Stunden recherchiert und nix gefunden.

Kann es sein, dass es an der unterschiedlichen PHP-Version liegt (Version auf altem Server PHP Version 5.3.2-2)

Herzlichen Dank schon mal für die Hilfe.

Rasi
Mitglied: Arano
17.09.2012 um 11:48 Uhr
Hi,

denke da eher an eine unterschiedliche PHP-Konfiguration !
Schau mal wie die Fehlerbehandlung gesetzt ist und was in den Logfiles steht.


Gruss aus der Schule
~Arano
Bitte warten ..
Mitglied: RaSi23
17.09.2012 um 12:46 Uhr
Hallo Arano,

die Logfiles geben nix her und mit der Original php.ini (habe ich natürlich vorher gesichert ) geht es auch nicht.

Sonst noch 'ne Idee?

Gruß

Rasi
Bitte warten ..
Mitglied: d4shoerncheN
17.09.2012, aktualisiert um 12:57 Uhr
Hallo, RaSi23.

Hast du dir auf deinem Webspace mal eine test.php mit folgendem Inhalt hinterlegt:

<?PHP 
phpinfo (); 
?>
und diese dann aufgerufen? Auch weiße Seite, oder bekommst du Informationen?

Ansonsten mal ein Error_Reporting einbauen
error_reporting(-1);
Falls du dich mit dem Debuggen nicht auskennst, schau mal hier rein:
http://php.net/manual/de/errorfunc.configuration.php

Auch einmal dran gedacht den APACHE neu zu starten?
/etc/init.d/apache2 restart



Gruß
Bitte warten ..
Mitglied: RaSi23
17.09.2012 um 13:14 Uhr
Hallo,

mit der test.php wird phpinfo angezeigt.
PHP selbst scheint ja zu laufen.
den Apache habe ich schon mehrfach neu gestartet (bei jeder kleinen Änderung).
Ja, ich kenne mich mit dem Debugging wirklich nicht gut aus. Ich komme eher aus der Server- und Betriebssystem-Welt

Ich habe mal die vorhandene index.php durch diese hier ersetzt:
<?php
echo "Hallo Welt";
?>

Es zeigt tatsächlich was an.
Ich denke, da müssen die Programmierer nich mal ran.
Bitte warten ..
Mitglied: d4shoerncheN
17.09.2012 um 13:17 Uhr
Hallo,

um was für Seiten handelt es sich denn? Um ein CMS-System? Dann natürlich auch daran denken die Datenbanken zu integrieren usw.

Gruß
Bitte warten ..
Mitglied: RaSi23
17.09.2012 um 13:31 Uhr
Hallo und herzlichen Dank.
Das Problem ist gelöst.
Es fehlte auf der Maschine noch xslt und curl

Aber ohne euch wäre ich nicht drauf gekommen.

Gruß Rasi
Bitte warten ..
Ähnliche Inhalte
Internet
Interessante Erkenntnisse: Zur dunklen Seite der Macht

Link von Skully zum Thema Internet ...

PHP
gelöst PHP - unique-array() und sort() (14)

Frage von ThomasXYZ zum Thema PHP ...

PHP
Homepage nach PHP Update blank (4)

Frage von ric2k17 zum Thema PHP ...

Neue Wissensbeiträge
Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Windows Server

Exchange 2010 auf Windows Server 2016 und AD

(2)

Tipp von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (22)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (16)

Frage von FA-jka zum Thema Windows 10 ...

Basic
Programmierung von Windows Programmen (10)

Frage von Ghost108 zum Thema Basic ...