Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Inhalt auf iPhone wird nicht richtig dargestellt wegen Cache von Server

Frage Microsoft Windows Server

Mitglied: Webdoktor

Webdoktor (Level 1) - Jetzt verbinden

11.08.2013 um 09:51 Uhr, 1683 Aufrufe, 8 Kommentare

Hallo zusammen

Zu Hause nutze ich einen Windows 2008 R2 Server als DNS, DHCP und Mailserver.
Wenn ich mich mit meinem iPhone über das interne Wireless verbinde, dann erhalte ich schön und gut die IP und kann surfen.

Immer wieder passiert es mir aber, dass die Apps, wie z.B. 20Minuten oder Blick (Nachrichtenapps) wie aber auch Facebook,
dann nicht mehr richtig aktualisieren d.h. die Bilder werden nicht geladen oder ganze Nachrichten werden nicht angezeigt.

Wenn ich dann über das öffentliche Internet gehe funktionieren die Apps einwandfrei.

Wenn es nicht mehr funktioniert, habe ich auch schon den DNS Cache auf dem Server gelöscht. Bin der Meinung, dass es
dann für paar Stunden wieder besser geht. Kann aber nicht 100% ausschliessen das es an dem liegt und vor allem kann ich dies
ja nicht immer manuell löschen gehen.

Hat jemand eine Ahnung, an was das liegen kann? Ich wäre über jede Antwort sehr dankbar!

Liebe Grüsse
Marco
Mitglied: aqui
11.08.2013, aktualisiert um 10:03 Uhr
Das kannst du ja ganz einfach mal querchecken indem du dem iPhone mal eine statische IP gibst wo nicht der DNS Server konfiguriert ist sondern direkt der Internet Router als DNS. Letzterer ist ja auch immer DNS Proxy.
Damit hast du quasi genau die gleichen Einstellungen wie "das öffentliche Internet" (was immer du damit meinst, denn das Internet ist ja auch in deinem WLAN "öffentlich" dzzz..)
Damit sollte es ja dann wunderbar klappen (kommt man eigentlich auch von selbst drauf)
Wenn ja hast du was falsch gemacht mit deiner DNS Weiterleitung im Server ?!
Bitte warten ..
Mitglied: Webdoktor
11.08.2013 um 10:32 Uhr
Hallo Aqui

Zuerst mal vielen Dank für Deine prompte Antwort. Ich habe das mit dem Router versucht d.h. ich habe direkt die IP-Adresse des Cablemodem angegeben bei DNS d.h. DNS ist nun die gleiche Adresse wie der Standard-Gateway. Wenn ich dies mache, geht aber gar nichts mehr. Dann komme ich mit meinem iPhone nicht mal mehr in das Internet.

Wenn ich mich aber auf die IP-Adresse 192.168.1.1 verbinde dann gibt dort das Cablemodem Antwort und ich komme auch auf das Interface.

Hmm?

LG Marco
Bitte warten ..
Mitglied: aqui
11.08.2013 um 11:16 Uhr
Das kann ja unmöglich sein !!
Dann dürfte ja logischerweise auch der gesamte Rest deines Netzwerkes nicht ins Internet kommen ! Du hängst ja so direkt am Router und das sollte immer gehen.
Entweder hast du da grundsätzlich was falsch gemacht in deinem Netz oder dein "Modem" ist wirklich nur ein reines Modem aber kein Router ?!
Kann es sein das du hier wieder laienhaft den Begriff "Modem" und "Router" durcheinanderwürfelst oder befindet sich hinter deinem Modem noch ein NAT Router ??
Bitte warten ..
Mitglied: Webdoktor
11.08.2013 um 11:27 Uhr
Hallo Aqui

Danke für Deine Antwort. Es ist definitiv ein Router. Ich verstehe es auch nicht, warum es nicht geht.

LG Marco
Bitte warten ..
Mitglied: colinardo
11.08.2013, aktualisiert um 12:34 Uhr
Hallo Marco,
trage mal bitte in den DNS-Einstellungen deiner Clients einen öffentlichen DNS-Server ein wie z.B. den von Google 8.8.8.8, wenn es dann funktioniert, hat eventuell der DNS-Proxy deines Routers einen Schuss. Hatte dieses Phänomen mal bei einer älteren Firmware eines Draytek-Routers der sich regelmäßig jede Woche mal aufgehängt hat. Entweder versuchst du dann mal durch ein Firmwareupdate des Routers das Problem in den Griff zu kriegen oder du konfigurierst in den DNS-Server-Einstellungen des Windows Server als Weiterleitungsadresse einen anderen öffentlichen DNS-Server (nicht mehr dein Gateway).

Schönen Sonntag!
Uwe
Bitte warten ..
Mitglied: Webdoktor
11.08.2013 um 17:04 Uhr
Hallo Colinardo

Vielen herzlichen Dank für Dein konstruktives Feedback. Mit diesem DNS-Server funktioniert es wie es aussieht bis jetzt perfekt.
Hmm, frage mich, ob es wirklich daran liegt, dass mein Router ein Problem hat.

Wenn ich mich auf den Router verbinde, sehe ich ja auch 3 öffentliche DNS-Adressen. Ich könnte ja auch eine von den direkt eintragen.
Dann verliere ich einfach die Redundanz - oder?

Was wäre das Problem, wenn ich einfach Google-DNS lasse?

LG Marco
Bitte warten ..
Mitglied: kn0rki
11.08.2013 um 18:57 Uhr
Google freut sich über alles was du ueber deren DNS Server aufloest und koennen ihre Statistiken ausweiten
Bitte warten ..
Mitglied: colinardo
11.08.2013, aktualisiert um 20:26 Uhr
Zitat von Webdoktor:
Wenn ich mich auf den Router verbinde, sehe ich ja auch 3 öffentliche DNS-Adressen. Ich könnte ja auch eine von den
direkt eintragen.
Du kannst diese als Forwarder-Adressen nehmen aber wenn sich die Adressen beim Provider mal ändern, musst du manuell wieder eingreifen und sie korrigieren. In den DNS-Server-Einstellungen kannst du ja mehrere Adressen angeben und erreichst so Redundanz.
Was wäre das Problem, wenn ich einfach Google-DNS lasse?
Keins, außer du traust Google nicht... Gibt auch noch diverse andere OpenDNS Server die du nehmen kannst, schmeiß einfach mal die Suche an. Nehm die mit der geringsten Latenz an deinem Anschluss.

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Exchange Server
E-Mails werden nicht richtig dargestellt (Exchange 2013) (2)

Frage von Philipp.S zum Thema Exchange Server ...

CMS
gelöst PhpMyAdmin Login-Seite wird nicht dargestellt (3)

Frage von Static zum Thema CMS ...

Netzwerke
Radius Server und IPHONE (12)

Frage von Finchen961988 zum Thema Netzwerke ...

Neue Wissensbeiträge
Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin zum Thema Vmware ...

Datenschutz

Session-Replay: Viele beliebte Webseiten zeichnen jegliche Texteingabe auf

Information von Penny.Cilin zum Thema Datenschutz ...

Sicherheit

Zufällige Speicherzuweisung: Windows-Bug hebelt Sicherheitsmechanismus ASLR aus

Information von Penny.Cilin zum Thema Sicherheit ...

Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Freigabe aus anderem Netz nicht erreichbar (44)

Frage von McLion zum Thema Router & Routing ...

Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail (24)

Frage von ahstax zum Thema Visual Studio ...

Windows Netzwerk
Netzwerk Neustrukturierung (16)

Frage von IT-Dreamer zum Thema Windows Netzwerk ...

Windows Server
RDP macht Server schneller??? (15)

Frage von JaniDJ zum Thema Windows Server ...