Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Installation von Packages hängt - egal ob via apper oder yast

Frage Linux Suse

Mitglied: diwaffm

diwaffm (Level 2) - Jetzt verbinden

01.06.2013 um 08:37 Uhr, 2672 Aufrufe, 9 Kommentare, 1 Danke

Hi Leute,

auf meinem openSUSE 12.3 Rechner möchte ich Software (hier:virtualBox) installieren.

Egal, wie ich vorgehe, ob per Suche in Yast oder per doppelklick auf das heruntergeladene .rpm-Paket oder per Klick auf "1-Klick-Installation" auf der Webseite - in allen Fällen startet die Installation und bleibt dann hängen.
Mal sofort, mal nach Installation von 2 der 5 Paketen.

Ich habe schon

zypper clean / zypper ref

durchgeführt und hatte das GEfühl, das danach ein Paket mehr installiert wurde...

Erfolgreich war die Installation aber in keinem Fall...

Any ideas?

Dirk
Mitglied: orcape
01.06.2013 um 09:14 Uhr
Hi diwaffm,

(hier:virtualBox)
...kann es sein das Du für die VM zu wenig RAM verwendest ?

Gruß orcape
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 09:18 Uhr
Zitat von orcape:
> (hier:virtualBox)
...kann es sein das Du für die VM zu wenig RAM verwendest ?


Ähm, was soll das mit der INSTALLATION von virtualBox zu tun haben?

top meint:
KiB Mem: 8193028 total, 3431172 used, 4742481 free
KiB Swap: 2104476 total, 0 used, 2104476 free

DAS sollte eigentlich genug für die Installation sein, oder?

Ciao

dirk
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 09:34 Uhr
Ich habe das jetzt noch mal genauer beobachtet:
Es sieht so aus, als hänge die Installation JEDESMAL bei

virtualbox-guest-kmp-desktop-4.2.6_k3.7.7_1,2-3.1.8.x86_64.rpm

Ciao

dirk
Bitte warten ..
Mitglied: 64748
01.06.2013 um 09:40 Uhr
Guten Morgen,

für vbox werden eigene Kernelmodule zur Verfügung gestellt. Ich weiß nicht, ob die schon im Paket enthalten sind oder auf dem System gebaut werden (wenn man das generische, also distributionsunabhängige Paket von der Oracle-Site installiert, dann werden zuerst die Module gebaut), wenn die gebaut werden müssen, dann müssen die Entwicklerwerkzeuge auf dem System vorhanden sein, als da wären (mindestens) gcc, make und Kernelheader.

Kann es sein, dass die Installation beim Erstellen der Module hängen bleibt? kannst Du mal während der Installation mit ps -e nachsehen, ob gcc und make ausgeführt werden? Ansonsten syslog.

Markus
Bitte warten ..
Mitglied: diwaffm
01.06.2013, aktualisiert um 10:54 Uhr
Wenn ich die Installation abbreche, ist danach

virtualbox-guest-kmp-default

als einige Komponente installiert.
Wenn ich das dann wieder deinstallieren will, so dauert das auch recht lange (ca. 1 Minute).

Ich habe dann mal probiert ein VirtualBox-4.1 Paket (von Oracle) zu installieren - das funktionierte.

Zumindest teilweise.
Die Verwaltungskonsole lässt sich starten.
Die VM allerdings nicht:
Hier kommt der "bewährte" Fehler mit den Kernel-Modulen.
"The VirtualBox kernel modules do not match this version of VirtualBox".

/etc/init.d/vboxdrv setup habe ich durchgeführt

hier kommt es zu einem Fehler:
"VM_RESERVED" undeclared

Kann es sein, dass da noch Reste der alten, misglückten Installtion irgendwo rumliegen und darauf zurückgegriffen wird?
Wenn ja - wie kann ich das verhindern?

Ciao

dirk
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 10:56 Uhr
Beim 4.2er Paket von Oracle läuft der Setup fehlerfrei durch.

Beim Start der VM kommt dann aber die gleiche Fehlermeldung...
Bitte warten ..
Mitglied: 64748
01.06.2013, aktualisiert um 12:35 Uhr
Der Kernel muss natürlich zur Version von vbox passen. [edit]zur Erklärung: ich meine das für ein fertiges Paket welches die fertigen Module schon mit installiert[/edit]

Lade Dir mal vbox hier die Version für "all distributions". Es ist ein Shellscript, einfach als root ausführen oder mit sudo. Dann bekommst Du auch richtige Fehlermeldungen (oder es funktioniert). Versuche, vorher die alte Installation von vbox zu deinstallieren.

Markus
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 11:13 Uhr
Merci.
Das wars.
Nun läuft die VM wieder.

Ich muss nun zwar noch ein paar Kleinigkeiten hinbekommen, wie den Autostart mit KDE (das passt irgendwie nicht mehr) - aber hauptsache ist, es läuft erst mal wieder

Ciao

dirk
Bitte warten ..
Mitglied: orcape
01.06.2013 um 12:06 Uhr
@ diwaffm

Ähm, was soll das mit der INSTALLATION von virtualBox zu tun haben?
...sorry, hatte ich wohl etwas falsch interpretiert.
Ich dachte das ganze OS läuft auf einer VM und da klappt die Installation nicht.
Deshalb meine Schlußfolgerung mit dem RAM.

Gruß orcape
Bitte warten ..
Ähnliche Inhalte
Windows Server
Installation via WDS hängt sich auf
gelöst Frage von NathalemWindows Server6 Kommentare

Hallo zusammen, ich bin seit einiger Zeit dabei in unserem Unternehmen einen WDS basierten Image Server zum laufen zu ...

Exchange Server
WIN2012R2 hängt nach Installation von Exchange 2010
gelöst Frage von Stefan007Exchange Server13 Kommentare

Hi Leute, habe in einer VM (VMware-Workstation) einen WIN2012R2 als DC laufen mit DNS und DHCP, keine Clients oder ...

Xenserver
Citrix XenServer 6.5 hängt bei der Installation
gelöst Frage von M.MarzXenserver2 Kommentare

Hallo zusammen, ich versuche den XenServer 6.5 auf der VirtualBox zu installieren. Beim starten sagt er mir "zum installieren ...

Windows 8
VMLite Xp Mode hängt sich bei der Installation auf
Frage von FragnantWindows 81 Kommentar

Mahlzeit, ich benötige einen XP Mode um auf den IE 8 zugreifen zu können. Allerdings hängt sich der VMLite ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 1 StundeWindows 101 Kommentar

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 3 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner2 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Brainstorming, einfachste Option 1 getrenntes LAN (mit WAN zugang)
Frage von 132954LAN, WAN, Wireless13 Kommentare

Hi, folgendes: Wir bekommen eine Glasfaser Leitung, Und das sollte Optional so aussehen: Ein Modem/Router für das WAN, ein ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...