Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Installation PHP auf dem IIS 6

Frage Microsoft Windows Installation

Mitglied: mark78

mark78 (Level 1) - Jetzt verbinden

19.07.2006, aktualisiert 09.08.2006, 3793 Aufrufe, 5 Kommentare

hallo zusammmen

ich bin dran PHP 5 auf unserem IIS 6 zu installieren! Auf der Defaultwebseite funktioniert es auch wunderbar. Jetzt haben wir aber im IIS natürlich einige andrere Seiten, also zusätzliche Webpages!
Bei denen funktioniert das PHP nicht.

Weiss jemand was ich evt. noch anpassen muss im php.ini oder so dass es auch auf allen anderen seiten funktioniert, oder vielleicht muss ich ja auch noch eine anpassung auf den weiteren Webpages im IIS vornehmen!

Besten Dank für Eure Hilfe!

Mark78
Mitglied: HenningD
08.08.2006 um 18:27 Uhr
Hallo,
ich habe genau das gleiche Problem. Hat mittlerweile jemand eine Lösung dafür?

Für die Default Seite funktioniert alles, für neu angelegte Seiten bekomme ich immer eine 404 Fehlerseite.

Für Hilfe wäre ich sehr dankbar!
Bitte warten ..
Mitglied: mark78
09.08.2006 um 09:44 Uhr
Hallo

Leider hat sich das problem bei mir auch noch nicht gelöst!
Habe auch das ganze nochmals durchgeführt wie es in der anleitung steht aber es kommt irgendwie nicht zum laufen!

Falls ich was neues weiss lass ich es dich wissen.
Bitte schreibe auch wenn du was neues weisst!

Gruss
Mark78
Bitte warten ..
Mitglied: HenningD
09.08.2006 um 15:07 Uhr
Hallo

Bei mir waren es 2 "Fehler". Prüf mal bei allen Webseiten nach, ob die php Erweiterung auch die gleichen Einstellungen hat wie die Default WEbseite. Bei der Default Webseite war bei mir phpisapi.dll angegeben, die neu erstellen Webseiten bezogen sich allerdings auf die php-cgi.exe. Warum auch immer.

Ausserdem musst du in der php.ini das doc_root auskommentieren. Danach hat bei mir alles einwandfrei funktioniert. PHP läuft nun auf allen eingerichteten Webseiten ohne Probleme.
Bitte warten ..
Mitglied: mark78
09.08.2006 um 18:00 Uhr
yessssssss....

das mit dem auskommentieren von der doc_root variable hat bei mir voll geholfen.

hast du dann dein wwwroot Verzeichnis auch nicht auf dem C: Laufwerk?
Ich habe es drum auf dem Laufwerk D: und ich könnte mir noch vorstellen dass das zu dem problem geführt hat. Ja nun habe ich einfach kein wert in doc_root un es funktioniert.

Gruss
Mark78
Bitte warten ..
Mitglied: HenningD
09.08.2006 um 18:53 Uhr
Also ich hab mein webroot noch auf C:

Ich denke PHP kommt einfach nicht mit den virtuellen Webseiten klar, wenn doc_root gesetzt ist und die Webseite die mit PHP laufen soll eine Ebene tiefer liegt.

Naja..zumindest funktioniert es nun, und das ist ja die Hauptsache!
Bitte warten ..
Ähnliche Inhalte
RedHat, CentOS, Fedora
PHP Installation unter CentOS 6
gelöst Frage von frank-fRedHat, CentOS, Fedora

Guten Tag allerseits, ich hoffe einer kann mir helfen. Ich versuche auf meinem V-Server mit CentOS 6 PHP zu ...

Hosting & Housing
HTTPS auf IIS 6 deaktivieren
Frage von kochi09Hosting & Housing3 Kommentare

Hallo zusammen, ich suche nach einer Lösung für folgendes Problem: ich habe eine Website auf einem alten IIS6 die ...

Informationsdienste
PHP-IIS 8 Websitefehler
Frage von BlacckyInformationsdienste2 Kommentare

Hallo liebe Forum Nutzer, Und zwar wollte ich Cloud/Mail(Website)/Forum Server jemanden zur Verfügung stellen. Für Tests habe ich die ...

CMS
TYPO3 6 PHP als Inhaltselement einfügen
Frage von TheMarcoSCMS

Hallo zusammen Ich habe folgendes Problem mit TYPO3 6 (Version 6.1.7). Grundsätzlich müsste ich vom Modul tx_news eine Listenansicht ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 5 StundenWindows 101 Kommentar

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 7 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner2 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Brainstorming, einfachste Option 1 getrenntes LAN (mit WAN zugang)
Frage von 132954LAN, WAN, Wireless13 Kommentare

Hi, folgendes: Wir bekommen eine Glasfaser Leitung, Und das sollte Optional so aussehen: Ein Modem/Router für das WAN, ein ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...