Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Installation von rrdtool schlug fehl

Frage Linux

Mitglied: JackSmith

JackSmith (Level 1) - Jetzt verbinden

11.02.2008, aktualisiert 12.02.2008, 5269 Aufrufe, 1 Kommentar

Hallo,

ich will auf meinem Notebook NMIS installieren und benötige dafür das RRDTOOL.
wenn ich es ausführen will so wie es in der Anleitung (./configure --enable-shared -prefix=/usr/local/rrdtool) teht kommt folgende Meldung:


./configure --enable-shared -prefix=/usr/local/rrdtool
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
....
....
....
checking for fpclassify... no
checking for fpclassify with <math.h>... no
checking for finite... yes
checking for isinf... yes
checking if IEEE math works out of the box... yes
checking for cgiInit in -lcgi... no
checking for pkg-config... pkg-config
checking for cgiInit in -lcgi... no
configure: WARNING:
  • I could not find a working copy of cgilib. Check config.log for hints on why
this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
so that compiler and the linker can find libcgi and its header files. If
you have not installed cgilib, you can get it either from its original home on

http://www.infodrom.org/projects/cgilib

You can find also find an archive copy on

http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/libs

The last tested version of cgilib is 0.5.

LIBS=-lm -lcgi
LDFLAGS= -L/root/cgilib-0.5
CPPFLAGS= -I/root/cgilib-0.5


checking for art_vpath_add_point in -lart_lgpl_2... yes
checking libart_lgpl/libart.h usability... yes
checking libart_lgpl/libart.h presence... yes
checking for libart_lgpl/libart.h... yes
checking for zlibVersion in -lz... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for png_access_version_number in -lpng... yes
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for FT_Init_FreeType in -lfreetype... yes
checking ft2build.h usability... yes
checking ft2build.h presence... yes
checking for ft2build.h... yes
configure: error: Please fix the library issues listed above and try again.

ich habe mal einen teil rausgenommen da es sonst zu viel gewesen wäre....
ich habe jetzt schon ein wenig gegoogelt aber habe noch nichts brauchbares gefunden....ich hab schon einige lösungsansätze gefunden aber irgendwie hat noch keiner etwas gebracht...
ich hab schon neue dateien erstell und kopiert....aber es hat nicht wirklich was geklappt...

kann mir jemand weiterhelfen? wie kann ich das problem lösen?

MfG
Jack
Mitglied: JackSmith
12.02.2008 um 11:40 Uhr
mein problem hat sich gerade gelöst...ich habs also hinbekommen...

bei dem Problem muss man unter /usr/lib/phkconfig/
eine Datei mit dem Namen cgilib.pc anlegen und folgendes reinschreiben

prefix=/root/cgilib-0.5 #Das ist der Pfad zu der heruntergeladenen Libary
exec_prefix=/root/cgilib-0.5
libdir=/root/cgilib-0.5
includedir=/root/cgilib-0.5
Name: cgilib
Description: Common Gateway Interface (CGI) Libary
Version: D_ver
libs: -L${libdir} -lcgi
cflags: -I${includedir}

dann in das cgilib verzeichnis wechsel und make && make install eingeben (libcgi.a) wird aktualisiert und dann bei den rrdtools den ./configure --enable-shared --prefix /usr/local/rrdtools eingeben und dann hat die installation bei mir funktioniert
Bitte warten ..
Ähnliche Inhalte
Firewall
Barracuda VPN Client - Installation schlägt fehl (3)

Frage von netzwerkschlumpf zum Thema Firewall ...

Windows 10
gelöst Windows 10 Pro Installation Hyper-V schlägt fehl (21)

Frage von Dominik-EUNES zum Thema Windows 10 ...

Windows Tools
gelöst DotNet Installation schlägt fehl (1)

Frage von emeriks zum Thema Windows Tools ...

Windows Server
TeamViewer 11 MSI Installation schlägt fehl (13)

Frage von Ghost108 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...

Outlook & Mail
Outlook 2010 mit Exchange 2016 (15)

Frage von slansky zum Thema Outlook & Mail ...