Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Installer meldet sich bei Aufruf eines Programmes

Frage Microsoft

Mitglied: Stoertebecker

Stoertebecker (Level 1) - Jetzt verbinden

09.01.2009, aktualisiert 08:58 Uhr, 8595 Aufrufe, 11 Kommentare

Hallo,

habe ein Problem mit einem PC. Hier wurde der "XP-Cleaner 5.8" installiert und danach wieder deinstalliert. Die Deinstallation ist wohl nicht sauber gelaufen. Es waren noch viele Reste in der Registry, etc.
Wir haben jetzt das Problem, dass sich der Installer bei einem ganz anderen Programm meldet. Wird dieses Programm gestartet, kommt der Installer und will noch etwas von "XP-Cleaner" installieren. Das gestartete Programm ist eine Individualsoftware für eine Tischlerei, hat also nichts mit XP-Clean zu tun.

Wollte den XP-Cleaner daraufhin nochmal installieren, um ihn dann nochmal sauber zu deinstallieren. Die Installation scheitert....

Habe mir dann die registry vorgenommen und alle Reste von XP-Cleaner gesucht und gelöscht. Leider ohne Erfolg.

Was kann ich noch machen?

Viele Grüße

Klaus
Mitglied: Hannes-Schurig
09.01.2009 um 09:49 Uhr
Kommt die Installation bei einem eingeschränktem Nutzer oder auch bei einem Administrator?
Was passiert in der Installation? Kommt nur ein Fortschrittsbalken der irgendwann abbricht und eine Fehlermeldung zeigt oder kommt ein richtiges Installationsfenster mit Weiter-Buttons und son Kram?

Ich kenne Verhalten dieser Art auch allerdings läuft diese Restinstallation bei mir im Administratorkonto durch und kommt dann auch nie wieder.
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 09:50 Uhr
Hallo Klaus,
schau doch mal ob du Logfiles von der fehlgeschlagenen Installation des XP Cleaners findest.
Einfach so in der Registry rumzuhandwerken reicht oft nicht / bringt mehr durcheinander.
Installationsreste gibt es oft als Verzeichnisse/Dateien an Stellen im os wo man gar nicht so schnell dran denkt.
Gruß
Michael
Bitte warten ..
Mitglied: Stoertebecker
09.01.2009 um 12:50 Uhr
Hallo,

es handelt sich um einen XP-Rechner. Benutzer ist auch Computeradministrator.

Rufe ich die Installation auf, erscheint folgende Fehlermeldung:
"Der Systemadministrator hat die Roichtlinien erlassen, um diese Installation zu verhindern..."
Benutzer ist aber Admin!

Log-Files? Wo werden welche erstellt? Kann keine finden....

Viele Grüße

Klaus
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 12:55 Uhr
Hi Klaus,
ist der Rechner in einer Domäne ?
Was ist das für ein Installationspaket (msi)?
Gruß
Michael
Bitte warten ..
Mitglied: Stoertebecker
09.01.2009 um 13:01 Uhr
Hallo,

danke für die schnelle Reaktion!!!!!

der Rechner ist ein Einzelplatzrechner. Keine Domäne.

Die Installationsdatei ist eine MSI (XPClean58.msi)

Wenn ich das Tischlerprogramm starte erscheint der Windows Installer: "Bitte warten Sie, während Windows XP-Clean konfiguriert". Dann erscheint das zweite Fenster "Fehler 1606. Zugriff auf die Netzwerkadresse war nicht möglich"Muss ein paar mal auf Abbrechen oder "X" klicken und dann startet die Anwendung un man kann normal arbeiten.

Viele Grüße

Klaus
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 13:15 Uhr
Zitat der Winfaq " ...Lösung:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders
HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders
HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

den Wert der Einträge "RECENT" (Datentyp REG_SZ) auf ein vorhandenes Verzeichnis abändern oder den Eintrag einfach löschen, nachdem man den entsprechenden Registryzweig exportiert (gesichert) hat.

Weiterhin muss der Eintrag "Eigene Dateien" auf ein gültiges Verzeichnis verweisen.

Wenn Sie eingestellt haben, dass die Historie der zuletzt genutzten Dateien bei jedem Neustart gelöscht wird (Tweak UI), werden alle Einträge in diesem Verzeichnis gelöscht. Sie sollten also entweder das Recent-Verzeichnis oder ein leeres Verzeichnis angeben.

Windows neu starten.
Wenn das nicht hilft, dann:

... kann es auch am Windows Installer liegen.

Von diesem Problem ist auch bei Office-Installationen berichtet worden. Die Ursache ist oft ein nicht korrekt deinstalliertes Office. Die Lösung brachte das Entfernen der *.msi Dateien aus dem windows\installer\ Verzeichnis, das Löschen des Temp-Verzeichnisses und aller Einträge von Office und Installer aus der Registry (!!).

Ich persönlich finde diese Lösung ziemlich kritisch, auf jeden Fall sollte man vorher eine Sicherung der Registry durchführen. ...."

Würde das mal so probieren
Bitte warten ..
Mitglied: Hannes-Schurig
09.01.2009 um 13:52 Uhr
Zitat von Stoertebecker:
Wenn ich das Tischlerprogramm starte erscheint der Windows Installer:
"Bitte warten Sie, während Windows XP-Clean
konfiguriert". Dann erscheint das zweite Fenster "Fehler
1606. Zugriff auf die Netzwerkadresse war nicht möglich"Muss
ein paar mal auf Abbrechen oder "X" klicken und dann startet
die Anwendung un man kann normal arbeiten.

SilentBob hat Recht, das Problem kommt u.A. auch bei Installationen von Office und u.U. auch bei Acrobat Installationen vor.
Der Installationsassistent sucht den Pfad ("Zugriff auf Netzwerkadresse" <- von dort wurde es wohl installiert) und findet ihn nicht. Wenn der Pfad mit den richtigen Dateien vorhanden wäre könnte der Assistent vielleicht abschließen und dann könnte man mit einer sauberen Installation das ganze beseitigen.

Wenn wir hier in der Firma Office 2003 Pro über ein Netzlaufwerk installieren und dann das Netzlaufwerk nicht vorhanden ist, wenn Office versucht sich beim ersten Start einzurichten, dann findet der Assistent diesen Pfad ins Netzwerk, von wo es installiert wurde, auch nicht. Durch mehrmaliges Abbrechen startet das Programm aber bei jedem Start versucht der Installer Office einzurichten, bis irgendwann das Verzeichnis vorliegt und er die nötigen Dateien zum konfigurieren erhält. Dann rattert er wenige Sekunden rum und Office startet ohne Fehler, in Zukunft dann auch.

Vielleicht kannst du Ähnliches in deiner Situation machen.
Bitte warten ..
Mitglied: Stoertebecker
09.01.2009 um 14:46 Uhr
Hallo,

habe die drei Punkte in der registry soeben bearbeitet. Auch TweakUI installiert und die Einstellung vorgenommen. Leider ohne Erfolg.

Einen neuen Installer habe ich auch installiert....

Leider habe ich unter Windows kein "Installer" Verzeichniss, wo ich die Datei hätte löschen können.

Die Alternative, die Installationsdatei nochmal an den Ursprungsort zu kopieren geht leider nicht. Ich habe es nicht installiert und weiß auch nicht, wo derjenige damals die Installationsdatei gespeichert hatte. Ich wurde nur gerufen um den Fehler zu beheben ála "Du kennst Dich doch mit Computern aus...." ..... Jetzt sitze ich damit

Viele Grüße

Klaus
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 14:52 Uhr
Dumme Frage hast die Ordneroption auf Ansicht für alle Dateien gestellt ? Kein Ausblenden von Systemdateien etc. ?
Gruß
Michael
Bitte warten ..
Mitglied: Hannes-Schurig
09.01.2009 um 15:00 Uhr
Und es lässt sich aus keinen Logeinträgen oder Fehlerberichten oder Fehlermeldungen ein Pfad ergattern? Meist erscheint eigentlich ein Fehler mit dem Format "Installationsdateien unter H:\Programme\XPClean nicht gefunden" oder so.
Bitte warten ..
Mitglied: Stoertebecker
10.01.2009 um 14:17 Uhr
Hallo,

habe es gestern abend hinbekommen! Lösung habe ich auf der Support-Seite von MS gefunden. Im Eventvwr konnte ich den Product-Code herauslesen. Nach diesen habe ich dann in der Regisry gesucht und die vorhandenen gelöscht. Jetzt läuft es wieder.

Danke für die Hilfe

Klaus
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...