Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Intel Pro 1000 MT Quad-Port-Teaming unter 2008R2 oder höher

Frage Netzwerke LAN, WAN, Wireless

Mitglied: C.R.S.

C.R.S. (Level 2) - Jetzt verbinden

04.09.2013 um 01:23 Uhr, 2609 Aufrufe, 6 Kommentare, 1 Danke

Hallo zusammen,

wir haben ein kleines Problem mit Kundenhardware, die nur über PCI-X-Slots verfügt:

Eigentlich sollten dort Quad-Port Intel Pro 1000 MT-Adapter im Teaming zum Einsatz kommen.
Als OS wird Windows 2008R2 oder höher benötigt.

Das unterstützt der Adapter zwar nicht offiziell, allerdings lassen sich die Erweiterten Netzwerkdienste (ANS) problemlos installieren, wenn ein Intel- anstelle des MS-Treibers vorinstalliert wird. Der Intel-Treiber wird beim Treiberupdate auch bevorzugt. Dies Konfiguration erfordert also keine "Zwangsinstallation" in irgendeiner Weise und wird auch laut einiger Foren-Berichte rege genutzt.

Bei mir allerdings scheitert das Teaming an mehreren Test-Switchen (sowohl statisch als auch dynamisch, die Switche sind schon korrekt konfiguriert), sobald mehr als zwei Adapter einbezogen werden. Bei drei oder vier Adaptern schaltet der Switch ca. alle 30 Sekunden einen Port komplett down für ca. 1-2 Sekunden.
Mit den ANS führt das zu einer inakzeptabel wackeligen Verbindung (neben normalen Pingzeiten immer mal wieder ~3000ms). Eingehend ist der Server nur sporadisch zu erreichen.
Alle ANS-Tests werden für die Einzeladapter positiv ausgeführt.

Versuchsweise habe ich Windows 2012 installiert, um die Adapter ohne ANS mit dem neueren MS-Treiber zu teamen. Dort bleibt zwar die Verbindung stabil und erreichbar, das Fehlerbild aber ansonsten das gleiche. Im dynamischen Modus wird dort eine fehlerhafte LACP-Aushandlung permanent für die Schnittstelle angezeigt, die beim Switch dann regelmäßig deaktiviert wird. Statisch gibt es keine Fehlermeldung, aber die Bandbreite des Teams geht natürlich runter, solange der Switch den Port deaktiviert.

Ich denke zwar an einen Hardware-Fehler und habe Ersatz bestellt, aber der Fehler tritt gleich bei zwei schon vorhandenen Test-Adaptern auf.

Deshalb die Frage: Hat jemand diesen Typ erfolgreich in der Konfiguration eingesetzt, so wie das Intel-Forum das suggeriert?
Oder sonst Ideen, was dahinter stecken könnte?

Vielen Dank!

Grüße
Richard
Mitglied: Dobby
04.09.2013 um 09:14 Uhr
Hallo,

das ganze klingt jetzt zwar ein wenig überzogen, aber ich denke hier treffen ein paar Sachen aufeinander die die gesamte Stabilität
des Servers beeinträchtigen und auch die Datensicherheit gefährden.

Also die Karte sollte immer vom OS unterstützt werden, auch Treiber seitig sollte die Unterstützung vorhanden sein und erst recht
wenn es um ein LAG (LACP) geht!!!

Nimm bitte lieber einen Intel PWLA8494GT Netzwerkadapter denn dieser überprüft den Bus (Steckplatz)
in dem er steckt und stellt sich zum einen selber ein, das OS Server 2008R2 wird unterstützt und die Treiber von Intel
können benutzt werden!!!

Bei mir allerdings scheitert das Teaming an mehreren Test-Switchen (sowohl statisch als auch dynamisch, die Switche sind schon korrekt konfiguriert), sobald mehr als zwei Adapter einbezogen werden. Bei drei oder vier Adaptern schaltet der Switch ca. alle 30 Sekunden einen Port komplett down für ca. 1-2 Sekunden.
Das deutet darauf hin, dass Du eine Netzwerkschleife (Network Loop) kreiert hast!
Und mit unter ist dann das Spanning Tree Protokoll (STP) daran schuld.

Wenn Du ein LAG aufsetzt bzw. anlegst ist das immer ein zweigleisige Sache, und auf beiden Seiten (Server - Switch, Switch - Switch,..)
müssen zwingend die gleichen Einstellungen vorgenommen werden! Hier mal ein Beispiel:
- RSTP - RSTP
- dynamisch - dynamisch
- LAG over LACP

Dann sollte es funktionieren, aber wie schon weiter oben angesprochen,
- wenn die Hardware nicht richtig zum Bus (Steckplatz) passt
- das OS keine richtige Unterstützung für den Adapter hat
- und mittels der Treiber nicht die richtige oder volle Funktionsweise garantiert ist

steht der Server eben auch auf wackeligen Beinen und das ist doch auch nichts halbes oder ganzes.



Denn PCI-X Setckplätze sind ja wohl vorhanden so wie Du das weiter oben geschrieben hast.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
04.09.2013 um 09:41 Uhr
Sind beide LACP Seiten bei dir im "Active" Mode ??
Du solltest dann mal je eine Seite in den Passive Mode setzen, das fixt LACP Negotiation Probleme meistens !
Bitte warten ..
Mitglied: C.R.S.
04.09.2013 um 21:44 Uhr
Hallo,

danke euch beiden!

@Dobby

Zitat von Dobby:
Nimm bitte lieber einen [http://www.alternate.de/Intel(R)/Intel(R)+PWLA8494GT,_Netzwerkadapter/html/product/48848/? Intel
PWLA8494GT Netzwerkadapter] denn dieser überprüft den Bus (Steckplatz)
in dem er steckt und stellt sich zum einen selber ein, das OS Server 2008R2 wird unterstützt und die
Treiber von Intel
können benutzt werden!!!

Neben einem MT-Ersatz warte ich gerade auf einen solchen. Meines Erachtens liegt aber der einzige Unterschied zwischen der GT- und MT-Version in der RoHS-Konformität. Die OS-Unterstützung ist laut Intel jedenfalls dieselbe wie für MT-Adapter, nämlich unter 2008R2 in Bezug auf ANS nicht gegeben.
Der "Basis-Treiber" wird jeweils schon voll unterstützt, das habe ich unpräzise ausgedrückt. Er ist nur älter als der MS-Treiber (23.09.2008 ggü. 2010). Der einzige Trick bei der Sache ist, dass das ANS-Setup den Adapter nur erkennt, wenn der Intel-Treiber schon installiert ist, und das (ANS nachinstallieren) eben nicht offiziell unterstützt ist.
Mir kam noch der Gedanke, eine ältere ANS-Version zu suchen, um keine so große Entwicklungsdiskrepanz zwischen Treiber und ANS zu haben. Habe ich bislang aber nicht verfolgt.

Wenn Du ein LAG aufsetzt bzw. anlegst ist das immer ein zweigleisige Sache, und auf beiden Seiten (Server - Switch, Switch -
Switch,..)
müssen zwingend die gleichen Einstellungen vorgenommen werden! Hier mal ein Beispiel:
- RSTP - RSTP
- dynamisch - dynamisch
- LAG over LACP

STP ist deaktiviert und Teaming mache ich eigentlich nicht zum ersten Mal.
Unsicher war ich mir bei der laut Intel-ANS "Statischen Linkaggregation": Ich gehe davon aus, dass das ein normaler 802.3ad-Modus ohne LACP ist, und keine Intel-Besonderheit (802.3ad ist in der Beschreibung nur für den dynamischen Modus explizit angegeben).
Mit zwei Adaptern funktioniert ein Team auch einwandfrei. Im LACP-Betrieb mit vier Schnittstellen kann man beim "wackeligen" Adapter das Kabel ziehen, der Fehler zieht dann auf einen der drei verbliebenen um, und das Team funktioniert, wenn man auch dort den Stecker zieht. Die Auswahl scheint egal. 2x2 läuft ebenso.


@aqui:
Auf Seiten des Switches habe ich mit Active/Passive experimentiert, ohne Erfolg. Für die Netzwerkkarte habe ich keine solche Einstellung gefunden?

Gibt es denn eine vernünftige Alternative für PCI-X-Slots? Ich habe mit einer gewissen Intel-Affinität gesucht. HP?

Danke nochmal.

Grüße
Richard
Bitte warten ..
Mitglied: Dobby
04.09.2013 um 23:08 Uhr
Hallo nochmal,

STP ist deaktiviert und Teaming mache ich eigentlich nicht zum ersten Mal.
Das will ich Dir ja auch gar nicht unterstellen, aber ich kenne es nur so, das bei einem LAG (LACP)
immer zwingend ein Form des "Spanning Tree Protocolls" (STP, RSTP, MST,..) und das auch immr
auf beiden Seiten das LAGs. Ich glaube Dir das daher nicht so recht, tut mir leid, denn die Symptome
die Du weiter oben beschrieben hast (Port flapping), weisen eher auf das Du einen Netzwerkloop kreiert hast.

Gruß
Dobby
Bitte warten ..
Mitglied: C.R.S.
05.09.2013 um 19:31 Uhr
Hallo,

nachdem ich heute Ersatz-Adapter und ein zweites Kundengerät bekommen habe, hat sich herausgestellt, dass es am Mainboard liegen muss.
Kann ich mir zwar nicht erklären, aber auf dem zweiten Board funktionieren alle NICs wie es sein soll.

Grüße
Richard
Bitte warten ..
Mitglied: Dobby
05.09.2013 um 20:42 Uhr
Kann ich mir zwar nicht erklären, aber auf dem zweiten Board funktionieren alle NICs wie es sein soll.
Na super da hättest Du ja noch lange suchen können und wärst nicht fündig geworden, aber gut
dass Du es wenigstens noch geschrieben hast.

Gruß
Dobby
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hyper-V
Windows Server 2012 R2 NIC Teaming mit Lancom Switch (2)

Frage von onkel87 zum Thema Hyper-V ...

Grafikkarten & Monitore
AMD GPU zusammen mit Intel CPU (3)

Frage von KungLao zum Thema Grafikkarten & Monitore ...

Firewall
Sophos Utm 9 Port 3000 für ProfiCash freigeben (4)

Frage von Floh21 zum Thema Firewall ...

Drucker und Scanner
USB-Drucker über virtuellen COM LPT- Port ansteuern (27)

Frage von magicman zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...