Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Internet Explorer kann WPAD nicht lesen

Frage Internet Webbrowser

Mitglied: Kaffeepause

Kaffeepause (Level 1) - Jetzt verbinden

02.09.2013 um 12:24 Uhr, 6868 Aufrufe, 9 Kommentare, 1 Danke

Hallo zusammen,

hab schon längere Zeit ein Problem, das ich zwar durch Notlösungen umgehen kann (das auch keine Top-Priorität hat), das ich aber irgendwann dann doch mal gelöst haben will, weil die Notlösungen umständlicher für meine Netzwerkverwaltung sind.

Problem:

Rechner (Win7 x64 und WinXP x86), die bereits länger im Netzwerk sind, können mit dem Internet Explorer (8, 9, 10) die WPAD.dat nicht lesen/auswerten. Frisch installierte Rechner haben damit kein Problem. Auch Firefox (portable) funktioniert über automatische Proxy-Konfigurations-URL.

Analyse:

  1. Der Name WPAD ist über PING auflös- und erreichbar
  2. Gibt man die WPAD-Adresse in der Browser-Adressleiste an: Die Adresse http://wpad:8080/wpad.dat ist erreichbar und bietet die Datei wpad.dat als Download an. Die Datei lässt sich nach dem Download im Notepad öffnen und sieht korrekt aus
  3. Die Datei WPAD landet – wenn man den Browser auf „Automatische Suche der Einstellungen – im Cache (Temporary Internet Files) und zeigt beim Öffnen mit Notepad den korrekten Inhalt

Das Problem scheint unabhängig von Gruppenrichtlinien zu sein. Das Update-/Patchlevel ist bei frisch installierten Rechnern und denjenigen, die schon länger in der Domäne (Server 2003 und Server 2008) aktiv sind, identisch.

Hintergrund:

Das Problem trat vor bereits mehr als einem Jahr über Nacht auf. Wir vermuten, dass ein damaliges Windows-/Microsoft-Update sich mit einer Einstellung beißt, die lokal auf den Clients existiert. Als Notlösung verteilen wir seitdem einen festen Proxy.

Bisher angewendete Maßnahmen:

  • Der Internet Explorer über „Extras“ – „Internetoptionen“ – „Erweitert“ – „Zurücksetzen“ zurückgesetzt – keine Besserung

  • Der Internet Explorer wurde über ein Microsoft Fixit (MicrosoftFixit50195.msi) zurückgesetzt – keine Besserung

  • Die Schnittstelle wurde über netsh-Befehle zurückgesetzt (netsh winsock reset all | netsh int ip reset | netsh int 6to4 reset all | netsh int ipv4 reset all | netsh int ipv6 reset all | netsh int httpstunnel reset all | netsh int isatap reset all | netsh int portproxy reset all | netsh int tcp reset all | netsh int teredo reset all | netsh int reset all | netsh int ip reset all) – keine Besserung

  • Der Internet Explorer wurde deinstalliert – soweit das geht – und neu installiert – keine Besserung

  • Systemdateireparatur über „sfc.exe /scannow“ wurde durchgeführt – keine Besserung

  • Der IE wurde ohne Add-Ons gestartet – keine Besserung

  • Computer- und Benutzerkonto wurden in OUs ohne GPO verschoben – keine Besserung

  • Auf Computern, auf denen die WPAD-Auswertung nicht funktioniert, wurden neue Benutzerprofile angelegt – auch unter diesen neuen Profile funktioniert die automatische Suche der Einstellungen im IE nicht


Hat jemand Ansatzpunkte? Im Internet findet man tausende von Forumseinträgen zur WPAD, aber praktisch keine, die hierzu passen oder die auch gelöst wurden.

Viele Grüße!
Die Kaffeepause
Mitglied: ollioe
02.09.2013 um 16:30 Uhr
Die WPAD wird wie verteilt? Mittels GPO?
Der Eintrag ist im DHCP eingerichtet?
Habt Ihr den GPO Cache (z.B. per Logon Script) gelöscht? Dort sammeln sich meistens veraltete und somit falsche Einträge: C:\Users\All Users\Microsoft\Group Policy\History

Ebenfalls denkbar: http://technet.microsoft.com/en-us/library/cc995158.aspx
Bitte warten ..
Mitglied: Kaffeepause
02.09.2013, aktualisiert um 18:06 Uhr
WPAD wurde in den DHCP-Optionen eingerichtet (Option 252).

GPO-Cache! Das klingt interessant! Daran hab ich noch nicht gedacht!
Wär plausibel; wir arbeiten viel mit Gruppenrichtlinien, und hin und wieder gibts im Netzwerk Änderungen.
Das würde erklären, warum neu aufgesetzte PCs das Problem nicht haben, neu installierte (über ältere Images) aber schon.
Ich wurschtel mich da mal durch und melde mich wieder.

Danke schon Mal!

PS: Blocklist ist es nicht. Diesmal. Das hatte ich früher...
Bitte warten ..
Mitglied: DerWoWusste
02.09.2013 um 23:26 Uhr
Hi.

prüf mal, wie sich andere Browser verhalten.
Bitte warten ..
Mitglied: Kaffeepause
03.09.2013 um 12:02 Uhr
Hallo,

wie ich schrieb: FirefoxPortable kann die WPAD verwenden.

Was war dein Gedanke / Ansatzpunkt?

Viele Grüße,
Bitte warten ..
Mitglied: DerWoWusste
04.09.2013, aktualisiert um 08:38 Uhr
Hatte such mal mit wpad zu kämpfen, zwar lediglich auf einem Pc, aber gleiche Symptome. Hab ihm damals Test halber den Proxy manuell eingetragen, Webseiten wurden dann aufgebaut, dann zurück zu wpad und es lief auch damit. Sehr merkwürdig. War auch der IE9, während es bei anderen ging.
Bitte warten ..
Mitglied: Kaffeepause
04.09.2013, aktualisiert um 10:06 Uhr
Eine Art lokaler GPO-Cache war es leider nicht.

Ich hab mit Administratorrechten folgende Aktionen ausgeführt, aber leider ohne Erfolg:

01.
DEL "C:\WINDOWS\security\Database\secedit.sdb" /F 
02.
 
03.
IF NOT EXIST %windir%\SysWOW64 DEL "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Group Policy\*.*" /F /S /Q 
04.
IF NOT EXIST %windir%\SysWOW64 RMDIR "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Group Policy" /S /Q 
05.
 
06.
IF EXIST %windir%\SysWOW64 DEL "C:\ProgramData\Microsoft\Group Policy\*.*" /F /S /Q 
07.
IF EXIST %windir%\SysWOW64 RMDIR "C:\ProgramData\Microsoft\Group Policy" /S /Q 
08.
 
09.
REG DELETE HKCU\SOFTWARE\Policies /f /va 
10.
REG DELETE HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies /f /va 
11.
 
12.
REG DELETE HKLM\SOFTWARE\Policies /f /va 
13.
REG DELETE HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies /f /va 
14.
 
15.
REG DELETE HKLM\SOFTWARE\Wow6432Node\Policies /f /va 
16.
REG DELETE HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Policies /f /va 
17.
 
18.
GPUPDATE /force /boot
Mittlerweile habe ich jetzt auch einige Microsoft-Kommentare gelesen, in denen die Mitarbeiter behaupten, es gäbe keinen lokalen GPO-Cache.
  1. Es gäbe eben Richtlinien, die Werte richtig verändern (die Änderungen bleiben, wenn man die GPO entfernt)
  2. und es gäbe Richtlinien, deren ursprünglichen Werte unangetastet bleiben, so dass die Ursprungseinstellung wieder greift, wenn man die GPO entfernt
Das ist soweit ja auch richtig.

Also entweder gibt es doch einen lokalen GPO-Cache, und ich habe ihn noch nicht gefunden / löschen können,
oder ich habe irgendwo durch eine alte GPO einen Registry-Wert geschrieben, der das korrekte Auslesen der WPAD im IE (alle Versionen) verhindert,
und der sich auch durch gängige Methoden (zurücksetzen / Neuinstallation / Fixit) der Browser-Reparatur nicht korrigieren lässt.

Also, leider noch offen, das Problem...

Viele Grüße!
Bitte warten ..
Mitglied: ollioe
04.09.2013, aktualisiert um 09:50 Uhr
Diesen Cache gibt es definitiv und er hat uns schon sehr viel Freude bereitet.
Wir löschen ihn per Logoff Script, das Verzeichnis lautet:
C:\Users\All Users\Microsoft\Group Policy\History
Alles darin kann beherzt beim Abmelden gelöscht werden
Bitte warten ..
Mitglied: Kaffeepause
04.09.2013 um 10:22 Uhr
Ja, vielen Dank, dass es das gibt, kann ich auch bestätigen; wird auch nicht verkehrt sein, den ab und zu (oder regelmäßig) zu leeren.

Die wpad wird leider aber immer noch nicht gelesen. Sie ist da, man kann sie herunterladen, sie ist korrekt, funktioniert im Firefox, wird nur leider von allen Internet Explorer Versionen nicht gelesen/angewendet - außer auf Maschinen, die frisch und neu (ohne Verwendung eines Images) installiert wurden.

Das macht mich ein wenig wahnsinnig, das Problem.
Bitte warten ..
Mitglied: ollioe
04.09.2013 um 10:27 Uhr
Ich denke dass Euch der Beitrag dieses geplagten und erfolgreichen Admin hilft:
http://serverfault.com/questions/54567/internet-explorer-isnt-auto-disc ...
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Windows Installation
gelöst Adobes Flash Player für den Internet Explorer schlägt mit Fehler 1722 fehl (10)

Frage von iGordon zum Thema Windows Installation ...

Windows Update
Microsoft Update Katalog ohne Internet Explorer nutzen (2)

Tipp von colinardo zum Thema Windows Update ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...